summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-08 21:16:40 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-08 21:16:40 +0000
commitb242bd7a4711074cecfba9dff71548c544c774af (patch)
tree099335cf5df87e390dd3b3559cf4cb5401c6e13b /sys-fs/e2fsprogs
parentarm/s390/sh stable (diff)
downloadgentoo-2-b242bd7a4711074cecfba9dff71548c544c774af.tar.gz
gentoo-2-b242bd7a4711074cecfba9dff71548c544c774af.tar.bz2
gentoo-2-b242bd7a4711074cecfba9dff71548c544c774af.zip
Version bump.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'sys-fs/e2fsprogs')
-rw-r--r--sys-fs/e2fsprogs/ChangeLog7
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.40.3.ebuild132
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.33
3 files changed, 141 insertions, 1 deletions
diff --git a/sys-fs/e2fsprogs/ChangeLog b/sys-fs/e2fsprogs/ChangeLog
index 113a24c316c0..75c2e43336dd 100644
--- a/sys-fs/e2fsprogs/ChangeLog
+++ b/sys-fs/e2fsprogs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/e2fsprogs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.117 2007/11/26 03:21:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/ChangeLog,v 1.118 2007/12/08 21:16:40 vapier Exp $
+
+*e2fsprogs-1.40.3 (08 Dec 2007)
+
+ 08 Dec 2007; Mike Frysinger <vapier@gentoo.org> +e2fsprogs-1.40.3.ebuild:
+ Version bump.
26 Nov 2007; Jeroen Roovers <jer@gentoo.org> e2fsprogs-1.40.2.ebuild:
Stable for HPPA (bug #200192).
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.40.3.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.40.3.ebuild
new file mode 100644
index 000000000000..dd603afae274
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.40.3.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.40.3.ebuild,v 1.1 2007/12/08 21:16:40 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static elibc_FreeBSD"
+
+RDEPEND="~sys-libs/com_err-${PV}
+ ~sys-libs/ss-${PV}
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-apps/texinfo"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix locale issues while running tests #99766
+ epatch "${FILESDIR}"/${PN}-1.38-tests-locale.patch #99766
+ epatch "${FILESDIR}"/e2fsprogs-1.39-util-strptime.patch
+ chmod u+w po/*.po # Userpriv fix #27348
+ # Clean up makefile to suck less
+ epatch "${FILESDIR}"/e2fsprogs-1.39-makefile.patch
+ epatch "${FILESDIR}"/${PN}-1.40-libintl.patch #122368
+
+ # Fix compile on FreeBSD
+ epatch "${FILESDIR}"/${PN}-1.40-fbsd.patch
+
+ # kernel headers use the same defines as e2fsprogs and can cause issues #48829
+ sed -i \
+ -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
+ $(grep -rl CONFIG_JBD_DEBUG *) \
+ || die "sed jbd debug failed"
+
+ # fake out files we forked into sep packages
+ sed -i \
+ -e '/^LIB_SUBDIRS/s:lib/et::' \
+ -e '/^LIB_SUBDIRS/s:lib/ss::' \
+ Makefile.in || die "remove subdirs"
+
+ ln -s "${ROOT}"/usr/$(get_libdir)/libcom_err.a lib/libcom_err.a
+ ln -s "${ROOT}"/$(get_libdir)/libcom_err.so lib/libcom_err.so
+ ln -s /usr/bin/mk_cmds lib/ss/mk_cmds
+ ln -s "${ROOT}"/usr/include/ss/ss_err.h lib/ss/
+ ln -s "${ROOT}"/$(get_libdir)/libss.so lib/libss.so
+
+ # sanity check for Bug 105304
+ if [[ -z ${USERLAND} ]] ; then
+ eerror "You just hit Bug 105304, please post your 'emerge info' here:"
+ eerror "http://bugs.gentoo.org/105304"
+ die "Aborting to prevent screwing your system"
+ fi
+}
+
+src_compile() {
+ # Keep the package from doing silly things
+ export LDCONFIG=:
+ export CC=$(tc-getCC)
+ export STRIP=:
+
+ econf \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --enable-elf-shlibs \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable !static dynamic-e2fsck) \
+ --without-included-gettext \
+ $(use_enable nls) \
+ $(use_enable userland_GNU fsck) \
+ || die
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+ # Parallel make sometimes fails
+ emake -j1 COMPILE_ET=compile_et || die
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake fsck_ext2fs || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README RELEASE-NOTES SHLIBS
+ docinto e2fsck
+ dodoc e2fsck/ChangeLog e2fsck/CHANGES
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
+ dolib.a lib/*.a || die "dolib.a"
+ rm -f "${D}"/usr/$(get_libdir)/libcom_err.a #125146
+ local x
+ cd "${D}"/$(get_libdir)
+ for x in *.so ; do
+ gen_usr_ldscript ${x} || die "gen ldscript ${x}"
+ done
+
+ # move 'useless' stuff to /usr/
+ dosbin "${D}"/sbin/mklost+found
+ rm -f "${D}"/sbin/mklost+found
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs || die
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # these manpages are already provided by FreeBSD libc
+ # and filefrag is linux only
+ rm -f \
+ "${D}"/sbin/filefrag \
+ "${D}"/usr/share/man/man8/filefrag.8 \
+ "${D}"/bin/uuidgen \
+ "${D}"/usr/share/man/man3/{uuid,uuid_compare}.3 \
+ "${D}"/usr/share/man/man1/uuidgen.1 || die
+ fi
+}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.3 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.3
new file mode 100644
index 000000000000..5b99f85c7b0d
--- /dev/null
+++ b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.40.3
@@ -0,0 +1,3 @@
+MD5 ad7ff4da7e200b9b25df58dc39989053 e2fsprogs-1.40.3.tar.gz 4064408
+RMD160 a49813cfaa5dc972c64119628a016b5857b7a74d e2fsprogs-1.40.3.tar.gz 4064408
+SHA256 1d4bc00e2759b29ca3051da1154bcc53d817a4190b2a7130b3241f50ee6cb00f e2fsprogs-1.40.3.tar.gz 4064408