summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-08 11:38:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-08 11:38:11 +0000
commit92f735bade80c0ba96c311bca6373718bd8106c4 (patch)
tree7cb47f6f8360f68c0fae212c5b47ba9511d81341 /sys-fs/e4rat
parentInsert 'MimeType=x-scheme-handler/http;x-scheme-handler/https;' to the .deskt... (diff)
downloadgentoo-2-92f735bade80c0ba96c311bca6373718bd8106c4.tar.gz
gentoo-2-92f735bade80c0ba96c311bca6373718bd8106c4.tar.bz2
gentoo-2-92f735bade80c0ba96c311bca6373718bd8106c4.zip
Multiple fixes. Bug #394325, #394323, #394321
(Portage version: 2.2.0_alpha82/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/e4rat')
-rw-r--r--sys-fs/e4rat/ChangeLog10
-rw-r--r--sys-fs/e4rat/e4rat-0.2.1-r2.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/sys-fs/e4rat/ChangeLog b/sys-fs/e4rat/ChangeLog
index 0f943bac820c..3c816acbf081 100644
--- a/sys-fs/e4rat/ChangeLog
+++ b/sys-fs/e4rat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/e4rat
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.3 2011/12/11 21:58:42 mgorny Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/ChangeLog,v 1.4 2012/01/08 11:38:11 hwoarang Exp $
+
+*e4rat-0.2.1-r2 (08 Jan 2012)
+
+ 08 Jan 2012; Markos Chandras <hwoarang@gentoo.org> +e4rat-0.2.1-r2.ebuild:
+ Check for CONFIG_AUDITSYSCALL (#394321). Add link to upstream documentation
+ (#394323). Add note about prelink (#394325). Move binaries to /sbin
*e4rat-0.2.1-r1 (11 Dec 2011)
diff --git a/sys-fs/e4rat/e4rat-0.2.1-r2.ebuild b/sys-fs/e4rat/e4rat-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..a64855ff88dd
--- /dev/null
+++ b/sys-fs/e4rat/e4rat-0.2.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/e4rat/e4rat-0.2.1-r2.ebuild,v 1.1 2012/01/08 11:38:11 hwoarang Exp $
+
+EAPI=4
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="Toolset to accelerate the boot process and application startup"
+HOMEPAGE="http://e4rat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=dev-libs/boost-1.42
+ sys-fs/e2fsprogs
+ sys-process/audit"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~AUDITSYSCALL"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-shared-build.patch
+ "${FILESDIR}"/${PN}-libdir.patch
+)
+
+pkg_setup() {
+ check_extra_config
+}
+
+src_install() {
+ cmake-utils_src_install
+ # relocate binaries to /sbin. If someone knows of a better way to do it
+ # please do tell me
+ dodir sbin
+ find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
+ || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Please consult the upstream wiki if you need help"
+ elog "configuring your system"
+ elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page"
+ elog
+ if has_version sys-apps/preload; then
+ elog "It appears you have sys-apps/preload installed. This may"
+ elog "has negative effects on ${PN}. You may want to disable preload"
+ elog "when using ${PN}."
+ elog "http://e4rat.sourceforge.net/wiki/index.php/Main_Page#Debian.2FUbuntu"
+ fi
+}