summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-04-02 22:48:44 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-04-02 22:48:44 +0000
commit247dd2a8a9f24830bd036b8af976bda630fc65a9 (patch)
treea2e716b2d7fab22da27c6996652bf67edd339196 /sys-fs/encfs/encfs-1.3.1.1.ebuild
parentInitial Commit. Slightly modified from the original ebuild Kia Huuhko <kia.hu... (diff)
downloadgentoo-2-247dd2a8a9f24830bd036b8af976bda630fc65a9.tar.gz
gentoo-2-247dd2a8a9f24830bd036b8af976bda630fc65a9.tar.bz2
gentoo-2-247dd2a8a9f24830bd036b8af976bda630fc65a9.zip
1.3.1.1 version bump.
(Portage version: 2.0.54)
Diffstat (limited to 'sys-fs/encfs/encfs-1.3.1.1.ebuild')
-rw-r--r--sys-fs/encfs/encfs-1.3.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/encfs/encfs-1.3.1.1.ebuild b/sys-fs/encfs/encfs-1.3.1.1.ebuild
new file mode 100644
index 000000000000..b5ee21dfd152
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.3.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.3.1.1.ebuild,v 1.1 2006/04/02 22:48:44 vanquirius Exp $
+
+inherit versionator
+
+DESCRIPTION="Encrypted Filesystem module for Linux"
+SRC_URI="http://arg0.net/users/vgough/download/${PN}-$(replace_version_separator 3 '-').tgz"
+HOMEPAGE="http://arg0.net/users/vgough/encfs.html"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="nls"
+
+DEPEND=">=dev-libs/openssl-0.9.7
+ >=sys-fs/fuse-2.5
+ >=dev-libs/rlog-1.3.6
+ nls? ( >=sys-devel/gettext-0.14.1 )"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ einfo "Please see http://arg0.net/wiki/encfs/intro2"
+ einfo "if this is your first time using encfs."
+}