summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-02-23 12:28:43 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-02-23 12:28:43 +0000
commitbdc15715045c9b35266b6510338b20d58263cfcd (patch)
tree5cf33b0a494025b4502654532caddec15ab9fbb4 /sys-fs/fuse/fuse-2.6.3.ebuild
parentDevelopment branch version bump. (diff)
downloadgentoo-2-bdc15715045c9b35266b6510338b20d58263cfcd.tar.gz
gentoo-2-bdc15715045c9b35266b6510338b20d58263cfcd.tar.bz2
gentoo-2-bdc15715045c9b35266b6510338b20d58263cfcd.zip
move variables into the right place, bug 168051
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-fs/fuse/fuse-2.6.3.ebuild')
-rw-r--r--sys-fs/fuse/fuse-2.6.3.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/sys-fs/fuse/fuse-2.6.3.ebuild b/sys-fs/fuse/fuse-2.6.3.ebuild
index 4cdcad203016..bd62b1b4896e 100644
--- a/sys-fs/fuse/fuse-2.6.3.ebuild
+++ b/sys-fs/fuse/fuse-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.1 2007/02/07 16:47:30 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.2 2007/02/23 12:28:43 genstef Exp $
inherit linux-mod eutils libtool
@@ -14,20 +14,21 @@ IUSE="kernel_linux kernel_FreeBSD"
S=${WORKDIR}/${MY_P}
PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-MODULE_NAMES="fuse(fs:${S}/kernel)"
-CONFIG_CHECK="@FUSE_FS:fuse"
-BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
-BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
-FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
-We will continue, but we wont build the module this time."
-
pkg_setup() {
if use kernel_linux ; then
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
+
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_TARGETS="all"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
}