summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-01-08 22:21:44 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-01-08 22:21:44 +0000
commitbee68dd632499f7da2f76d508d0223099652c309 (patch)
tree196fe6e1bbd20e64ed83525eda82c165071cbdd3 /sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
parentAdd ~alpha keyword. (diff)
downloadgentoo-2-bee68dd632499f7da2f76d508d0223099652c309.tar.gz
gentoo-2-bee68dd632499f7da2f76d508d0223099652c309.tar.bz2
gentoo-2-bee68dd632499f7da2f76d508d0223099652c309.zip
Added fix for bug #160975, thanks to Ed Catmur for reporting.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild')
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild27
1 files changed, 19 insertions, 8 deletions
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
index 044e77a5b1c8..9d41a34ca303 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.12 2007/01/04 18:23:05 flameeyes Exp $
-
-WANT_AUTOMAKE="latest"
-WANT_AUTOCONF="latest"
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild,v 1.13 2007/01/08 22:21:44 josejx Exp $
+WANT_AUTOMAKE=1.6
inherit autotools eutils libtool
MY_P="hfsplus_${PV}"
@@ -25,11 +23,24 @@ S=${WORKDIR}/hfsplus-${PV}
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/hfsplusutils-1.0.4-glob.patch
- epatch ${FILESDIR}/hfsplusutils-1.0.4-errno.patch
- epatch ${FILESDIR}/hfsplusutils-1.0.4-gcc4.patch
+ epatch ${FILESDIR}/${P}-glob.patch
+ epatch ${FILESDIR}/${P}-errno.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-string.patch
+ #let's avoid the Makefile.cvs since isn't working for us
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.6
+ aclocal
+ autoconf
+ autoheader
+ automake -a
+ libtoolize --force --copy
+ elibtoolize
+}
- eautoreconf
+src_compile() {
+ econf || die
+ emake || die
}
src_install() {