summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-08-02 21:43:30 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-08-02 21:43:30 +0000
commit0fe039615267792069e6d710d839712b75078428 (patch)
tree92217becf3ed80277a6288089469ceb422ae5a69 /sys-fs/jfsutils
parentMarked stable on AMD64 as requested by Gilles "eva" Dartiguelongue <eva@gento... (diff)
downloadgentoo-2-0fe039615267792069e6d710d839712b75078428.tar.gz
gentoo-2-0fe039615267792069e6d710d839712b75078428.tar.bz2
gentoo-2-0fe039615267792069e6d710d839712b75078428.zip
(non maintainer commit) Version bump for bug 267509, tested by Lars Wendler (Polynomial-C), approved to commit by Daniel Drake (dsd). bug 267509
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/jfsutils')
-rw-r--r--sys-fs/jfsutils/ChangeLog11
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.14.ebuild35
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-fs/jfsutils/ChangeLog b/sys-fs/jfsutils/ChangeLog
index 3c549f2b4b4b..db11784ce8c3 100644
--- a/sys-fs/jfsutils/ChangeLog
+++ b/sys-fs/jfsutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/jfsutils
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/jfsutils/ChangeLog,v 1.51 2009/02/06 05:38:04 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/jfsutils/ChangeLog,v 1.52 2009/08/02 21:43:30 darkside Exp $
+
+*jfsutils-1.1.14 (02 Aug 2009)
+
+ 02 Aug 2009; Jeremy Olexa <darkside@gentoo.org> +jfsutils-1.1.14.ebuild:
+ (non maintainer commit) Version bump for bug 267509, tested by Lars
+ Wendler (Polynomial-C), approved to commit by Daniel Drake (dsd). bug
+ 267509
06 Feb 2009; Jeroen Roovers <jer@gentoo.org> jfsutils-1.1.13.ebuild:
Stable for HPPA (bug #250281).
diff --git a/sys-fs/jfsutils/jfsutils-1.1.14.ebuild b/sys-fs/jfsutils/jfsutils-1.1.14.ebuild
new file mode 100644
index 000000000000..33edf7d14102
--- /dev/null
+++ b/sys-fs/jfsutils/jfsutils-1.1.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/jfsutils/jfsutils-1.1.14.ebuild,v 1.1 2009/08/02 21:43:30 darkside Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
+HOMEPAGE="http://jfs.sourceforge.net/"
+SRC_URI="http://jfs.sourceforge.net/project/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ use static && append-ldflags -static
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ rm -f "${D}"/sbin/mkfs.jfs fsck.jfs
+ dosym /sbin/jfs_mkfs /sbin/mkfs.jfs
+ dosym /sbin/jfs_fsck /sbin/fsck.jfs
+
+ dodoc AUTHORS ChangeLog NEWS README
+}