summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2008-10-31 20:57:56 +0000
committerDaniel Drake <dsd@gentoo.org>2008-10-31 20:57:56 +0000
commit422c23f290e7c1b3d1fb6a9ae406fd952e5b6120 (patch)
treefb3ec766c1f22e0cc9f3d265f19be971ac110f1c /sys-fs/jfsutils
parentRemove virtual/tetex, bug 222501. (diff)
downloadgentoo-2-422c23f290e7c1b3d1fb6a9ae406fd952e5b6120.tar.gz
gentoo-2-422c23f290e7c1b3d1fb6a9ae406fd952e5b6120.tar.bz2
gentoo-2-422c23f290e7c1b3d1fb6a9ae406fd952e5b6120.zip
Version bump, thanks to Lars in bug #237248
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo-r2 i686)
Diffstat (limited to 'sys-fs/jfsutils')
-rw-r--r--sys-fs/jfsutils/ChangeLog9
-rw-r--r--sys-fs/jfsutils/jfsutils-1.1.13.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/sys-fs/jfsutils/ChangeLog b/sys-fs/jfsutils/ChangeLog
index 63994e44395f..3c539af4ac62 100644
--- a/sys-fs/jfsutils/ChangeLog
+++ b/sys-fs/jfsutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/jfsutils
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/jfsutils/ChangeLog,v 1.42 2007/11/22 23:38:56 stefaan Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/jfsutils/ChangeLog,v 1.43 2008/10/31 20:57:56 dsd Exp $
+
+*jfsutils-1.1.13 (31 Oct 2008)
+
+ 31 Oct 2008; Daniel Drake <dsd@gentoo.org> +jfsutils-1.1.13.ebuild:
+ Version bump, thanks to Lars in bug #237248
22 Nov 2007; Stefaan De Roeck <stefaan@gentoo.org> jfsutils-1.1.12.ebuild:
Fix compilation on alpha (bug #193617)
diff --git a/sys-fs/jfsutils/jfsutils-1.1.13.ebuild b/sys-fs/jfsutils/jfsutils-1.1.13.ebuild
new file mode 100644
index 000000000000..beb0d2b4e26c
--- /dev/null
+++ b/sys-fs/jfsutils/jfsutils-1.1.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/jfsutils/jfsutils-1.1.13.ebuild,v 1.1 2008/10/31 20:57:56 dsd Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="IBM's Journaling Filesystem (JFS) Utilities"
+HOMEPAGE="http://jfs.sourceforge.net/"
+SRC_URI="http://jfs.sourceforge.net/project/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ use static && append-ldflags -static
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ rm -f "${D}"/sbin/mkfs.jfs fsck.jfs
+ dosym /sbin/jfs_mkfs /sbin/mkfs.jfs
+ dosym /sbin/jfs_fsck /sbin/fsck.jfs
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}