summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-12-21 23:27:57 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-12-21 23:27:57 +0000
commit09b85f0b996c506b4a2459cccb205593cf34d29a (patch)
tree3a15101bc1d64bb1abf32377ad8808ba7db6174e /sys-fs/lvm2
parentKeyworded ~sparc (diff)
downloadgentoo-2-09b85f0b996c506b4a2459cccb205593cf34d29a.tar.gz
gentoo-2-09b85f0b996c506b4a2459cccb205593cf34d29a.tar.bz2
gentoo-2-09b85f0b996c506b4a2459cccb205593cf34d29a.zip
Version bump.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/ChangeLog7
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.173
-rw-r--r--sys-fs/lvm2/lvm2-2.02.17.ebuild108
3 files changed, 117 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 2765bff9da4c..a177bdfcfce7 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.86 2006/09/22 00:16:14 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.87 2006/12/21 23:27:57 robbat2 Exp $
+
+*lvm2-2.02.17 (21 Dec 2006)
+
+ 21 Dec 2006; Robin H. Johnson <robbat2@gentoo.org> +lvm2-2.02.17.ebuild:
+ Version bump.
*lvm2-2.02.10 (22 Sep 2006)
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.17 b/sys-fs/lvm2/files/digest-lvm2-2.02.17
new file mode 100644
index 000000000000..d0418e097189
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.17
@@ -0,0 +1,3 @@
+MD5 a1bebdabb0dace2b9dd98579625ce53c LVM2.2.02.17.tgz 506854
+RMD160 39e74668ff009f71fa897ff03880862a6bb69dcb LVM2.2.02.17.tgz 506854
+SHA256 529722442097d8aeb0f0aced58dd708e419fbe13fb9abf5bd5beb2f232c86b89 LVM2.2.02.17.tgz 506854
diff --git a/sys-fs/lvm2/lvm2-2.02.17.ebuild b/sys-fs/lvm2/lvm2-2.02.17.ebuild
new file mode 100644
index 000000000000..c84d9318ed61
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.17.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.17.ebuild,v 1.1 2006/12/21 23:27:57 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline nolvmstatic clvm cman gulm nolvm1 nosnapshots nomirrors selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.10
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ #epatch ${FILESDIR}/lvm2-2.02.04-vgid.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+
+ if ! use nolvmstatic
+ then
+ myconf="${myconf} --enable-static_link"
+ use nosnapshots || myconf="${myconf} --with-snapshots=internal"
+ use nomirrors || myconf="${myconf} --with-mirrors=internal"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=internal"
+ fi
+ else
+ use nosnapshots || myconf="${myconf} --with-snapshots=shared"
+ use nomirrors || myconf="${myconf} --with-mirrors=shared"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=shared"
+ fi
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ if use nolvmstatic
+ then
+ myconf="${myconf} --with-cluster=shared"
+ else
+ myconf="${myconf} --with-cluster=internal"
+ fi
+ if useq cman && useq gulm; then
+ myconf="${myconf} --with-clvmd=all"
+ fi
+ if useq cman && ! useq gulm; then
+ myconf="${myconf} --with-clvmd=cman"
+ fi
+ if useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=gulm"
+ fi
+ if ! useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=none"
+ fi
+ fi
+
+ econf $(use_enable readline) $(use_enable selinux) ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin" staticdir="${D}/sbin" confdir="${D}/etc/lvm"
+ mv -f "${D}/sbin/lvm.static" "${D}/sbin/lvm"
+
+ dodoc COPYING* INSTALL README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh lvm-start.sh || die
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh || die
+ if use clvm; then
+ newinitd ${FILESDIR}/clvmd.rc clvmd || die
+ fi
+
+ ewarn "use flag nocman is deprecated and replaced"
+ ewarn "with cman and gulm use flags."
+ ewarn ""
+ ewarn "use flags clvm,cman and gulm are masked"
+ ewarn "by default and need to be unmasked to use them"
+ ewarn ""
+ ewarn "Rebuild your genkernel initramfs if you are using lvm"
+}