summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-09 02:47:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-09 02:47:44 +0000
commit1befabe39694ab848c564cf2767904e825cbd94e (patch)
treef8e067a881659be98894696afc1bcc1430adc224 /sys-fs/mdadm/mdadm-2.3.1.ebuild
parentfix segv properly (diff)
downloadgentoo-2-1befabe39694ab848c564cf2767904e825cbd94e.tar.gz
gentoo-2-1befabe39694ab848c564cf2767904e825cbd94e.tar.bz2
gentoo-2-1befabe39694ab848c564cf2767904e825cbd94e.zip
Version bump #122095 by Wolfram Schlich.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-fs/mdadm/mdadm-2.3.1.ebuild')
-rw-r--r--sys-fs/mdadm/mdadm-2.3.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/mdadm/mdadm-2.3.1.ebuild b/sys-fs/mdadm/mdadm-2.3.1.ebuild
new file mode 100644
index 000000000000..054796dcf80f
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.3.1.ebuild,v 1.1 2006/02/09 02:47:44 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~mips"
+IUSE="static"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
+ use static && append-ldflags -static
+}
+
+src_compile() {
+ emake \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ exeinto /$(get_libdir)/rcscripts/addons
+ doexe "${FILESDIR}"/raid-{start,stop}.sh || die "addon failed"
+ dodoc INSTALL TODO "ANNOUNCE-${PV}"
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm
+}