summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-28 16:31:02 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-28 16:31:02 +0000
commit4563265b3e6a393c3e39f0bc7c8936e7d01dcf9b (patch)
tree2fab6b6e8f99d26bb8496a3b6e73b7a279388b19 /sys-fs/mdadm
parentVersion bump. (diff)
downloadgentoo-2-4563265b3e6a393c3e39f0bc7c8936e7d01dcf9b.tar.gz
gentoo-2-4563265b3e6a393c3e39f0bc7c8936e7d01dcf9b.tar.bz2
gentoo-2-4563265b3e6a393c3e39f0bc7c8936e7d01dcf9b.zip
old
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-fs/mdadm')
-rw-r--r--sys-fs/mdadm/files/mdraid.rc26
-rw-r--r--sys-fs/mdadm/files/mdraid.rc-2.6.3-r326
-rwxr-xr-xsys-fs/mdadm/files/raid-start.sh55
-rw-r--r--sys-fs/mdadm/files/raid-start.sh-2.6.3-r251
-rw-r--r--sys-fs/mdadm/files/raid-start.sh-2.6.3-r451
-rw-r--r--sys-fs/mdadm/files/raid-stop.sh28
-rw-r--r--sys-fs/mdadm/mdadm-2.6.2.ebuild42
-rw-r--r--sys-fs/mdadm/mdadm-2.6.3-r1.ebuild50
-rw-r--r--sys-fs/mdadm/mdadm-2.6.3-r2.ebuild54
-rw-r--r--sys-fs/mdadm/mdadm-2.6.3-r3.ebuild54
-rw-r--r--sys-fs/mdadm/mdadm-2.6.3-r4.ebuild54
-rw-r--r--sys-fs/mdadm/mdadm-2.6.3.ebuild42
-rw-r--r--sys-fs/mdadm/mdadm-2.6.4.ebuild54
13 files changed, 0 insertions, 587 deletions
diff --git a/sys-fs/mdadm/files/mdraid.rc b/sys-fs/mdadm/files/mdraid.rc
deleted file mode 100644
index 0b53664f3103..000000000000
--- a/sys-fs/mdadm/files/mdraid.rc
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/files/mdraid.rc,v 1.2 2008/02/01 12:42:12 flameeyes Exp $
-
-depend() {
- if [ -e /lib/librc.so ]; then
- # on baselayout-1 this could cause
- # dependency-cycles with checkroot (before *)
- before checkfs fsck lvm
- fi
-}
-
-start() {
- if [ ! -e /lib/librc.so ]; then
- eerror "The ${SVCNAME} init script is written for baselayout-2"
- eerror "Please do not use it with baselayout-1"
- return 1
- fi
-
- start_addon raid
-}
-
-stop() {
- stop_addon raid
-}
diff --git a/sys-fs/mdadm/files/mdraid.rc-2.6.3-r3 b/sys-fs/mdadm/files/mdraid.rc-2.6.3-r3
deleted file mode 100644
index dab6b70d18e7..000000000000
--- a/sys-fs/mdadm/files/mdraid.rc-2.6.3-r3
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/files/mdraid.rc-2.6.3-r3,v 1.2 2008/02/01 12:42:12 flameeyes Exp $
-
-depend() {
- if [ -e /lib/librc.so ]; then
- # on baselayout-1 this could cause
- # dependency-cycles with checkroot (before *)
- before checkfs fsck
- fi
-}
-
-start() {
- if [ ! -e /lib/librc.so ]; then
- eerror "The ${SVCNAME} init script is written for baselayout-2"
- eerror "Please do not use it with baselayout-1"
- return 1
- fi
-
- start_addon raid
-}
-
-stop() {
- stop_addon raid
-}
diff --git a/sys-fs/mdadm/files/raid-start.sh b/sys-fs/mdadm/files/raid-start.sh
deleted file mode 100755
index 0ada6a8bf0a2..000000000000
--- a/sys-fs/mdadm/files/raid-start.sh
+++ /dev/null
@@ -1,55 +0,0 @@
-# /lib/rcscripts/addons/raid-start.sh: Setup raid volumes at boot
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/files/raid-start.sh,v 1.5 2006/11/10 00:27:07 vapier Exp $
-
-[[ -f /proc/mdstat ]] || exit 0
-
-# We could make this dynamic, but eh
-#[[ -z ${MAJOR} ]] && export MAJOR=$(awk '$2 == "md" { print $1 }' /proc/devices)
-MAJOR=9
-
-# Try to make sure the devices exist before we use them
-create_devs() {
- local node dir minor
- for node in $@ ; do
- [[ ${node} != /dev/* ]] && node=/dev/${node}
- [[ -e ${node} ]] && continue
-
- dir=${node%/*}
- [[ ! -d ${dir} ]] && mkdir -p "${dir}"
-
- minor=${node##*/}
- mknod "${node}" b ${MAJOR} ${minor##*md} &> /dev/null
- done
-}
-
-# Start software raid with raidtools (old school)
-if [[ -x /sbin/raidstart && -f /etc/raidtab ]] ; then
- devs=$(awk '/^[[:space:]]*raiddev/ { print $2 }' /etc/raidtab)
- if [[ -n ${devs} ]] ; then
- create_devs ${devs}
- ebegin "Starting up RAID devices (raidtools)"
- output=$(raidstart -aq 2>&1)
- ret=$?
- [[ ${ret} -ne 0 ]] && echo "${output}"
- eend ${ret}
- fi
-fi
-
-# Start software raid with mdadm (new school)
-mdadm_conf="/etc/mdadm/mdadm.conf"
-[[ -e /etc/mdadm.conf ]] && mdadm_conf="/etc/mdadm.conf"
-if [[ -x /sbin/mdadm && -f ${mdadm_conf} ]] ; then
- devs=$(awk '/^[[:space:]]*ARRAY/ { print $2 }' ${mdadm_conf})
- if [[ -n ${devs} ]] ; then
- create_devs ${devs}
- ebegin "Starting up RAID devices (mdadm)"
- output=$(mdadm -As 2>&1)
- ret=$?
- [[ ${ret} -ne 0 ]] && echo "${output}"
- eend ${ret}
- fi
-fi
-
-# vim:ts=4
diff --git a/sys-fs/mdadm/files/raid-start.sh-2.6.3-r2 b/sys-fs/mdadm/files/raid-start.sh-2.6.3-r2
deleted file mode 100644
index 0f8060df93b8..000000000000
--- a/sys-fs/mdadm/files/raid-start.sh-2.6.3-r2
+++ /dev/null
@@ -1,51 +0,0 @@
-# /lib/rcscripts/addons/raid-start.sh: Setup raid volumes at boot
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/files/raid-start.sh-2.6.3-r2,v 1.1 2007/10/03 11:58:45 robbat2 Exp $
-
-[ -f /proc/mdstat ] || exit 0
-
-# We could make this dynamic, but eh
-#[ -z ${MAJOR} ] && export MAJOR=$(awk '$2 == "md" { print $1 }' /proc/devices)
-MAJOR=9
-
-# Try to make sure the devices exist before we use them
-create_devs() {
- local node dir minor
- for node in $@ ; do
- [ "${node#/dev}" != "${node}" ] && node="/dev/${node}"
- [ -e "${node}" ] && continue
-
- dir="${node%/*}"
- [ ! -d "${dir}" ] && mkdir -p "${dir}"
-
- minor="${node##*/}"
- mknod "${node}" b ${MAJOR} "${minor##*md}" &> /dev/null
- done
-}
-
-# Start software raid with mdadm (new school)
-mdadm_conf="/etc/mdadm/mdadm.conf"
-[ -e /etc/mdadm.conf ] && mdadm_conf="/etc/mdadm.conf"
-if [ -x /sbin/mdadm -a -f "${mdadm_conf}" ] ; then
- devs="$(awk '/^[[:space:]]*ARRAY/ { print $2 }' ${mdadm_conf})"
- if [ -n "${devs}" ]; then
- create_devs ${devs}
- ebegin "Starting up RAID devices (mdadm)"
- output=$(mdadm -As 2>&1)
- ret=$?
- [ ${ret} -ne 0 ] && echo "${output}"
- eend ${ret}
- fi
-fi
-
-partitioned_devs="$(find /dev -maxdepth 1 -name 'md_d*')"
-if [ -n "${partitioned_devs}" ]; then
- ebegin "Creating RAID device partitions"
- /sbin/blockdev ${partitioned_devs}
- eend 0
- # wait because vgscan runs next, and we want udev to fire
- sleep 1
-fi
-
-# vim:ts=4
diff --git a/sys-fs/mdadm/files/raid-start.sh-2.6.3-r4 b/sys-fs/mdadm/files/raid-start.sh-2.6.3-r4
deleted file mode 100644
index 96c29952ef3a..000000000000
--- a/sys-fs/mdadm/files/raid-start.sh-2.6.3-r4
+++ /dev/null
@@ -1,51 +0,0 @@
-# /lib/rcscripts/addons/raid-start.sh: Setup raid volumes at boot
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/files/raid-start.sh-2.6.3-r4,v 1.1 2007/10/08 21:07:07 robbat2 Exp $
-
-[ -f /proc/mdstat ] || exit 0
-
-# We could make this dynamic, but eh
-#[ -z ${MAJOR} ] && export MAJOR=$(awk '$2 == "md" { print $1 }' /proc/devices)
-MAJOR=9
-
-# Try to make sure the devices exist before we use them
-create_devs() {
- local node dir minor
- for node in $@ ; do
- [ "${node#/dev}" != "${node}" ] && node="/dev/${node}"
- [ -e "${node}" ] && continue
-
- dir="${node%/*}"
- [ ! -d "${dir}" ] && mkdir -p "${dir}"
-
- minor="${node##*/}"
- mknod "${node}" b ${MAJOR} "${minor##*md}" &> /dev/null
- done
-}
-
-# Start software raid with mdadm (new school)
-mdadm_conf="/etc/mdadm/mdadm.conf"
-[ -e /etc/mdadm.conf ] && mdadm_conf="/etc/mdadm.conf"
-if [ -x /sbin/mdadm -a -f "${mdadm_conf}" ] ; then
- devs="$(awk '/^[[:space:]]*ARRAY/ { print $2 }' ${mdadm_conf})"
- if [ -n "${devs}" ]; then
- create_devs ${devs}
- ebegin "Starting up RAID devices (mdadm)"
- output=$(mdadm -As 2>&1)
- ret=$?
- [ ${ret} -ne 0 ] && echo "${output}"
- eend ${ret}
- fi
-fi
-
-partitioned_devs="$(ls /dev/md_d* 2>/dev/null)"
-if [ -n "${partitioned_devs}" ]; then
- ebegin "Creating RAID device partitions"
- /sbin/blockdev ${partitioned_devs}
- eend 0
- # wait because vgscan runs next, and we want udev to fire
- sleep 1
-fi
-
-# vim:ts=4
diff --git a/sys-fs/mdadm/files/raid-stop.sh b/sys-fs/mdadm/files/raid-stop.sh
deleted file mode 100644
index 79ca0a8e9a94..000000000000
--- a/sys-fs/mdadm/files/raid-stop.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-# /lib/rcscripts/addons/raid-stop.sh: Stop raid volumes at shutdown
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/files/raid-stop.sh,v 1.2 2006/11/10 00:27:07 vapier Exp $
-
-[[ -f /proc/mdstat ]] || exit 0
-
-# Stop software raid with raidtools (old school)
-if [[ -x /sbin/raidstop && -f /etc/raidtab ]] ; then
- ebegin "Shutting down RAID devices (raidtools)"
- output=$(raidstop -a 2>&1)
- ret=$?
- [[ ${ret} -ne 0 ]] && echo "${output}"
- eend ${ret}
-fi
-
-# Stop software raid with mdadm (new school)
-mdadm_conf="/etc/mdadm/mdadm.conf"
-[[ -e /etc/mdadm.conf ]] && mdadm_conf="/etc/mdadm.conf"
-if [[ -x /sbin/mdadm && -f ${mdadm_conf} ]] ; then
- ebegin "Shutting down RAID devices (mdadm)"
- output=$(mdadm -Ss 2>&1)
- ret=$?
- [[ ${ret} -ne 0 ]] && echo "${output}"
- eend ${ret}
-fi
-
-# vim:ts=4
diff --git a/sys-fs/mdadm/mdadm-2.6.2.ebuild b/sys-fs/mdadm/mdadm-2.6.2.ebuild
deleted file mode 100644
index ca99ec7322d2..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.2.ebuild,v 1.9 2007/07/01 11:53:06 dertobi123 Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- doexe "${FILESDIR}"/raid-{start,stop}.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die
-}
diff --git a/sys-fs/mdadm/mdadm-2.6.3-r1.ebuild b/sys-fs/mdadm/mdadm-2.6.3-r1.ebuild
deleted file mode 100644
index 2b74d104cea3..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.3-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.3-r1.ebuild,v 1.1 2007/10/02 22:02:23 cardoe Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- doexe "${FILESDIR}"/raid-{start,stop}.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die "installing mdadm.rc failed"
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die "installing mdadm.confd failed"
- newinitd "${FILESDIR}"/mdraid.rc mdraid || die "installing mdraid.rc failed"
-}
-
-pkg_postinst() {
- elog "If using baselayout-2 and not relying on kernel auto-detect"
- elog "of your RAID devices, you need to add 'mdraid' to your 'boot'"
- elog "runlevel. Run the following command:"
- elog "rc-update add mdraid boot"
-}
diff --git a/sys-fs/mdadm/mdadm-2.6.3-r2.ebuild b/sys-fs/mdadm/mdadm-2.6.3-r2.ebuild
deleted file mode 100644
index 1f1470f2b0f7..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.3-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.3-r2.ebuild,v 1.2 2007/10/03 18:23:14 mr_bones_ Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- newexe "${FILESDIR}"/raid-start.sh-2.6.3-r2 raid-start.sh || die "addon failed"
- newexe "${FILESDIR}"/raid-stop.sh-2.6.3-r2 raid-stop.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die "installing mdadm.rc failed"
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die "installing mdadm.confd failed"
- newinitd "${FILESDIR}"/mdraid.rc mdraid || die "installing mdraid.rc failed"
-
- insinto /etc/udev/rules.d/
- newins "${FILESDIR}"/64-md-raid.rules-2.6.3-r2 64-md-raid.rules || die
-}
-
-pkg_postinst() {
- elog "If using baselayout-2 and not relying on kernel auto-detect"
- elog "of your RAID devices, you need to add 'mdraid' to your 'boot'"
- elog "runlevel. Run the following command:"
- elog "rc-update add mdraid boot"
-}
diff --git a/sys-fs/mdadm/mdadm-2.6.3-r3.ebuild b/sys-fs/mdadm/mdadm-2.6.3-r3.ebuild
deleted file mode 100644
index 5dd856be430a..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.3-r3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.3-r3.ebuild,v 1.1 2007/10/04 14:27:23 cardoe Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- newexe "${FILESDIR}"/raid-start.sh-2.6.3-r2 raid-start.sh || die "addon failed"
- newexe "${FILESDIR}"/raid-stop.sh-2.6.3-r2 raid-stop.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die "installing mdadm.rc failed"
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die "installing mdadm.confd failed"
- newinitd "${FILESDIR}"/mdraid.rc-2.6.3-r3 mdraid || die "installing mdraid.rc failed"
-
- insinto /etc/udev/rules.d/
- newins "${FILESDIR}"/64-md-raid.rules-2.6.3-r2 64-md-raid.rules || die
-}
-
-pkg_postinst() {
- elog "If using baselayout-2 and not relying on kernel auto-detect"
- elog "of your RAID devices, you need to add 'mdraid' to your 'boot'"
- elog "runlevel. Run the following command:"
- elog "rc-update add mdraid boot"
-}
diff --git a/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild b/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild
deleted file mode 100644
index ba0835306d3a..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.3-r4.ebuild,v 1.1 2007/10/08 21:07:06 robbat2 Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- newexe "${FILESDIR}"/raid-start.sh-2.6.3-r4 raid-start.sh || die "addon failed"
- newexe "${FILESDIR}"/raid-stop.sh-2.6.3-r2 raid-stop.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die "installing mdadm.rc failed"
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die "installing mdadm.confd failed"
- newinitd "${FILESDIR}"/mdraid.rc-2.6.3-r4 mdraid || die "installing mdraid.rc failed"
-
- insinto /etc/udev/rules.d/
- newins "${FILESDIR}"/64-md-raid.rules-2.6.3-r2 64-md-raid.rules || die
-}
-
-pkg_postinst() {
- elog "If using baselayout-2 and not relying on kernel auto-detect"
- elog "of your RAID devices, you need to add 'mdraid' to your 'boot'"
- elog "runlevel. Run the following command:"
- elog "rc-update add mdraid boot"
-}
diff --git a/sys-fs/mdadm/mdadm-2.6.3.ebuild b/sys-fs/mdadm/mdadm-2.6.3.ebuild
deleted file mode 100644
index 747717708a18..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.3.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.3.ebuild,v 1.1 2007/09/01 03:52:40 vapier Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- doexe "${FILESDIR}"/raid-{start,stop}.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die
-}
diff --git a/sys-fs/mdadm/mdadm-2.6.4.ebuild b/sys-fs/mdadm/mdadm-2.6.4.ebuild
deleted file mode 100644
index 27b87b1dd733..000000000000
--- a/sys-fs/mdadm/mdadm-2.6.4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-2.6.4.ebuild,v 1.8 2008/02/27 15:12:24 armin76 Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
-HOMEPAGE="http://neil.brown.name/blog/mdadm"
-SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="static"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.9.0-dont-make-man.patch
- epatch "${FILESDIR}"/${PN}-2.6-syslog-updates.patch
- use static && append-ldflags -static
-}
-
-src_compile() {
- emake \
- CROSS_COMPILE=${CHOST}- \
- CWFLAGS="-Wall" \
- CXFLAGS="${CFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- exeinto /$(get_libdir)/rcscripts/addons
- newexe "${FILESDIR}"/raid-start.sh-2.6.3-r4 raid-start.sh || die "addon failed"
- newexe "${FILESDIR}"/raid-stop.sh-2.6.3-r2 raid-stop.sh || die "addon failed"
- dodoc INSTALL TODO "ANNOUNCE-${PV}"
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm || die "installing mdadm.rc failed"
- newconfd "${FILESDIR}"/mdadm.confd mdadm || die "installing mdadm.confd failed"
- newinitd "${FILESDIR}"/mdraid.rc-2.6.3-r4 mdraid || die "installing mdraid.rc failed"
-
- insinto /etc/udev/rules.d/
- newins "${FILESDIR}"/64-md-raid.rules-2.6.3-r2 64-md-raid.rules || die
-}
-
-pkg_postinst() {
- elog "If using baselayout-2 and not relying on kernel auto-detect"
- elog "of your RAID devices, you need to add 'mdraid' to your 'boot'"
- elog "runlevel. Run the following command:"
- elog "rc-update add mdraid boot"
-}