summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-29 16:03:21 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-29 16:03:21 +0000
commita883cc0c0c213f5c5cc9aeab63147c5a50dac425 (patch)
tree9359215b9f22cd7327618819553828fe8a6f32e9 /sys-fs/mtpfs/mtpfs-1.1.ebuild
parentFix implicit function declarations (diff)
downloadgentoo-2-a883cc0c0c213f5c5cc9aeab63147c5a50dac425.tar.gz
gentoo-2-a883cc0c0c213f5c5cc9aeab63147c5a50dac425.tar.bz2
gentoo-2-a883cc0c0c213f5c5cc9aeab63147c5a50dac425.zip
Dependency on libmad and libid3tag is now optional
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/mtpfs/mtpfs-1.1.ebuild')
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sys-fs/mtpfs/mtpfs-1.1.ebuild b/sys-fs/mtpfs/mtpfs-1.1.ebuild
index 510707a819fd..eeaf1b9131c7 100644
--- a/sys-fs/mtpfs/mtpfs-1.1.ebuild
+++ b/sys-fs/mtpfs/mtpfs-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/mtpfs-1.1.ebuild,v 1.2 2012/02/29 15:50:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtpfs/mtpfs-1.1.ebuild,v 1.3 2012/02/29 16:03:21 xarthisius Exp $
EAPI=4
@@ -11,13 +11,15 @@ SRC_URI="http://www.adebenham.com/files/mtp/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug"
+IUSE="debug mad"
DEPEND="dev-libs/glib:2
- media-libs/libid3tag
- media-libs/libmad
>=media-libs/libmtp-1.1.2
- sys-fs/fuse"
+ sys-fs/fuse
+ mad? (
+ media-libs/libid3tag
+ media-libs/libmad
+ )"
RDEPEND="${DEPEND}"
DOCS=(AUTHORS NEWS README)
@@ -28,7 +30,8 @@ src_prepare() {
}
src_configure() {
- econf $(use_enable debug)
+ econf $(use_enable debug) \
+ $(use_enable mad)
}
pkg_postinst() {