summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-30 04:30:50 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-30 04:30:50 +0000
commita066bf2d0fd405f3a423ed3d02d8e3df9625567d (patch)
tree45144cfdb67bff62ac2f0786099f741e5a49d331 /sys-fs/multipath-tools
parentAdd USE=readline control over readline dep. (diff)
downloadgentoo-2-a066bf2d0fd405f3a423ed3d02d8e3df9625567d.tar.gz
gentoo-2-a066bf2d0fd405f3a423ed3d02d8e3df9625567d.tar.bz2
gentoo-2-a066bf2d0fd405f3a423ed3d02d8e3df9625567d.zip
Add missing readline depepend, and drop ncurses linkage since it's only there for readline.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/ChangeLog9
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch2
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.4.9-r3.ebuild71
3 files changed, 80 insertions, 2 deletions
diff --git a/sys-fs/multipath-tools/ChangeLog b/sys-fs/multipath-tools/ChangeLog
index 6c1a5d901bd1..56a108c6447a 100644
--- a/sys-fs/multipath-tools/ChangeLog
+++ b/sys-fs/multipath-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/multipath-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.37 2011/08/06 08:12:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.38 2011/11/30 04:30:50 vapier Exp $
+
+*multipath-tools-0.4.9-r3 (30 Nov 2011)
+
+ 30 Nov 2011; Mike Frysinger <vapier@gentoo.org>
+ +multipath-tools-0.4.9-r3.ebuild, files/multipath-tools-0.4.9-build.patch:
+ Add missing readline depepend, and drop ncurses linkage since it's only
+ there for readline.
06 Aug 2011; Samuli Suominen <ssuominen@gentoo.org>
multipath-tools-0.4.8.ebuild, multipath-tools-0.4.8-r1.ebuild,
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch b/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch
index c6196f73b579..336f3468ab10 100644
--- a/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.4.9-build.patch
@@ -107,7 +107,7 @@
CFLAGS += -I$(multipathdir)
-LDFLAGS += -lpthread -ldevmapper -lreadline -lncurses -ldl \
- -lmultipath -L$(multipathdir)
-+LIBS = -lpthread -ldevmapper -lreadline -lncurses -ldl \
++LIBS = -lpthread -ldevmapper -lreadline -ldl \
+ -L$(multipathdir) -lmultipath
#
diff --git a/sys-fs/multipath-tools/multipath-tools-0.4.9-r3.ebuild b/sys-fs/multipath-tools/multipath-tools-0.4.9-r3.ebuild
new file mode 100644
index 000000000000..55c3e251707b
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.4.9-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.4.9-r3.ebuild,v 1.1 2011/11/30 04:30:50 vapier Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="http://christophe.varoqui.free.fr/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=sys-fs/lvm2-2.02.45
+ >=sys-fs/device-mapper-1.00.19-r1
+ )
+ >=sys-fs/udev-124
+ dev-libs/libaio
+ sys-libs/readline
+ !<sys-apps/baselayout-2"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4.9-build.patch
+ epatch "${FILESDIR}"/${PN}-0.4.9-buffer-overflows.patch
+ epatch "${FILESDIR}"/${PN}-0.4.8-kparted-ext-partitions.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man8
+ emake DESTDIR="${D}" install || die
+
+ insinto /etc
+ newins "${S}"/multipath.conf.annotated multipath.conf
+ fperms 644 /etc/udev/rules.d/65-multipath.rules
+ fperms 644 /etc/udev/rules.d/66-kpartx.rules
+ newinitd "${FILESDIR}"/rc-multipathd multipathd || die
+ newinitd "${FILESDIR}"/multipath.rc multipath || die
+
+ dodoc multipath.conf.* AUTHOR ChangeLog FAQ README TODO
+ docinto kpartx
+ dodoc kpartx/ChangeLog kpartx/README
+}
+
+pkg_preinst() {
+ # The dev.d script was previously wrong and is now removed (the udev rules
+ # file does the job instead), but it won't be removed from live systems due
+ # to cfgprotect.
+ # This should help out a little...
+ if [[ -e ${ROOT}/etc/dev.d/block/multipath.dev ]] ; then
+ mkdir -p "${D}"/etc/dev.d/block
+ echo "# Please delete this file. It is obsoleted by /etc/udev/rules.d/65-multipath.rules" \
+ > "${D}"/etc/dev.d/block/multipath.dev
+ fi
+}
+
+pkg_postinst() {
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+}