summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-03-27 00:28:43 +0000
committerNaohiro Aota <naota@gentoo.org>2012-03-27 00:28:43 +0000
commitc27e69651afd954ad055b337d313b1b2b306411e (patch)
tree41144f4c739ebd79e5dda9ee5ba343b9d1ee59b3 /sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild
parentDrop mtrach-test to be built. Bug #409717 (diff)
downloadgentoo-2-c27e69651afd954ad055b337d313b1b2b306411e.tar.gz
gentoo-2-c27e69651afd954ad055b337d313b1b2b306411e.tar.bz2
gentoo-2-c27e69651afd954ad055b337d313b1b2b306411e.zip
Don't strictly depend on POSIX_MQUEUE. Just check and warn for it. #396159
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild')
-rw-r--r--sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild21
1 files changed, 3 insertions, 18 deletions
diff --git a/sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild b/sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild
index 1711be46f125..84e8ddf8c8ea 100644
--- a/sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild
+++ b/sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild,v 1.4 2012/03/19 17:04:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/nilfs-utils/nilfs-utils-2.1.0.ebuild,v 1.5 2012/03/27 00:28:43 naota Exp $
EAPI=3
-inherit multilib linux-mod
+inherit multilib linux-info
DESCRIPTION="A New Implementation of a Log-structured File System for Linux"
HOMEPAGE="http://www.nilfs.org/"
@@ -19,22 +19,7 @@ RDEPEND="sys-libs/e2fsprogs-libs"
DEPEND="${DEPEND}
sys-kernel/linux-headers"
-pkg_setup() {
- linux-mod_pkg_setup
- ebegin "Checking for POSIX MQUEUE support"
- linux_chkconfig_present POSIX_MQUEUE
- eend $?
-
- if [[ $? -ne 0 ]]; then
- eerror "Plese enable POSIX Message Queues support"
- eerror
- eerror " General setup"
- eerror " [*] POSIX Message Queues"
- eerror
- eerror "and recompile your kernel ..."
- die "POSIX Message Queues support not detected!"
- fi
-}
+CONFIG_CHECK="~POSIX_MQUEUE"
src_configure() {
econf $(use_enable static-libs static)