summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-03-06 20:38:57 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-03-06 20:38:57 +0000
commit08f4bab36d7ba6c34669552f1574afa98752e8da (patch)
treecabe81d5d7653587256580f315e67e0895a26a33 /sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild
parentVersion bump; closes bug #43381. (Manifest recommit) (diff)
downloadgentoo-2-08f4bab36d7ba6c34669552f1574afa98752e8da.tar.gz
gentoo-2-08f4bab36d7ba6c34669552f1574afa98752e8da.tar.bz2
gentoo-2-08f4bab36d7ba6c34669552f1574afa98752e8da.zip
Version bump; closes bug #43421. Old version removed due to memory leaks.
Diffstat (limited to 'sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild')
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild b/sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild
new file mode 100644
index 000000000000..2a2dfddbe9cb
--- /dev/null
+++ b/sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.8.5.ebuild,v 1.1 2004/03/06 20:38:57 plasmaroo Exp $
+
+DESCRIPTION="User tools for NTFS filesystems -- includes: ntsresize, mkntfs,
+ntfsfix, ntfsdefrag"
+HOMEPAGE="http://linux-ntfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-ntfs/${P}.tar.gz"
+
+DEPEND=">sys-devel/gcc-2.95
+ >=sys-apps/sed-4
+ gnome? ( >=dev-libs/glib-2.0
+ >=gnome-base/gnome-vfs-2.0 )"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+src_compile() {
+ sed -i 's:head -1:head -n 1:g' getgccver
+ econf `use_enable gnome gnome-vfs` || die "Configure failed"
+
+ # I've added only this Makefile tweak, and we don't need
+ # the gcc patch - Quequero
+ sed -i -e "s:CFLAGS = -g -O2:CFLAGS = ${CFLAGS}:" \
+ -e "s:CPPFLAGS =:CPPFLAGS = ${CXXFLAGS}:" Makefile
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Install failed"
+ dodoc AUTHORS COPYING CREDITS ChangeLog NEWS README TODO.* \
+ doc/attribute_definitions doc/*.txt doc/tunable_settings
+
+ # A normal user cannot run ntfsfix; move it over to the right place
+ mv ${D}/usr/bin/ntfsfix ${D}/usr/sbin
+ rmdir ${D}/usr/bin
+}