summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-05-05 12:59:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-05-05 12:59:48 +0000
commitab33ccf867820f32a7b2a6ad4262e9320bec19f4 (patch)
tree5273ff93dedc1b811420d31f287746c48ec512b2 /sys-fs/ocfs2-tools
parentAdd keywords for darcs 2.8.0. [profile?] for haskell libs (part of fix for bu... (diff)
downloadgentoo-2-ab33ccf867820f32a7b2a6ad4262e9320bec19f4.tar.gz
gentoo-2-ab33ccf867820f32a7b2a6ad4262e9320bec19f4.tar.bz2
gentoo-2-ab33ccf867820f32a7b2a6ad4262e9320bec19f4.zip
[sys-fs/ocfs2-tools] Fix building with recent kernels
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ocfs2-tools')
-rw-r--r--sys-fs/ocfs2-tools/ChangeLog7
-rw-r--r--sys-fs/ocfs2-tools/files/ocfs2-tools-recent-kernels.patch19
-rw-r--r--sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild9
-rw-r--r--sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild7
4 files changed, 38 insertions, 4 deletions
diff --git a/sys-fs/ocfs2-tools/ChangeLog b/sys-fs/ocfs2-tools/ChangeLog
index 3199e13638af..58728890e1eb 100644
--- a/sys-fs/ocfs2-tools/ChangeLog
+++ b/sys-fs/ocfs2-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ocfs2-tools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ocfs2-tools/ChangeLog,v 1.7 2012/02/21 14:29:00 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ocfs2-tools/ChangeLog,v 1.8 2012/05/05 12:59:48 alexxy Exp $
+
+ 05 May 2012; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/ocfs2-tools-recent-kernels.patch, ocfs2-tools-1.6.4-r1.ebuild,
+ ocfs2-tools-1.6.4.ebuild:
+ [sys-fs/ocfs2-tools] Fix building with recent kernels
*ocfs2-tools-1.6.4-r1 (21 Feb 2012)
diff --git a/sys-fs/ocfs2-tools/files/ocfs2-tools-recent-kernels.patch b/sys-fs/ocfs2-tools/files/ocfs2-tools-recent-kernels.patch
new file mode 100644
index 000000000000..24bc40dcd09f
--- /dev/null
+++ b/sys-fs/ocfs2-tools/files/ocfs2-tools-recent-kernels.patch
@@ -0,0 +1,19 @@
+# git diff include/ocfs2-kernel/ocfs2_fs.h
+diff --git a/include/ocfs2-kernel/ocfs2_fs.h b/include/ocfs2-kernel/ocfs2_fs.h
+index 3eafb07..7bb954a 100644
+--- a/include/ocfs2-kernel/ocfs2_fs.h
++++ b/include/ocfs2-kernel/ocfs2_fs.h
+@@ -1681,11 +1681,11 @@ static inline int ocfs2_sprintf_system_inode_name(char *buf, int len,
+ return chars;
+ }
+
+-static inline void ocfs2_set_de_type(struct ocfs2_dir_entry *de,
++/*static inline void ocfs2_set_de_type(struct ocfs2_dir_entry *de,
+ umode_t mode)
+ {
+ de->file_type = ocfs2_type_by_mode[(mode & S_IFMT)>>S_SHIFT];
+-}
++}*/
+
+ static inline int ocfs2_gd_is_discontig(struct ocfs2_group_desc *gd)
+ { \ No newline at end of file
diff --git a/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild b/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild
index 7d164841dd40..9ba6562d8c30 100644
--- a/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild
+++ b/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild,v 1.1 2012/02/21 14:29:00 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4-r1.ebuild,v 1.2 2012/05/05 12:59:47 alexxy Exp $
EAPI=4
PYTHON_DEPEND="gtk? 2"
@@ -41,6 +41,11 @@ DOCS=(
MAKEOPTS+=" -j1"
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${PN}-recent-kernels.patch"
+ )
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup
@@ -51,7 +56,7 @@ src_prepare() {
sed -e 's:"/dlm/":"/sys/kernel/dlm":g' \
-i libo2dlm/o2dlm_test.c \
-i libocfs2/dlm.c || die "sed failed"
- epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch ${PATCHES[@]}
rm -f aclocal.m4
AT_M4DIR=. eautoreconf
}
diff --git a/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild b/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild
index 74109404d08f..45c797a581a9 100644
--- a/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild
+++ b/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild,v 1.2 2012/02/21 14:29:00 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ocfs2-tools/ocfs2-tools-1.6.4.ebuild,v 1.3 2012/05/05 12:59:47 alexxy Exp $
EAPI=3
PYTHON_DEPEND="gtk? 2"
@@ -40,6 +40,11 @@ DOCS=(
MAKEOPTS+=" -j1"
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+ "${FILESDIR}/${PN}-recent-kernels.patch"
+ )
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup