summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-03 18:54:30 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-03 18:54:30 +0000
commit6696e9dbf769d283763d12cd808f19a2278f604b (patch)
treebf3a48505723b90ec0985334a597dc2ffc97faa2 /sys-fs/owfs
parentContinue with bug 503174 and make sys-apps/openrc a dependency too. (diff)
downloadgentoo-2-6696e9dbf769d283763d12cd808f19a2278f604b.tar.gz
gentoo-2-6696e9dbf769d283763d12cd808f19a2278f604b.tar.bz2
gentoo-2-6696e9dbf769d283763d12cd808f19a2278f604b.zip
[QA] Revision bump. EAPI 5. Support user's CFLAGS and LDFLAGS; fixes bug #331795, reported by Diego.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sys-fs/owfs')
-rw-r--r--sys-fs/owfs/ChangeLog9
-rw-r--r--sys-fs/owfs/owfs-2.7_p21-r2.ebuild (renamed from sys-fs/owfs/owfs-2.7_p21-r1.ebuild)44
2 files changed, 35 insertions, 18 deletions
diff --git a/sys-fs/owfs/ChangeLog b/sys-fs/owfs/ChangeLog
index 232727a0a834..fe1c8c406565 100644
--- a/sys-fs/owfs/ChangeLog
+++ b/sys-fs/owfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/owfs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/ChangeLog,v 1.23 2014/03/22 18:09:30 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/ChangeLog,v 1.24 2014/04/03 18:54:30 tomwij Exp $
+
+*owfs-2.7_p21-r2 (03 Apr 2014)
+
+ 03 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +owfs-2.7_p21-r2.ebuild,
+ -owfs-2.7_p21-r1.ebuild:
+ [QA] Revision bump. EAPI 5. Support user's CFLAGS and LDFLAGS; fixes bug
+ #331795, reported by Diego.
22 Mar 2014; Michael Palimaka <kensington@gentoo.org> -owfs-2.7_p21.ebuild:
Remove old.
diff --git a/sys-fs/owfs/owfs-2.7_p21-r1.ebuild b/sys-fs/owfs/owfs-2.7_p21-r2.ebuild
index b736664381e2..d269561abb88 100644
--- a/sys-fs/owfs/owfs-2.7_p21-r1.ebuild
+++ b/sys-fs/owfs/owfs-2.7_p21-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/owfs-2.7_p21-r1.ebuild,v 1.4 2012/05/25 10:54:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/owfs-2.7_p21-r2.ebuild,v 1.1 2014/04/03 18:54:30 tomwij Exp $
+
+EAPI="5"
-EAPI="2"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
@@ -14,19 +15,23 @@ MY_P=${P/_/}
DESCRIPTION="Access 1-Wire devices like a filesystem"
SRC_URI="mirror://sourceforge/owfs/${MY_P}.tar.gz"
HOMEPAGE="http://www.owfs.org/ http://owfs.sourceforge.net/"
+
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
LICENSE="GPL-2"
+
RDEPEND="fuse? ( sys-fs/fuse )
perl? ( dev-lang/perl )
php? ( dev-lang/php )
tcl? ( dev-lang/tcl )
usb? ( virtual/libusb:0 )
zeroconf? ( net-dns/avahi[mdnsresponder-compat] )"
+
DEPEND="${RDEPEND}
perl? ( dev-lang/swig )
php? ( dev-lang/swig )
python? ( dev-lang/swig )"
-KEYWORDS="~amd64 ~arm ~x86"
-SLOT="0"
+
IUSE="debug fuse ftpd httpd parport perl php python server tcl usb zeroconf"
S=${WORKDIR}/${MY_P}
@@ -41,28 +46,31 @@ pkg_setup() {
if use php; then
require_php_cli
fi
+
if use python; then
python_pkg_setup
fi
+
enewgroup ${OWGID} 150
enewuser ${OWUID} 150 -1 -1 ${OWGID}
}
-src_unpack() {
- base_src_unpack
-}
-
src_prepare() {
- base_src_prepare
-
- sed -e 's/ \$(OWNET_SUBDIRPYTHON)//' -i module/ownet/Makefile.{am,in} || die "sed failed"
- sed -e 's/ \$(SWIG_SUBDIRPYTHON)//' -i module/swig/Makefile.{am,in} || die "sed failed"
+ sed -e 's/ \$(OWNET_SUBDIRPYTHON)//' -i module/ownet/Makefile.{am,in} || die
+ sed -e 's/ \$(SWIG_SUBDIRPYTHON)//' -i module/swig/Makefile.{am,in} || die
sed \
-e "s/@PYCFLAGS@//" \
-e "s/@PYLDFLAGS@//" \
-i module/swig/python/setup.py.in || die "sed failed"
+ # Support user's CFLAGS and LDFLAGS.
+ sed -i "s/@CPPFLAGS@/@CPPFLAGS@ ${CFLAGS}/" \
+ module/swig/perl5/OW/Makefile.linux.in || die
+ sed -i "s/@LIBS@/@LIBS@ ${LDFLAGS}/" \
+ module/swig/perl5/OW/Makefile.linux.in || die
+
epatch "${FILESDIR}/${PN}-vendordir.patch"
+
eautoreconf
}
@@ -83,7 +91,7 @@ src_configure() {
}
src_compile() {
- base_src_compile
+ default
if use python; then
pushd module/ownet/python > /dev/null
@@ -91,7 +99,7 @@ src_compile() {
popd > /dev/null
pushd module/swig/python > /dev/null
- emake ow_wrap.c || die "emake ow_wrap.c failed"
+ emake ow_wrap.c
distutils_src_compile
popd > /dev/null
fi
@@ -100,17 +108,19 @@ src_compile() {
src_test() { :; }
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README NEWS ChangeLog AUTHORS || die
+ default
+
if use server || use httpd || use ftpd || use fuse; then
diropts -m 0750 -o ${OWUID} -g ${OWGID}
dodir /var/run/owfs
+
for i in server httpd ftpd; do
if use ${i}; then
newinitd "${FILESDIR}"/ow${i}.initd ow${i}
newconfd "${FILESDIR}"/ow${i}.confd ow${i}
fi
done
+
if use fuse; then
dodir /var/lib/owfs
dodir /var/lib/owfs/mnt