summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-10-15 03:05:19 +0000
committerJeroen Roovers <jer@gentoo.org>2008-10-15 03:05:19 +0000
commitebc732f7bc99261393090b07fe753d82b838f0d4 (patch)
tree200513fdcef5b2b58ef0181ebcbc614eac8c26ca /sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
parentMarked ~hppa too. (diff)
downloadgentoo-2-ebc732f7bc99261393090b07fe753d82b838f0d4.tar.gz
gentoo-2-ebc732f7bc99261393090b07fe753d82b838f0d4.tar.bz2
gentoo-2-ebc732f7bc99261393090b07fe753d82b838f0d4.zip
Pick up CFLAGS from the environment instead of "setting them in stone" (bug #242030).
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
index 1b32258087c8..1ca24229dde6 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild,v 1.4 2008/06/28 09:13:48 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.3.ebuild,v 1.5 2008/10/15 03:05:19 jer Exp $
inherit eutils toolchain-funcs
@@ -21,7 +21,7 @@ S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i "s:-O2:${CFLAGS}:" Makefile
+ sed -i 's:-O2:$(CFLAGS):' Makefile
epatch "${FILESDIR}"/squashfs-tools-3.3-posix.patch || die patching failed
}