summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-02-08 18:25:08 +0000
committerJeroen Roovers <jer@gentoo.org>2012-02-08 18:25:08 +0000
commit8ad9592f86215c818c97651c3e562d34e2c5e271 (patch)
treed54d4ddce221490902edc92bb0fa8b069a8ec4fe /sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
parentStable for HPPA (bug #400937). (diff)
downloadgentoo-2-8ad9592f86215c818c97651c3e562d34e2c5e271.tar.gz
gentoo-2-8ad9592f86215c818c97651c3e562d34e2c5e271.tar.bz2
gentoo-2-8ad9592f86215c818c97651c3e562d34e2c5e271.zip
Change USE=lzma to USE=xz now that upstream calls it that way (bug #400939).
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
index 7bab0bb6f055..69408f5d8843 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild,v 1.4 2012/02/08 18:11:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-4.2.ebuild,v 1.5 2012/02/08 18:25:08 jer Exp $
EAPI="2"
@@ -14,13 +14,13 @@ SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-linux"
-IUSE="+gzip +lzma lzo xattr"
+IUSE="+gzip +xz lzo xattr"
RDEPEND="
gzip? ( sys-libs/zlib )
- lzma? ( app-arch/xz-utils )
+ xz? ( app-arch/xz-utils )
lzo? ( dev-libs/lzo )
- !lzma? ( !lzo? ( sys-libs/zlib ) )
+ !xz? ( !lzo? ( sys-libs/zlib ) )
xattr? ( sys-apps/attr )"
DEPEND="${RDEPEND}"
@@ -41,12 +41,12 @@ src_configure() {
einfo "You can set the default compression (gzip, xz or lzo) by exporting SQUASH_FS_DEFAULT_COMP"
if use gzip; then
def="gzip"
- elif use lzma; then
+ elif use xz; then
def="xz"
elif use lzo; then
def="lzo"
else
- die "Please set at least one of the gzip, lzma and lzo USE flags as compression algorithm."
+ die "Please set at least one of the gzip, xz and lzo USE flags as compression algorithm."
fi
fi
@@ -55,7 +55,7 @@ src_configure() {
sed -i -r \
-e "/^COMP_DEFAULT =/s:=.*:= ${def}:" \
-e "$(use_sed gzip)" \
- -e "$(use_sed lzma XZ)" \
+ -e "$(use_sed xz XZ)" \
-e "$(use_sed lzo)" \
-e "$(use_sed xattr)" \
Makefile || die
@@ -69,6 +69,6 @@ src_install() {
pkg_postinst() {
ewarn "This version of mksquashfs requires a 2.6.29 kernel or better"
- use lzma &&
+ use xz &&
ewarn "XZ support requires a 2.6.38 kernel or better"
}