summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 17:11:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 17:11:37 +0000
commit41ce19b34421d9b5c269c0d2bef2b786e5ffe754 (patch)
tree0d7d4d8c810da25ca3fb31a5ed634607cf621e58 /sys-fs/udisks
parentalpha/ia64/s390/sh/sparc stable wrt #350835 (diff)
downloadgentoo-2-41ce19b34421d9b5c269c0d2bef2b786e5ffe754.tar.gz
gentoo-2-41ce19b34421d9b5c269c0d2bef2b786e5ffe754.tar.bz2
gentoo-2-41ce19b34421d9b5c269c0d2bef2b786e5ffe754.zip
Fix building with Linux >= 2.6.36 wrt #352335.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/udisks')
-rw-r--r--sys-fs/udisks/ChangeLog8
-rw-r--r--sys-fs/udisks/files/udisks-1.0.1-linux-headers-2.6.36.patch42
-rw-r--r--sys-fs/udisks/udisks-1.0.1-r1.ebuild7
3 files changed, 52 insertions, 5 deletions
diff --git a/sys-fs/udisks/ChangeLog b/sys-fs/udisks/ChangeLog
index c901c6b097c2..529096f4581a 100644
--- a/sys-fs/udisks/ChangeLog
+++ b/sys-fs/udisks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/udisks
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/ChangeLog,v 1.23 2010/12/02 15:39:13 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/ChangeLog,v 1.24 2011/01/29 17:11:37 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> udisks-1.0.1-r1.ebuild,
+ +files/udisks-1.0.1-linux-headers-2.6.36.patch:
+ Fix building with Linux >= 2.6.36 wrt #352335.
*udisks-1.0.2 (02 Dec 2010)
diff --git a/sys-fs/udisks/files/udisks-1.0.1-linux-headers-2.6.36.patch b/sys-fs/udisks/files/udisks-1.0.1-linux-headers-2.6.36.patch
new file mode 100644
index 000000000000..4097a72b12f7
--- /dev/null
+++ b/sys-fs/udisks/files/udisks-1.0.1-linux-headers-2.6.36.patch
@@ -0,0 +1,42 @@
+http://cgit.freedesktop.org/udisks/commit/?id=1f97cf90f30a6184486cee8877494eb828a34da4
+
+--- src/device.c
++++ src/device.c
+@@ -36,6 +36,7 @@
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <grp.h>
++#include <stdint.h>
+ #include <linux/fs.h>
+ #include <sys/ioctl.h>
+ #include <linux/cdrom.h>
+--- src/helpers/job-drive-benchmark.c
++++ src/helpers/job-drive-benchmark.c
+@@ -28,6 +28,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
++#include <stdint.h>
+ #include <linux/fs.h>
+ #include <fcntl.h>
+ #include <string.h>
+--- src/helpers/job-shared.h
++++ src/helpers/job-shared.h
+@@ -30,6 +30,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <sys/ioctl.h>
++#include <stdint.h>
+ #include <linux/fs.h>
+
+ #include <glib.h>
+--- src/helpers/partutil.c
++++ src/helpers/partutil.c
+@@ -34,6 +34,7 @@
+ #include <errno.h>
+ #include <sys/ioctl.h>
+ #include <ctype.h>
++#include <stdint.h>
+ #include <linux/fs.h>
+
+ #include <linux/hdreg.h>
diff --git a/sys-fs/udisks/udisks-1.0.1-r1.ebuild b/sys-fs/udisks/udisks-1.0.1-r1.ebuild
index e7d61cca0143..9ba06545bd42 100644
--- a/sys-fs/udisks/udisks-1.0.1-r1.ebuild
+++ b/sys-fs/udisks/udisks-1.0.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/udisks-1.0.1-r1.ebuild,v 1.10 2010/10/29 06:24:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/udisks-1.0.1-r1.ebuild,v 1.11 2011/01/29 17:11:37 ssuominen Exp $
EAPI=3
inherit eutils bash-completion
@@ -38,7 +38,8 @@ DEPEND="${COMMON_DEPEND}
RESTRICT="test"
src_prepare() {
- epatch "${FILESDIR}"/${P}-lvm2_api_support.patch
+ epatch "${FILESDIR}"/${P}-lvm2_api_support.patch \
+ "${FILESDIR}"/${P}-linux-headers-2.6.36.patch
}
src_configure() {