summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-10-15 13:43:49 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-10-15 13:43:49 +0000
commit95ae3cae84e346daf6eed0bcaafee92bb3f4f7d6 (patch)
tree9aaecfdcf3608340bc8ef4c6be59cb37b8e045f5 /sys-fs/unionfs/unionfs-1.0.14.ebuild
parentStable on alpha wrt security bug #109094 (diff)
downloadgentoo-2-95ae3cae84e346daf6eed0bcaafee92bb3f4f7d6.tar.gz
gentoo-2-95ae3cae84e346daf6eed0bcaafee92bb3f4f7d6.tar.bz2
gentoo-2-95ae3cae84e346daf6eed0bcaafee92bb3f4f7d6.zip
Version bump thanks to Alexander Skwar <askwar@digitalprojects.com> in bug 104702
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'sys-fs/unionfs/unionfs-1.0.14.ebuild')
-rw-r--r--sys-fs/unionfs/unionfs-1.0.14.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-fs/unionfs/unionfs-1.0.14.ebuild b/sys-fs/unionfs/unionfs-1.0.14.ebuild
new file mode 100644
index 000000000000..01650de54888
--- /dev/null
+++ b/sys-fs/unionfs/unionfs-1.0.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/unionfs/unionfs-1.0.14.ebuild,v 1.1 2005/10/15 13:43:49 genstef Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable unification file system, which can appear to merge the contents of several directories"
+HOMEPAGE="http://www.fsl.cs.sunysb.edu/project-unionfs.html"
+SRC_URI="ftp://ftp.fsl.cs.sunysb.edu/pub/unionfs/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="acl debug"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ MODULE_NAMES="unionfs(fs:)"
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="LINUXSRC=${KV_DIR} KERNELVERSION=${KV_MAJOR}.${KV_MINOR}"
+}
+
+src_unpack() {
+ local user_Makefile=fistdev.mk EXTRACFLAGS=""
+
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/unionfs-1.0.13-amd64.patch
+ epatch ${FILESDIR}/unionfs-1.0.14-remove_call_to_ctags.patch
+
+ if ! use debug; then
+ echo "UNIONFS_DEBUG_CFLAG=" >> ${user_Makefile}
+ EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_NDEBUG"
+ fi
+
+ use acl && EXTRACFLAGS="${EXTRACFLAGS} -DUNIONFS_XATTR" # -DFIST_SETXATTR_CONSTVOID"
+
+ echo "EXTRACFLAGS=${EXTRACFLAGS}" >> ${user_Makefile}
+}
+
+src_install() {
+ dosbin unionctl uniondbg unionimap snapmerge
+ doman man/unionfs.4 man/unionctl.8 man/uniondbg.8 man/unionimap.8
+
+ linux-mod_src_install
+
+ dodoc INSTALL NEWS README ChangeLog patch-kernel.sh
+}
+