summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-08-11 14:58:48 +0000
committerPeter Volkov <pva@gentoo.org>2010-08-11 14:58:48 +0000
commit4e325c599e0d48f49d49778f1609e25ecf7fce76 (patch)
tree95b021a4ea9c235f2ebd0ce91843d2f5139fec77 /sys-fs/vhba
parentRespect LDFLAGS, CFLAGS, and CC (Bug #332227) (diff)
downloadgentoo-2-4e325c599e0d48f49d49778f1609e25ecf7fce76.tar.gz
gentoo-2-4e325c599e0d48f49d49778f1609e25ecf7fce76.tar.bz2
gentoo-2-4e325c599e0d48f49d49778f1609e25ecf7fce76.zip
Fix udev deprecation warning, bug #304267, thank haarp for report. Fix build problem on hppa, thank Jeroen Roovers for report and fix in bug #305893.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/ChangeLog9
-rw-r--r--sys-fs/vhba/vhba-1.2.1_p682.ebuild62
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-fs/vhba/ChangeLog b/sys-fs/vhba/ChangeLog
index 29f7388acb57..92f596c3a3d1 100644
--- a/sys-fs/vhba/ChangeLog
+++ b/sys-fs/vhba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/vhba
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.17 2010/04/26 19:40:36 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.18 2010/08/11 14:58:48 pva Exp $
+
+*vhba-1.2.1_p682 (11 Aug 2010)
+
+ 11 Aug 2010; Peter Volkov <pva@gentoo.org> +vhba-1.2.1_p682.ebuild:
+ Fix udev deprecation warning, bug #304267, thank haarp for report. Fix
+ build problem on hppa, thank Jeroen Roovers for report and fix in bug
+ #305893.
26 Apr 2010; Peter Volkov <pva@gentoo.org>
+files/vhba-1.2.1-kernel-2.6.34.patch:
diff --git a/sys-fs/vhba/vhba-1.2.1_p682.ebuild b/sys-fs/vhba/vhba-1.2.1_p682.ebuild
new file mode 100644
index 000000000000..b153b3ba215c
--- /dev/null
+++ b/sys-fs/vhba/vhba-1.2.1_p682.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.2.1_p682.ebuild,v 1.1 2010/08/11 14:58:48 pva Exp $
+
+# Use svn snapshots:
+# https://sourceforge.net/tracker/?func=detail&atid=603423&aid=3041832&group_id=93175
+# "As for the release, could you package the SVN version instead? I'd prefer
+# if people used latest SVN at any time anyway..." -- Upstream
+
+EAPI="2"
+
+inherit linux-mod eutils
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="VHBA module provides Virtual (SCSI) Host Bus Adapter for the cdemu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/linux-sources-2.6.19"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=all
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/1.2.1-parallel_build.patch" \
+ "${FILESDIR}/1.2.1-kerneldir.patch"
+}
+
+src_install() {
+ linux-mod_src_install || die "Error: installing module failed!"
+
+ einfo "Generating udev rules ..."
+ dodir /etc/udev/rules.d/
+ cat > "${D}"/etc/udev/rules.d/70-vhba.rules <<-EOF || die
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", MODE="0660", OWNER="root", GROUP="cdemu"
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup cdemu
+
+ elog "Don't forget to add your user to the cdemu group"
+ elog "if you want to be able to use virtual cdemu devices."
+ linux-mod_pkg_postinst
+}