summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-03-12 07:59:38 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-03-12 07:59:38 +0000
commitea6f03bb2c65fc6ad748fc10aa777f25703a9411 (patch)
tree6beff92b7851c86c6bb26dd58d6377bda9689927 /sys-fs/vhba
parentUse EAPI=2, removed non-existing TODO, fixed broken DEPEND=${DEPEND}. (diff)
downloadgentoo-2-ea6f03bb2c65fc6ad748fc10aa777f25703a9411.tar.gz
gentoo-2-ea6f03bb2c65fc6ad748fc10aa777f25703a9411.tar.bz2
gentoo-2-ea6f03bb2c65fc6ad748fc10aa777f25703a9411.zip
Version bump (bug #255743, should also fix #233910 and #233102), general ebuild cleanup.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/ChangeLog11
-rw-r--r--sys-fs/vhba/files/1.2.1-parallel_build.patch17
-rw-r--r--sys-fs/vhba/vhba-1.2.1.ebuild57
3 files changed, 83 insertions, 2 deletions
diff --git a/sys-fs/vhba/ChangeLog b/sys-fs/vhba/ChangeLog
index caa5cedd7ce9..3bd8cf5d818d 100644
--- a/sys-fs/vhba/ChangeLog
+++ b/sys-fs/vhba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/vhba
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.9 2008/11/16 01:24:38 vanquirius Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/ChangeLog,v 1.10 2009/03/12 07:59:38 dev-zero Exp $
+
+*vhba-1.2.1 (12 Mar 2009)
+
+ 12 Mar 2009; Tiziano Müller <dev-zero@gentoo.org>
+ +files/1.2.1-parallel_build.patch, +vhba-1.2.1.ebuild:
+ Version bump (bug #255743, should also fix #233910 and #233102), general
+ ebuild cleanup.
16 Nov 2008; Marcelo Goes <vanquirius@gentoo.org> vhba-1.1.0.ebuild:
Build against sources in /usr/src/linux instead of /lib/modules/uname -r for
diff --git a/sys-fs/vhba/files/1.2.1-parallel_build.patch b/sys-fs/vhba/files/1.2.1-parallel_build.patch
new file mode 100644
index 000000000000..2de83a56375f
--- /dev/null
+++ b/sys-fs/vhba/files/1.2.1-parallel_build.patch
@@ -0,0 +1,17 @@
+--- vhba-module-1.2.1/Makefile.orig 2009-03-12 07:27:57.162795736 +0100
++++ vhba-module-1.2.1/Makefile 2009-03-12 07:28:11.929429127 +0100
+@@ -12,12 +12,12 @@
+ KDIR := /lib/modules/$(KERNELRELEASE)/build
+ KMAKE := $(MAKE) -C $(KDIR) M=$(PWD)
+
+-all: kernel.api.h modules
++all: modules
+
+ kernel.api.h: kat/*.c
+ kat/kat ${KDIR} $@ $^
+
+-modules:
++modules: kernel.api.h
+ $(KMAKE) modules
+
+ module_install:
diff --git a/sys-fs/vhba/vhba-1.2.1.ebuild b/sys-fs/vhba/vhba-1.2.1.ebuild
new file mode 100644
index 000000000000..749c9484fa73
--- /dev/null
+++ b/sys-fs/vhba/vhba-1.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vhba/vhba-1.2.1.ebuild,v 1.1 2009/03/12 07:59:38 dev-zero Exp $
+
+EAPI="2"
+
+inherit linux-info linux-mod eutils
+
+DESCRIPTION="VHBA module provides Virtual (SCSI) Host Bus Adapter for the cdemu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/vhba-module-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/linux-sources-2.6.19"
+RDEPEND=""
+
+S="${WORKDIR}/vhba-module-${PV}"
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-parallel_build.patch"
+ sed -i \
+ -e "s:/lib/modules/\$(KERNELRELEASE)/build:${KERNEL_DIR}:g" \
+ Makefile || die "sed failed"
+}
+
+src_install() {
+ KV_OBJ="ko"
+ linux-mod_src_install || die "Error: installing module failed!"
+ UDEV_RULES="/etc/udev/rules.d/70-vhba.rules"
+ einfo "Generating UDEV-rules ..."
+ mkdir -p "${D}"/${UDEV_RULES%/*}
+ echo -e "# do not edit this file, it will be overwritten on update\n#" \
+ > "${D}"/${UDEV_RULES}
+ echo -e "KERNEL==\"vhba_ctl\", NAME=\"%k\", MODE=\"0660\", OWNER=\"root\",GROUP=\"cdemu\"" >> "${D}"/${UDEV_RULES}
+}
+
+pkg_postinst() {
+ einfo "Generating cdemu group ..."
+ enewgroup cdemu
+
+ elog "Don't forget to add your user to the cdemu group "
+ elog "if you want to be able to use virtual cdemu devices."
+ linux-mod_pkg_postinst
+}