summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-06 04:50:58 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-06 04:50:58 +0000
commit4ba742072d4acac0b9961fa7df6954774c6f34ad (patch)
tree38cd2538a603493b87cad31a690fc3ae4dc0e236 /sys-fs/xfsdump/xfsdump-3.0.6.ebuild
parentBump to 3.2.1 from the gnome overlay, drop old. Minor fixes. (diff)
downloadgentoo-2-4ba742072d4acac0b9961fa7df6954774c6f34ad.tar.gz
gentoo-2-4ba742072d4acac0b9961fa7df6954774c6f34ad.tar.bz2
gentoo-2-4ba742072d4acac0b9961fa7df6954774c6f34ad.zip
Version bump, and fix fortify overflows #370949 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-3.0.6.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-3.0.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-3.0.6.ebuild b/sys-fs/xfsdump/xfsdump-3.0.6.ebuild
new file mode 100644
index 000000000000..7e4315384a90
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.0.6.ebuild,v 1.1 2011/11/06 04:50:58 vapier Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ !<sys-fs/xfsprogs-3
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+ epatch "${FILESDIR}"/${PN}-3.0.6-path-overflow.patch #370949
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install || die
+ prepalldocs
+}