summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2013-03-28 22:19:35 +0000
committerRichard Yao <ryao@gentoo.org>2013-03-28 22:19:35 +0000
commit386ba560f31d6ba6a6774bc3a4d907d17922179b (patch)
treedb08b67683240eff62357d74238f5aed4ad3acc2 /sys-fs/zfs-kmod
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-386ba560f31d6ba6a6774bc3a4d907d17922179b.tar.gz
gentoo-2-386ba560f31d6ba6a6774bc3a4d907d17922179b.tar.bz2
gentoo-2-386ba560f31d6ba6a6774bc3a4d907d17922179b.zip
Version bump to 0.6.1
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'sys-fs/zfs-kmod')
-rw-r--r--sys-fs/zfs-kmod/ChangeLog8
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.6.1.ebuild122
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild35
3 files changed, 141 insertions, 24 deletions
diff --git a/sys-fs/zfs-kmod/ChangeLog b/sys-fs/zfs-kmod/ChangeLog
index 73a9b96605b0..6eb5ae4d38cd 100644
--- a/sys-fs/zfs-kmod/ChangeLog
+++ b/sys-fs/zfs-kmod/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/zfs-kmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.25 2013/03/24 00:02:31 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/ChangeLog,v 1.26 2013/03/28 22:19:35 ryao Exp $
+
+*zfs-kmod-0.6.1 (28 Mar 2013)
+
+ 28 Mar 2013; Richard Yao <ryao@gentoo.org> +zfs-kmod-0.6.1.ebuild,
+ zfs-kmod-9999.ebuild:
+ Version bump to 0.6.1
24 Mar 2013; Richard Yao <ryao@gentoo.org> zfs-kmod-0.6.0_rc14-r5.ebuild,
zfs-kmod-9999.ebuild:
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.6.1.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.6.1.ebuild
new file mode 100644
index 000000000000..9827fd9f81c3
--- /dev/null
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.6.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-0.6.1.ebuild,v 1.1 2013/03/28 22:19:35 ryao Exp $
+
+EAPI="4"
+
+AT_M4DIR="config"
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+inherit bash-completion-r1 flag-o-matic linux-info linux-mod toolchain-funcs autotools-utils
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-2
+ MY_PV=9999
+ EGIT_REPO_URI="git://github.com/zfsonlinux/zfs.git"
+else
+ inherit eutils versionator
+ MY_PV=$(replace_version_separator 3 '-')
+ SRC_URI="https://github.com/zfsonlinux/zfs/archive/zfs-${MY_PV}.tar.gz"
+ S="${WORKDIR}/zfs-zfs-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="CDDL debug? ( GPL-2+ )"
+SLOT="0"
+IUSE="custom-cflags debug +rootfs"
+RESTRICT="test"
+
+DEPEND="
+ =sys-kernel/spl-${PV}*
+ virtual/awk
+"
+
+RDEPEND="${DEPEND}
+ !sys-fs/zfs-fuse
+"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="!DEBUG_LOCK_ALLOC
+ BLK_DEV_LOOP
+ EFI_PARTITION
+ IOSCHED_NOOP
+ MODULES
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ use rootfs && \
+ CONFIG_CHECK="${CONFIG_CHECK} BLK_DEV_INITRD
+ DEVTMPFS"
+
+ kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"
+
+ [ ${PV} != "9999" ] && \
+ { kernel_is le 3 9 || die "Linux 3.9 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ # Remove GPLv2-licensed ZPIOS unless we are debugging
+ use debug || sed -e 's/^subdir-m += zpios$//' -i "${S}/module/Makefile.in"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ filter-ldflags -Wl,*
+
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=kernel
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc AUTHORS COPYRIGHT DISCLAIMER README.markdown
+
+ # Provide /usr/src/zfs symlink for lustre
+ dosym "$(basename $(echo "${ED}/usr/src/zfs-"*))/${KV_FULL}" /usr/src/zfs
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ # Remove old modules
+ if [ -d "${EROOT}lib/modules/${KV_FULL}/addon/zfs" ]
+ then
+ ewarn "${PN} now installs modules in ${EROOT}lib/modules/${KV_FULL}/extra/zfs"
+ ewarn "Old modules were detected in ${EROOT}lib/modules/${KV_FULL}/addon/zfs"
+ ewarn "Automatically removing old modules to avoid problems."
+ rm -r "${EROOT}lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
+ rmdir --ignore-fail-on-non-empty "${EROOT}lib/modules/${KV_FULL}/addon"
+ fi
+
+ if use x86 || use arm
+ then
+ ewarn "32-bit kernels will likely require increasing vmalloc to"
+ ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
+ fi
+
+ ewarn "This version of ZFSOnLinux includes support for features flags."
+ ewarn "If you upgrade your pools to make use of feature flags, you will lose"
+ ewarn "the ability to import them using older versions of ZFSOnLinux."
+ ewarn "Any new pools will be created with feature flag support and will"
+ ewarn "not be compatible with older versions of ZFSOnLinux. To create a new"
+ ewarn "pool that is backward compatible, use zpool create -o version=28 ..."
+}
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index b9fb690f4b20..cb79a8a3341e 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild,v 1.13 2013/03/24 00:02:31 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild,v 1.14 2013/03/28 22:19:35 ryao Exp $
EAPI="4"
@@ -64,27 +64,6 @@ pkg_setup() {
}
src_prepare() {
- if [ ${PV} != "9999" ]
- then
- # Cast constant for 32-bit compatibility
- epatch "${FILESDIR}/${P}-cast-const-for-32bit-compatibility.patch"
-
- # Handle missing name length check in Linux VFS
- epatch "${FILESDIR}/${P}-vfs-name-length-compatibility.patch"
-
- # Fix NULL pointer exception on hardened kernels, bug #457176
- epatch "${FILESDIR}/${P}-improved-hardened-support.patch"
-
- # Fix barrier regression on Linux 2.6.37 and later
- epatch "${FILESDIR}/${P}-flush-properly.patch"
-
- # Improve accuracy of autotools checks
- epatch "${FILESDIR}/${P}-improved-autotools-checks.patch"
-
- # Linux 3.9 Support
- epatch "${FILESDIR}/${P}-linux-3.9-compat.patch"
- fi
-
# Remove GPLv2-licensed ZPIOS unless we are debugging
use debug || sed -e 's/^subdir-m += zpios$//' -i "${S}/module/Makefile.in"
@@ -118,13 +97,23 @@ src_install() {
pkg_postinst() {
linux-mod_pkg_postinst
+ # Remove old modules
+ if [ -d "${EROOT}lib/modules/${KV_FULL}/addon/zfs" ]
+ then
+ ewarn "${PN} now installs modules in ${EROOT}lib/modules/${KV_FULL}/extra/zfs"
+ ewarn "Old modules were detected in ${EROOT}lib/modules/${KV_FULL}/addon/zfs"
+ ewarn "Automatically removing old modules to avoid problems."
+ rm -r "${EROOT}lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
+ rmdir --ignore-fail-on-non-empty "${EROOT}lib/modules/${KV_FULL}/addon"
+ fi
+
if use x86 || use arm
then
ewarn "32-bit kernels will likely require increasing vmalloc to"
ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
fi
- ewarn "This version of ZFSOnLinux introduces support for features flags."
+ ewarn "This version of ZFSOnLinux includes support for features flags."
ewarn "If you upgrade your pools to make use of feature flags, you will lose"
ewarn "the ability to import them using older versions of ZFSOnLinux."
ewarn "Any new pools will be created with feature flag support and will"