summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-07-21 18:55:54 +0000
committerRichard Yao <ryao@gentoo.org>2012-07-21 18:55:54 +0000
commit0e83f37176092965120d616a0d425ab5fdda064f (patch)
treeea6c709455b11ee1a194365d7ae867f617bb08e1 /sys-fs
parenteapi bump, fix compilation for qt-4.8 wrt #427412, update icon cache (diff)
downloadgentoo-2-0e83f37176092965120d616a0d425ab5fdda064f.tar.gz
gentoo-2-0e83f37176092965120d616a0d425ab5fdda064f.tar.bz2
gentoo-2-0e83f37176092965120d616a0d425ab5fdda064f.zip
Fix NULL pointer dereference on >=sys-kernel/hardened-sources-3.3.0
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/ChangeLog9
-rw-r--r--sys-fs/zfs/files/zfs-0.6.0_rc9-hardened-3.3-and-later-support.patch37
-rw-r--r--sys-fs/zfs/zfs-0.6.0_rc9-r6.ebuild (renamed from sys-fs/zfs/zfs-0.6.0_rc9-r5.ebuild)3
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild3
4 files changed, 49 insertions, 3 deletions
diff --git a/sys-fs/zfs/ChangeLog b/sys-fs/zfs/ChangeLog
index 8208243554d2..32f047652fbd 100644
--- a/sys-fs/zfs/ChangeLog
+++ b/sys-fs/zfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/zfs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.38 2012/07/11 19:45:53 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/ChangeLog,v 1.39 2012/07/21 18:55:54 ryao Exp $
+
+*zfs-0.6.0_rc9-r6 (21 Jul 2012)
+
+ 21 Jul 2012; Richard Yao <ryao@gentoo.org>
+ +files/zfs-0.6.0_rc9-hardened-3.3-and-later-support.patch,
+ +zfs-0.6.0_rc9-r6.ebuild, -zfs-0.6.0_rc9-r5.ebuild, zfs-9999.ebuild:
+ Fix NULL pointer dereference on >=sys-kernel/hardened-sources-3.3.0
11 Jul 2012; Richard Yao <ryao@gentoo.org>
+files/zfs-0.6.0_rc9-bsd-init.patch:
diff --git a/sys-fs/zfs/files/zfs-0.6.0_rc9-hardened-3.3-and-later-support.patch b/sys-fs/zfs/files/zfs-0.6.0_rc9-hardened-3.3-and-later-support.patch
new file mode 100644
index 000000000000..5e6cb4e8af95
--- /dev/null
+++ b/sys-fs/zfs/files/zfs-0.6.0_rc9-hardened-3.3-and-later-support.patch
@@ -0,0 +1,37 @@
+commit 91d3b3c46473ee8a7f7dc8177b80fbece3f5ac94
+Author: Richard Yao <ryao@cs.stonybrook.edu>
+Date: Thu Jul 19 18:37:56 2012 -0400
+
+ Fix NULL pointer dereference on PaX/GRSecurity patched Linux 3.3 and later kernels
+
+ Support for PaX/GRSecurity patched kernels was developed against Linux
+ 3.2. Unfortunately, an autotools check introduced for a Linux 3.3 API
+ fails on PaX/GRSecurity patched kernels. This causes the module to be
+ built against the Linux 3.2 ABI, which results in a NULL pointer
+ dereference at runtime.
+
+ Closes zfsonlinux/zfs#794 and zfsonlinux/zfs#809
+
+ Signed-off-by: Richard Yao <ryao@cs.stonybrook.edu>
+
+diff --git a/config/kernel-show-options.m4 b/config/kernel-show-options.m4
+index 1bddb0a..67d683c 100644
+--- a/config/kernel-show-options.m4
++++ b/config/kernel-show-options.m4
+@@ -6,11 +6,12 @@ AC_DEFUN([ZFS_AC_KERNEL_SHOW_OPTIONS], [
+
+ ZFS_LINUX_TRY_COMPILE([
+ #include <linux/fs.h>
+- ],[
+- int (*show_options) (struct seq_file *, struct dentry *) = NULL;
+- struct super_operations sops __attribute__ ((unused));
+
+- sops.show_options = show_options;
++ int show_options (struct seq_file * x, struct dentry * y) { return 0; };
++ static struct super_operations sops __attribute__ ((unused)) = {
++ .show_options = show_options,
++ };
++ ],[
+ ],[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_SHOW_OPTIONS_WITH_DENTRY, 1,
diff --git a/sys-fs/zfs/zfs-0.6.0_rc9-r5.ebuild b/sys-fs/zfs/zfs-0.6.0_rc9-r6.ebuild
index 9a6dc91af126..634a8c2638af 100644
--- a/sys-fs/zfs/zfs-0.6.0_rc9-r5.ebuild
+++ b/sys-fs/zfs/zfs-0.6.0_rc9-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.0_rc9-r5.ebuild,v 1.1 2012/07/11 13:20:31 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-0.6.0_rc9-r6.ebuild,v 1.1 2012/07/21 18:55:54 ryao Exp $
EAPI="4"
@@ -81,6 +81,7 @@ src_prepare() {
then
# Fix build issues
epatch "${FILESDIR}/${P}-hardened-support.patch"
+ epatch "${FILESDIR}/${P}-hardened-3.3-and-later-support.patch"
epatch "${FILESDIR}/${P}-linux-3.5-support.patch"
epatch "${FILESDIR}/${P}-fix-32-bit-warnings.patch"
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 4f4bd6d9c209..85745691f09a 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.28 2012/07/11 13:20:31 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs/zfs-9999.ebuild,v 1.29 2012/07/21 18:55:54 ryao Exp $
EAPI="4"
@@ -81,6 +81,7 @@ src_prepare() {
then
# Fix build issues
epatch "${FILESDIR}/${P}-hardened-support.patch"
+ epatch "${FILESDIR}/${P}-hardened-3.3-and-later-support.patch"
epatch "${FILESDIR}/${P}-linux-3.5-support.patch"
epatch "${FILESDIR}/${P}-fix-32-bit-warnings.patch"