summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-10-11 12:06:10 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-10-11 12:06:10 +0000
commit1db55fb27617528c14ad6530454da7bc5d3f3289 (patch)
tree9173bced833ee320217b2dfd9ba92325028cac69 /sys-fs
parentMask sys-fs/device-mapper-1.02.22-r5 for testing (diff)
downloadgentoo-2-1db55fb27617528c14ad6530454da7bc5d3f3289.tar.gz
gentoo-2-1db55fb27617528c14ad6530454da7bc5d3f3289.tar.bz2
gentoo-2-1db55fb27617528c14ad6530454da7bc5d3f3289.zip
Swap NAME/SYMLINK. Now /dev/mapper/NAME is the device-node, and /dev/dm-* is a symlink on it. This should fix Bug #190819 for now.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/device-mapper/ChangeLog10
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.22-r5.ebuild69
-rw-r--r--sys-fs/device-mapper/files/64-device-mapper.rules-1.02.22-r525
-rw-r--r--sys-fs/device-mapper/files/digest-device-mapper-1.02.22-r53
4 files changed, 106 insertions, 1 deletions
diff --git a/sys-fs/device-mapper/ChangeLog b/sys-fs/device-mapper/ChangeLog
index a0048cce95d8..ba1b5d863c6b 100644
--- a/sys-fs/device-mapper/ChangeLog
+++ b/sys-fs/device-mapper/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/device-mapper
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.92 2007/10/09 14:19:55 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.93 2007/10/11 12:06:10 zzam Exp $
+
+*device-mapper-1.02.22-r5 (11 Oct 2007)
+
+ 11 Oct 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/64-device-mapper.rules-1.02.22-r5,
+ +device-mapper-1.02.22-r5.ebuild:
+ Swap NAME/SYMLINK. Now /dev/mapper/NAME is the device-node, and /dev/dm-* is
+ a symlink on it. This should fix Bug #190819 for now.
*device-mapper-1.02.22-r4 (09 Oct 2007)
diff --git a/sys-fs/device-mapper/device-mapper-1.02.22-r5.ebuild b/sys-fs/device-mapper/device-mapper-1.02.22-r5.ebuild
new file mode 100644
index 000000000000..bb341ecc49b2
--- /dev/null
+++ b/sys-fs/device-mapper/device-mapper-1.02.22-r5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.22-r5.ebuild,v 1.1 2007/10/11 12:06:10 zzam Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
+HOMEPAGE="http://sources.redhat.com/dm/"
+SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz
+ ftp://sources.redhat.com/pub/dm/old/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/device-mapper-1.02.22-export-format-r1.diff
+}
+
+src_compile() {
+ econf --sbindir=/sbin $(use_enable selinux) --enable-dmeventd || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # move shared libs to /
+ mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
+ dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
+ gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ newinitd "${FILESDIR}"/device-mapper.rc-1.02.22-r3 device-mapper || die
+ newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper || die
+
+ newinitd "${FILESDIR}"/1.02.22-dmeventd.initd dmeventd || die
+ dolib.a dmeventd/libdevmapper-event.a || die
+ gen_usr_ldscript libdevmapper-event.so
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/64-device-mapper.rules-1.02.22-r5 64-device-mapper.rules
+
+ dodoc INSTALL INTRO README VERSION WHATS_NEW
+}
+
+pkg_preinst() {
+ local l="${ROOT}"/$(get_libdir)/libdevmapper.so.1.01
+ [[ -e ${l} ]] && cp "${l}" "${D}"/$(get_libdir)/
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libdevmapper.so.1.01
+
+ elog "device-mapper volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add device-mapper boot"
+}
diff --git a/sys-fs/device-mapper/files/64-device-mapper.rules-1.02.22-r5 b/sys-fs/device-mapper/files/64-device-mapper.rules-1.02.22-r5
new file mode 100644
index 000000000000..36c085b56b97
--- /dev/null
+++ b/sys-fs/device-mapper/files/64-device-mapper.rules-1.02.22-r5
@@ -0,0 +1,25 @@
+# do not edit this file, it will be overwritten on update
+
+KERNEL=="device-mapper", SYMLINK+="mapper/control"
+
+KERNEL!="dm-*", GOTO="device_mapper_end"
+ACTION!="add|change", GOTO="device_mapper_end"
+
+IMPORT{program}="/sbin/dmsetup info --export -j%M -m%m"
+ENV{DM_NAME}!="?*", GOTO="device_mapper_end"
+NAME="mapper/$env{DM_NAME}", SYMLINK+="%k"
+
+SYMLINK+="disk/by-id/dm-name-$env{DM_NAME}"
+ENV{DM_UUID}=="?*", SYMLINK+="disk/by-id/dm-uuid-$env{DM_UUID}"
+
+ENV{DM_SUSPENDED}=="1", GOTO="device_mapper_end"
+ENV{DM_EXISTS}=="0", GOTO="device_mapper_end"
+ENV{DM_TARGET_TYPES}=="|*error*", GOTO="device_mapper_end"
+
+IMPORT{program}="vol_id --export $tempnode"
+OPTIONS="link_priority=-100"
+ENV{DM_TARGET_TYPES}=="*snapshot-origin*", OPTIONS="link_priority=-90"
+ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{ID_FS_UUID_ENC}=="?*", SYMLINK+="disk/by-uuid/$env{ID_FS_UUID_ENC}"
+ENV{ID_FS_USAGE}=="filesystem|other", ENV{ID_FS_LABEL_ENC}=="?*", SYMLINK+="disk/by-label/$env{ID_FS_LABEL_ENC}"
+
+LABEL="device_mapper_end"
diff --git a/sys-fs/device-mapper/files/digest-device-mapper-1.02.22-r5 b/sys-fs/device-mapper/files/digest-device-mapper-1.02.22-r5
new file mode 100644
index 000000000000..9b8f6a284ce3
--- /dev/null
+++ b/sys-fs/device-mapper/files/digest-device-mapper-1.02.22-r5
@@ -0,0 +1,3 @@
+MD5 6b94db57cdc9022af1583b3f2acb91cd device-mapper.1.02.22.tgz 189726
+RMD160 8bf9986536c49f53c398d6a2180e21e1235bea18 device-mapper.1.02.22.tgz 189726
+SHA256 ff833a6cd6246686f5b3f5692fd6597f1ffbc60f08929e5fe68304cdafb61595 device-mapper.1.02.22.tgz 189726