summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-04 21:59:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-04 21:59:22 +0000
commit2f6505c07c6d363d5aefc614feea1cc813994fa4 (patch)
tree483b5d9c5a1b030369ce9c8b029a17dff1302ac3 /sys-fs
parentRestore patch that was accidentally dropped, bug #445740. (diff)
downloadgentoo-2-2f6505c07c6d363d5aefc614feea1cc813994fa4.tar.gz
gentoo-2-2f6505c07c6d363d5aefc614feea1cc813994fa4.tar.bz2
gentoo-2-2f6505c07c6d363d5aefc614feea1cc813994fa4.zip
Import Debian patchset to get 05_fix_segmentation_fault.patch wrt #445856 by "Kobboi"
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/extundelete/ChangeLog9
-rw-r--r--sys-fs/extundelete/extundelete-0.2.0-r2.ebuild30
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-fs/extundelete/ChangeLog b/sys-fs/extundelete/ChangeLog
index cc2d30cc7a16..aed6a67546fc 100644
--- a/sys-fs/extundelete/ChangeLog
+++ b/sys-fs/extundelete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/extundelete
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/extundelete/ChangeLog,v 1.6 2012/06/20 08:20:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/extundelete/ChangeLog,v 1.7 2012/12/04 21:59:22 ssuominen Exp $
+
+*extundelete-0.2.0-r2 (04 Dec 2012)
+
+ 04 Dec 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +extundelete-0.2.0-r2.ebuild:
+ Import Debian patchset to get 05_fix_segmentation_fault.patch wrt #445856 by
+ "Kobboi"
20 Jun 2012; Jeff Horelick <jdhore@gentoo.org> extundelete-0.2.0-r1.ebuild:
marked x86 per bug 422211
diff --git a/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild b/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..7ef6ddd07d72
--- /dev/null
+++ b/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/extundelete/extundelete-0.2.0-r2.ebuild,v 1.1 2012/12/04 21:59:22 ssuominen Exp $
+
+EAPI=5
+inherit eutils
+
+_UNDEL_DEB=2.1
+_UNDEL_E2FS=1.42.6
+
+DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
+HOMEPAGE="http://extundelete.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${_UNDEL_DEB}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/e2fsprogs-${_UNDEL_E2FS}
+ >=sys-libs/e2fsprogs-libs-${_UNDEL_E2FS}"
+DEPEND="${RDEPEND}"
+
+DOCS="README"
+
+src_prepare() {
+ local d=${WORKDIR}/debian/patches
+ EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
+}