summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-09-23 04:21:02 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-09-23 04:21:02 +0000
commit39a0490d118e7462c241511685069ce1b775424f (patch)
tree0669d8ed717393a3c5e7205512c52071e01d6996 /sys-fs
parentx86 stable (diff)
downloadgentoo-2-39a0490d118e7462c241511685069ce1b775424f.tar.gz
gentoo-2-39a0490d118e7462c241511685069ce1b775424f.tar.bz2
gentoo-2-39a0490d118e7462c241511685069ce1b775424f.zip
initial ebuild, thx to kir
(Portage version: 2.0.52-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/vzquota/ChangeLog10
-rw-r--r--sys-fs/vzquota/Manifest4
-rw-r--r--sys-fs/vzquota/files/digest-vzquota-2.7.0.71
-rw-r--r--sys-fs/vzquota/metadata.xml5
-rw-r--r--sys-fs/vzquota/vzquota-2.7.0.7.ebuild35
5 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/vzquota/ChangeLog b/sys-fs/vzquota/ChangeLog
new file mode 100644
index 000000000000..0b9983694d22
--- /dev/null
+++ b/sys-fs/vzquota/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-fs/vzquota
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vzquota/ChangeLog,v 1.1 2005/09/23 04:21:02 hollow Exp $
+
+*vzquota-2.7.0.7 (23 Sep 2005)
+
+ 23 Sep 2005; Benedikt Boehm <hollow@gentoo.org> +metadata.xml,
+ +vzquota-2.7.0.7.ebuild:
+ initial ebuild, thx to kir
+
diff --git a/sys-fs/vzquota/Manifest b/sys-fs/vzquota/Manifest
new file mode 100644
index 000000000000..4de0e35dc254
--- /dev/null
+++ b/sys-fs/vzquota/Manifest
@@ -0,0 +1,4 @@
+MD5 4a202e48865b64f0eeafd241765490e1 vzquota-2.7.0.7.ebuild 793
+MD5 b55bfb88b955107a0f0e6c5aaef21723 metadata.xml 162
+MD5 ab790d980a6e2aef8b8e6ae034cd1b33 ChangeLog 269
+MD5 216c395711a7d2d0f890dcebb9f7838d files/digest-vzquota-2.7.0.7 67
diff --git a/sys-fs/vzquota/files/digest-vzquota-2.7.0.7 b/sys-fs/vzquota/files/digest-vzquota-2.7.0.7
new file mode 100644
index 000000000000..9656b7a749e7
--- /dev/null
+++ b/sys-fs/vzquota/files/digest-vzquota-2.7.0.7
@@ -0,0 +1 @@
+MD5 e1109e8795fe734fc501b662d70eb01f vzquota-2.7.0-7.tar.bz2 35082
diff --git a/sys-fs/vzquota/metadata.xml b/sys-fs/vzquota/metadata.xml
new file mode 100644
index 000000000000..63d45921090f
--- /dev/null
+++ b/sys-fs/vzquota/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vserver</herd>
+</pkgmetadata>
diff --git a/sys-fs/vzquota/vzquota-2.7.0.7.ebuild b/sys-fs/vzquota/vzquota-2.7.0.7.ebuild
new file mode 100644
index 000000000000..a575e18d4787
--- /dev/null
+++ b/sys-fs/vzquota/vzquota-2.7.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/vzquota/vzquota-2.7.0.7.ebuild,v 1.1 2005/09/23 04:21:02 hollow Exp $
+
+inherit eutils toolchain-funcs versionator linux-info
+
+VVER="$(get_version_component_range 1-3 ${PV})"
+VREL="$(get_version_component_range 4 ${PV})"
+MY_PV="${VVER}-${VREL}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="OpenVZ VPS disk quota utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${MY_PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="VE VE_CALLS VZ_QUOTA"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ check_kernel_built
+}
+
+src_compile() {
+ emake VZKERNEL_HEADERS=${KV_DIR}/include || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+}