summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-19 09:29:28 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-19 09:29:28 +0000
commit434ec8b11b56421309df732a76825a7a8cb7b6ca (patch)
tree35147c99c6afd3e87febeddedc7752c1dd997abe /sys-fs
parentgawk-4.1.0: Add upstream patches for AIX support, bug#490266. (diff)
downloadgentoo-2-434ec8b11b56421309df732a76825a7a8cb7b6ca.tar.gz
gentoo-2-434ec8b11b56421309df732a76825a7a8cb7b6ca.tar.bz2
gentoo-2-434ec8b11b56421309df732a76825a7a8cb7b6ca.zip
sys-fs/aufs3: Turned around patch combining, #491554
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs3/ChangeLog6
-rw-r--r--sys-fs/aufs3/aufs3-3_p20131104.ebuild6
-rw-r--r--sys-fs/aufs3/aufs3-3_p20131111.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/sys-fs/aufs3/ChangeLog b/sys-fs/aufs3/ChangeLog
index 2f9ba8796a3c..e903b4df887c 100644
--- a/sys-fs/aufs3/ChangeLog
+++ b/sys-fs/aufs3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/aufs3
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.77 2013/11/19 07:22:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/ChangeLog,v 1.78 2013/11/19 09:29:28 jlec Exp $
+
+ 19 Nov 2013; Justin Lecher <jlec@gentoo.org> aufs3-3_p20131104.ebuild,
+ aufs3-3_p20131111.ebuild:
+ Turned around patch combining, #491554
19 Nov 2013; Justin Lecher <jlec@gentoo.org> aufs3-3_p20131111.ebuild:
Add min supported version check
diff --git a/sys-fs/aufs3/aufs3-3_p20131104.ebuild b/sys-fs/aufs3/aufs3-3_p20131104.ebuild
index 6379464cde10..fdea4cd6e884 100644
--- a/sys-fs/aufs3/aufs3-3_p20131104.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20131104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20131104.ebuild,v 1.2 2013/11/11 15:45:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20131104.ebuild,v 1.3 2013/11/19 09:29:28 jlec Exp $
EAPI=5
@@ -75,8 +75,8 @@ pkg_setup() {
cd ${PN}-standalone || die
local module_branch=origin/${PN}.${PATCH_BRANCH}
git checkout -q -b local-gentoo ${module_branch} || die
- combinediff ${PN}-base.patch ${PN}-mmap.patch > "${T}"/combined-1.patch
- combinediff ${PN}-standalone.patch "${T}"/combined-1.patch > ${PN}-standalone-base-mmap-combined.patch
+ combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
if use kernel-patch; then
cd ${KV_DIR}
diff --git a/sys-fs/aufs3/aufs3-3_p20131111.ebuild b/sys-fs/aufs3/aufs3-3_p20131111.ebuild
index d51386f3a66b..6e71488ce90d 100644
--- a/sys-fs/aufs3/aufs3-3_p20131111.ebuild
+++ b/sys-fs/aufs3/aufs3-3_p20131111.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20131111.ebuild,v 1.2 2013/11/19 07:22:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/aufs3/aufs3-3_p20131111.ebuild,v 1.3 2013/11/19 09:29:28 jlec Exp $
EAPI=5
@@ -77,8 +77,8 @@ pkg_setup() {
cd ${PN}-standalone || die
local module_branch=origin/${PN}.${PATCH_BRANCH}
git checkout -q -b local-gentoo ${module_branch} || die
- combinediff ${PN}-base.patch ${PN}-mmap.patch > "${T}"/combined-1.patch
- combinediff ${PN}-standalone.patch "${T}"/combined-1.patch > ${PN}-standalone-base-mmap-combined.patch
+ combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
if use kernel-patch; then
cd ${KV_DIR}