summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-01-18 14:29:44 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-01-18 14:29:44 +0000
commit4c893d0961ee530d99ddae0ff7d64a474a6d1ac0 (patch)
tree17f351890577da68792541f154dfa24f31d99d4b /sys-fs
parentUndo fixing bug #133743 since none of the patches actually work (diff)
downloadgentoo-2-4c893d0961ee530d99ddae0ff7d64a474a6d1ac0.tar.gz
gentoo-2-4c893d0961ee530d99ddae0ff7d64a474a6d1ac0.tar.bz2
gentoo-2-4c893d0961ee530d99ddae0ff7d64a474a6d1ac0.zip
Version bump, remove FUSE kernel module check as it now works with both the in-kernel FUSE module and the FUSE package one. Clean out older version.
(Portage version: 2.1.2)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog9
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.200701183
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild35
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index aad7a9eeca78..64356f4fb9ba 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.19 2007/01/16 03:14:24 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.20 2007/01/18 14:29:44 chutzpah Exp $
+
+*ntfs3g-0.20070118 (18 Jan 2007)
+
+ 18 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
+ -ntfs3g-0.20061212.ebuild, +ntfs3g-0.20070118.ebuild:
+ Version bump, remove FUSE kernel module check as it now works with both the
+ in-kernel FUSE module and the FUSE package one. Clean out older version.
*ntfs3g-0.20070116 (16 Jan 2007)
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070118 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070118
new file mode 100644
index 000000000000..711c28c09a2c
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070118
@@ -0,0 +1,3 @@
+MD5 f25c2a09926446168969bd093fda0079 ntfs-3g-0.20070118-BETA.tgz 562512
+RMD160 7765e159c3767bea82bcc8fc06262281d1b9d413 ntfs-3g-0.20070118-BETA.tgz 562512
+SHA256 7740d5fa1d9811263b06a11851e6359c4d62b65d0a4a2ba17497e94b8c1ab4c7 ntfs-3g-0.20070118-BETA.tgz 562512
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild
new file mode 100644
index 000000000000..52c851b6539b
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20070118.ebuild,v 1.1 2007/01/18 14:29:44 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+}