summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-25 22:24:04 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-25 22:24:04 +0000
commit4ef2aea402d762f1c234939aca7fa5713774bf8a (patch)
treefde4be4fe521c45fc0ba83a5c1b402c35c403103 /sys-fs
parentFix multilib-strictness and make it compatible with FreeBSD. (diff)
downloadgentoo-2-4ef2aea402d762f1c234939aca7fa5713774bf8a.tar.gz
gentoo-2-4ef2aea402d762f1c234939aca7fa5713774bf8a.tar.bz2
gentoo-2-4ef2aea402d762f1c234939aca7fa5713774bf8a.zip
clean some older versions
(Portage version: 2.0.52-r1 http://www.bash.org/?136501 )
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.36.ebuild123
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.37.ebuild96
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.361
-rw-r--r--sys-fs/e2fsprogs/files/digest-e2fsprogs-1.371
4 files changed, 0 insertions, 221 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.36.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.36.ebuild
deleted file mode 100644
index 82649702b6ac..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.36.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.36.ebuild,v 1.3 2005/08/28 06:03:14 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls static"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Fix a cosmetic error in mk_cmds's help output.
- epatch ${FILESDIR}/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Patch to make the configure and sed scripts more friendly to,
- # for example, the Estonian locale
- epatch ${FILESDIR}/${P}-sed-locale.patch
- # Userpriv fix. Closes #27348
- chmod u+w po/*.po
-
- # Use -fPIC compiled shared files in .a files. Fix kdelibs-3.3.0 compilation on hppa.
- use static || sed -e '/ARUPD/s:$(OBJS):elfshared/*.o:' -i ${S}/lib/Makefile.library
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- configure e2fsck/journal.c e2fsck/recovery.c \
- e2fsck/unix.c lib/ext2fs/kernel-jbd.h \
- || die "sed jbd debug failed"
-
- # building e2fsprogs on sparc results in silo breaking
- [[ ${ARCH} == "sparc" ]] && filter-flags -fstack-protector
-
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_compile() {
- local myconf
- use static \
- && myconf="${myconf} --with-ldopts=-static" \
- || myconf="${myconf} --enable-dynamic-e2fsck --enable-elf-shlibs"
- econf \
- $(use_enable nls) \
- ${myconf} || die
-
- # Parallel make sometimes fails
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR=${D} libdir=/zapme install || die
- #evil e2fsprogs makefile -- I'll get you!
- rm -rf ${D}/zapme
-
- make DESTDIR=${D} install-libs || die
-
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- dodir /$(get_libdir) /bin /sbin
- cd ${D}/usr/$(get_libdir)
- mv * ../../$(get_libdir)
- cd ${D}/$(get_libdir)
- mv *.a ../usr/$(get_libdir)
- local mylib=""
- local x=""
- #install ldscripts to fix bug #4411
- cd ${D}/usr/$(get_libdir)
- for x in *.a
- do
- [ ! -f ${x} ] && continue
- gen_usr_ldscript ${x/a}so
- done
- #normalize evil symlinks
- cd ${D}/$(get_libdir)
- for x in *
- do
- [ ! -L ${x} ] && continue
- mylib="`readlink ${x}`"
- mylib="`basename ${mylib}`"
- ln -sf ${mylib} ${x}
- done
-
- mv ${D}/usr/sbin/* ${D}/sbin
- cd ${D}/usr/bin
- mv lsattr chattr uuidgen ../../bin
- cd ${D}/sbin
- mv mklost+found ../usr/sbin
- #time to convert hard links/duplicates to symbolic links
- cd ${D}/sbin
- rm fsck.*
- ln -sf e2fsck fsck.ext2
- ln -sf e2fsck fsck.ext3
- rm mkfs.*
- ln -sf mke2fs mkfs.ext2
- ln -sf mke2fs mkfs.ext3
-
- # 03 Aug 2002 <raker@gentoo.org>
- # There are awk files that don't get installed when doing
- # a 'make install'. They are the template files for
- # /bin/compile_et.
- cd ${S}/$(get_libdir)/et
- insinto /usr/share/et
- doins et_c.awk et_h.awk
- cd ${S}/$(get_libdir)/ss
- insinto /usr/share/ss
- doins ct_c.awk
-}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.37.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.37.ebuild
deleted file mode 100644
index 917faf4d9647..000000000000
--- a/sys-fs/e2fsprogs/e2fsprogs-1.37.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/e2fsprogs/e2fsprogs-1.37.ebuild,v 1.7 2005/08/28 06:03:14 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Standard EXT2 and EXT3 filesystem utilities"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nls static"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- sys-apps/texinfo"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # Fix a cosmetic error in mk_cmds's help output.
- epatch "${FILESDIR}"/e2fsprogs-1.32-mk_cmds-cosmetic.patch
- # Patch to make the configure and sed scripts more friendly to,
- # for example, the Estonian locale
- epatch "${FILESDIR}"/e2fsprogs-1.36-sed-locale.patch
- chmod u+w po/*.po # Userpriv fix #27348
- # Clean up makefile to suck less
- epatch "${FILESDIR}"/e2fsprogs-1.36-makefile.patch
- # Fix tests to work #88570
- epatch "${FILESDIR}"/e2fsprogs-1.37-e2p-test.patch
-
- # kernel headers use the same defines as e2fsprogs and can cause issues #48829
- sed -i \
- -e 's:CONFIG_JBD_DEBUG:__CONFIG_JBD_DEBUG__E2FS:g' \
- $(grep -rl CONFIG_JBD_DEBUG *) \
- || die "sed jbd debug failed"
-
- # building e2fsprogs on sparc results in silo breaking
- [[ ${ARCH} == "sparc" ]] && filter-flags -fstack-protector
-
- # Keep the package from doing silly things
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_compile() {
- econf \
- --bindir=/bin \
- --sbindir=/sbin \
- --enable-elf-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !static dynamic-e2fsck) \
- --without-included-gettext \
- $(use_enable nls) \
- || die
- if ! use elibc_uclibc && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
- eerror "INTL sanity check failed, aborting build."
- eerror "Please post your ${S}/config.log file as an"
- eerror "attachment to http://bugs.gentoo.org/show_bug.cgi?id=81096"
- die "Preventing included intl cruft from building"
- fi
- # Parallel make sometimes fails
- emake -j1 || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc ChangeLog README RELEASE-NOTES SHLIBS
- docinto e2fsck
- dodoc e2fsck/ChangeLog e2fsck/CHANGES
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/
- dolib.a lib/*.a || die "dolib.a"
- local x
- cd "${D}"/$(get_libdir)
- for x in *.so ; do
- gen_usr_ldscript ${x} || die "gen ldscript ${x}"
- done
-
- # move 'useless' stuff to /usr/
- dosbin "${D}"/sbin/mklost+found
- rm -f "${D}"/sbin/mklost+found
-
- # Install template awk files for compile_et
- insinto /usr/share/et
- doins "${S}"/lib/et/*.awk || die "doins et awk"
- insinto /usr/share/ss
- doins "${S}"/lib/ss/*.awk || die "doins ss awk"
-}
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36
deleted file mode 100644
index b9df1ce9da18..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.36
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1804ee96b76e5e7113fe3cecd6fe582b e2fsprogs-1.36.tar.gz 3264042
diff --git a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37 b/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37
deleted file mode 100644
index f0ccfbd55831..000000000000
--- a/sys-fs/e2fsprogs/files/digest-e2fsprogs-1.37
+++ /dev/null
@@ -1 +0,0 @@
-MD5 084b49e919121fc0bf53c8dae23a71f8 e2fsprogs-1.37.tar.gz 3507693