summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-10-19 09:27:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-10-19 09:27:42 +0000
commit85518b925224c05a2e0c34ad5b6b602f44587ad8 (patch)
tree8050860b7d20426e45d27b8e630f0e0197e396bb /sys-fs
parentVersion bump. (diff)
downloadgentoo-2-85518b925224c05a2e0c34ad5b6b602f44587ad8.tar.gz
gentoo-2-85518b925224c05a2e0c34ad5b6b602f44587ad8.tar.bz2
gentoo-2-85518b925224c05a2e0c34ad5b6b602f44587ad8.zip
Use /usr/sbin instead of /usr/bin for now because util-linux fails to search /usr/bin for mount wrappers. Install udev rules too as per forums post. See bug #437230 for details and link to the forums post.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse-exfat/ChangeLog10
-rw-r--r--sys-fs/fuse-exfat/files/99-exfat.rules1
-rw-r--r--sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild36
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-fs/fuse-exfat/ChangeLog b/sys-fs/fuse-exfat/ChangeLog
index 299cbfaa0688..11f438eca3a2 100644
--- a/sys-fs/fuse-exfat/ChangeLog
+++ b/sys-fs/fuse-exfat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/fuse-exfat
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-exfat/ChangeLog,v 1.4 2012/08/27 07:04:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-exfat/ChangeLog,v 1.5 2012/10/19 09:27:42 ssuominen Exp $
+
+*fuse-exfat-0.9.8-r1 (19 Oct 2012)
+
+ 19 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> +files/99-exfat.rules,
+ +fuse-exfat-0.9.8-r1.ebuild:
+ Use /usr/sbin instead of /usr/bin for now because util-linux fails to search
+ /usr/bin for mount wrappers. Install udev rules too as per forums post. See
+ bug #437230 for details and link to the forums post.
*fuse-exfat-0.9.8 (27 Aug 2012)
diff --git a/sys-fs/fuse-exfat/files/99-exfat.rules b/sys-fs/fuse-exfat/files/99-exfat.rules
new file mode 100644
index 000000000000..914e9d576f13
--- /dev/null
+++ b/sys-fs/fuse-exfat/files/99-exfat.rules
@@ -0,0 +1 @@
+ENV{ID_FS_TYPE}=="exfat", ENV{ID_FS_TYPE}="exfat-fuse"
diff --git a/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild b/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..d913c5e16ac5
--- /dev/null
+++ b/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-exfat/fuse-exfat-0.9.8-r1.ebuild,v 1.1 2012/10/19 09:27:42 ssuominen Exp $
+
+EAPI=4
+inherit scons-utils toolchain-funcs
+
+DESCRIPTION="exFAT filesystem FUSE module"
+HOMEPAGE="http://code.google.com/p/exfat/"
+SRC_URI="http://exfat.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/fuse"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+ escons CCFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dosbin fuse/mount.exfat-fuse
+ dosym mount.exfat-fuse /usr/sbin/mount.exfat
+
+ doman */*.8
+ dodoc ChangeLog
+
+ local udevdir=/lib/udev
+ has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+ insinto "${udevdir}"/rules.d
+ doins "${FILESDIR}"/99-exfat.rules
+}