summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-01-05 01:33:24 +0000
committerMichael Weber <xmw@gentoo.org>2011-01-05 01:33:24 +0000
commit8afa8a8731d40b478035a45df30b42466af86232 (patch)
treeae8d91cf96252eb9ceda44509c30340a05604728 /sys-fs
parentFixed patch filename (diff)
downloadgentoo-2-8afa8a8731d40b478035a45df30b42466af86232.tar.gz
gentoo-2-8afa8a8731d40b478035a45df30b42466af86232.tar.bz2
gentoo-2-8afa8a8731d40b478035a45df30b42466af86232.zip
Version bump (thanks to Michele Beltrame <mb@cattlegrid.info> for the report on bug 350603)
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/s3fs/ChangeLog8
-rw-r--r--sys-fs/s3fs/s3fs-1.33.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/sys-fs/s3fs/ChangeLog b/sys-fs/s3fs/ChangeLog
index a674194c0c2c..dbf95b8622ec 100644
--- a/sys-fs/s3fs/ChangeLog
+++ b/sys-fs/s3fs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/s3fs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.9 2011/01/05 01:07:44 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/ChangeLog,v 1.10 2011/01/05 01:33:24 xmw Exp $
+
+*s3fs-1.33 (05 Jan 2011)
+
+ 05 Jan 2011; Michael Weber <xmw@gentoo.org> +s3fs-1.33.ebuild:
+ Version bump (thanks to Michele Beltrame <mb@cattlegrid.info> for the report
+ on bug 350603)
05 Jan 2011; Michael Weber <xmw@gentoo.org> s3fs-0_p191.ebuild:
Fixed patch filename
diff --git a/sys-fs/s3fs/s3fs-1.33.ebuild b/sys-fs/s3fs/s3fs-1.33.ebuild
new file mode 100644
index 000000000000..97ccb9923d5d
--- /dev/null
+++ b/sys-fs/s3fs/s3fs-1.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/s3fs/s3fs-1.33.ebuild,v 1.1 2011/01/05 01:33:24 xmw Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Amazon mounting S3 via fuse"
+HOMEPAGE="http://s3fs.googlecode.com/"
+SRC_URI="http://s3fs.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/libxml2-2.6
+ dev-libs/openssl
+ >=net-misc/curl-7.0
+ >=sys-fs/fuse-2.8.4"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types"
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README || die
+}