summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-21 09:17:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-21 09:17:06 +0000
commit96851409e738a6cd0d875f4b533d3e57e58b2a7d (patch)
tree7cf5dc1da1f70c1d9d8afedacfc0af38769bcd84 /sys-fs
parentBug #333737: version bump. (diff)
downloadgentoo-2-96851409e738a6cd0d875f4b533d3e57e58b2a7d.tar.gz
gentoo-2-96851409e738a6cd0d875f4b533d3e57e58b2a7d.tar.bz2
gentoo-2-96851409e738a6cd0d875f4b533d3e57e58b2a7d.zip
Fix long hangs on probing nonexistant floppies.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udisks/ChangeLog8
-rw-r--r--sys-fs/udisks/files/udisks-1.0.1-no-floppy.patch30
-rw-r--r--sys-fs/udisks/udisks-1.0.1-r2.ebuild67
3 files changed, 104 insertions, 1 deletions
diff --git a/sys-fs/udisks/ChangeLog b/sys-fs/udisks/ChangeLog
index 1d3e9b42f814..3ed98f3dd956 100644
--- a/sys-fs/udisks/ChangeLog
+++ b/sys-fs/udisks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/udisks
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/ChangeLog,v 1.15 2010/08/20 17:08:15 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/ChangeLog,v 1.16 2010/08/21 09:17:06 ssuominen Exp $
+
+*udisks-1.0.1-r2 (21 Aug 2010)
+
+ 21 Aug 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +udisks-1.0.1-r2.ebuild, +files/udisks-1.0.1-no-floppy.patch:
+ Fix long hangs on probing nonexistant floppies.
20 Aug 2010; Jeroen Roovers <jer@gentoo.org> udisks-1.0.1-r1.ebuild:
Move from sys-apps/parted to sys-block/parted.
diff --git a/sys-fs/udisks/files/udisks-1.0.1-no-floppy.patch b/sys-fs/udisks/files/udisks-1.0.1-no-floppy.patch
new file mode 100644
index 000000000000..1d69d1cbc89d
--- /dev/null
+++ b/sys-fs/udisks/files/udisks-1.0.1-no-floppy.patch
@@ -0,0 +1,30 @@
+From ca93d4e2d9e7f483b2fde1725da086e2cca44164 Mon Sep 17 00:00:00 2001
+From: Martin Pitt <martin.pitt@ubuntu.com>
+Date: Wed, 02 Jun 2010 13:56:07 +0000
+Subject: Fix long hangs on probing nonexistant floppy drives
+
+A lot of modern machines do not have a floppy drive any more, but still have a
+floppy controller somewhere (or at least the BIOS pretends to). Trying to
+open(/dev/fd0) on these machines causes long hangs, which lead to long desktop
+startup times.
+
+To fix this, avoid probing floppies for media in update_info().
+
+https://launchpad.net/bugs/539515
+---
+diff --git a/src/device.c b/src/device.c
+index 763385c..0e87f1d 100644
+--- a/src/device.c
++++ b/src/device.c
+@@ -4471,7 +4471,8 @@ update_info (Device *device)
+ {
+ media_available = FALSE;
+
+- if (!g_udev_device_get_property_as_boolean (device->priv->d, "ID_CDROM"))
++ if (!g_udev_device_get_property_as_boolean (device->priv->d, "ID_CDROM") &&
++ !g_udev_device_get_property_as_boolean (device->priv->d, "ID_DRIVE_FLOPPY"))
+ {
+ int fd;
+ fd = open (device->priv->device_file, O_RDONLY);
+--
+cgit v0.8.3-6-g21f6
diff --git a/sys-fs/udisks/udisks-1.0.1-r2.ebuild b/sys-fs/udisks/udisks-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..7986c136265b
--- /dev/null
+++ b/sys-fs/udisks/udisks-1.0.1-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udisks/udisks-1.0.1-r2.ebuild,v 1.1 2010/08/21 09:17:06 ssuominen Exp $
+
+EAPI=3
+inherit eutils bash-completion
+
+DESCRIPTION="Daemon providing interfaces to work with storage devices"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/udisks"
+SRC_URI="http://hal.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc nls remote-access"
+
+COMMON_DEPEND=">=sys-fs/udev-147[extras]
+ >=dev-libs/glib-2.16.1:2
+ >=sys-apps/dbus-1
+ >=dev-libs/dbus-glib-0.82
+ >=sys-auth/polkit-0.92
+ >=sys-block/parted-1.8.8[device-mapper]
+ >=sys-fs/lvm2-2.02.66
+ >=dev-libs/libatasmart-0.14
+ >=sys-apps/sg3_utils-1.27.20090411
+ !sys-apps/devicekit-disks"
+RDEPEND="${COMMON_DEPEND}
+ remote-access? ( net-dns/avahi )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )
+ nls? ( >=dev-util/intltool-0.40.0 )"
+
+# This would require running dbus and also sudo.
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-lvm2_api_support.patch \
+ "${FILESDIR}"/${P}-no-floppy.patch
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable debug verbose-mode) \
+ --enable-man-pages \
+ $(use_enable doc gtk-doc) \
+ $(use_enable remote-access) \
+ $(use_enable nls) \
+ --with-html-dir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS HACKING NEWS README
+
+ rm -f "${ED}"/etc/profile.d/udisks-bash-completion.sh
+ dobashcompletion tools/udisks-bash-completion.sh ${PN}
+
+ find "${ED}" -name '*.la' -delete
+ keepdir /media
+}