summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-28 08:43:48 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-28 08:43:48 +0000
commit9718a654eedda863142fad1816f35a1f96e32be9 (patch)
treebfa0a624364d65d9c0c27b8070c974c9ec76e091 /sys-fs
parentDepend on dev-qt/qtdbus. This fixes bug #484162. Thanks to Nikoli for the rep... (diff)
downloadgentoo-2-9718a654eedda863142fad1816f35a1f96e32be9.tar.gz
gentoo-2-9718a654eedda863142fad1816f35a1f96e32be9.tar.bz2
gentoo-2-9718a654eedda863142fad1816f35a1f96e32be9.zip
Install additional upstream unit file (#485902 by Alexander Tsoy), show elog messages only when people are booting with openRC
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mdadm/ChangeLog8
-rw-r--r--sys-fs/mdadm/mdadm-3.3-r1.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-fs/mdadm/ChangeLog b/sys-fs/mdadm/ChangeLog
index e93c3f9f70fd..2550854145e3 100644
--- a/sys-fs/mdadm/ChangeLog
+++ b/sys-fs/mdadm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/mdadm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.171 2013/09/25 17:30:09 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/ChangeLog,v 1.172 2013/09/28 08:43:48 pacho Exp $
+
+*mdadm-3.3-r1 (28 Sep 2013)
+
+ 28 Sep 2013; Pacho Ramos <pacho@gentoo.org> +mdadm-3.3-r1.ebuild:
+ Install additional upstream unit file (#485902 by Alexander Tsoy), show elog
+ messages only when people are booting with openRC
25 Sep 2013; Agostino Sarubbo <ago@gentoo.org> mdadm-3.2.6-r1.ebuild:
Stable for ppc, wrt bug #480114
diff --git a/sys-fs/mdadm/mdadm-3.3-r1.ebuild b/sys-fs/mdadm/mdadm-3.3-r1.ebuild
new file mode 100644
index 000000000000..262949415a43
--- /dev/null
+++ b/sys-fs/mdadm/mdadm-3.3-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mdadm/mdadm-3.3-r1.ebuild,v 1.1 2013/09/28 08:43:48 pacho Exp $
+
+EAPI="4"
+inherit multilib flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="A useful tool for running RAID systems - it can be used as a replacement for the raidtools"
+HOMEPAGE="http://neil.brown.name/blog/mdadm"
+SRC_URI="mirror://kernel/linux/utils/raid/mdadm/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+DEPEND="virtual/pkgconfig
+ app-arch/xz-utils"
+RDEPEND=">=sys-apps/util-linux-2.16"
+
+# The tests edit values in /proc and run tests on software raid devices.
+# Thus, they shouldn't be run on systems with active software RAID devices.
+RESTRICT="test"
+
+mdadm_emake() {
+ emake \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ CC="$(tc-getCC)" \
+ CWFLAGS="-Wall" \
+ CXFLAGS="${CFLAGS}" \
+ MAP_DIR=/run/mdadm \
+ "$@"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ mdadm_emake all mdassemble
+}
+
+src_test() {
+ mdadm_emake test
+
+ sh ./test || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ SYSTEMD_DIR=$(systemd_get_unitdir) \
+ install install-systemd
+ into /
+ dosbin mdassemble
+ dodoc ChangeLog INSTALL TODO README* ANNOUNCE-${PV}
+
+ insinto /etc
+ newins mdadm.conf-example mdadm.conf
+ newinitd "${FILESDIR}"/mdadm.rc mdadm
+ newconfd "${FILESDIR}"/mdadm.confd mdadm
+ newinitd "${FILESDIR}"/mdraid.rc mdraid
+ newconfd "${FILESDIR}"/mdraid.confd mdraid
+ systemd_dounit "${FILESDIR}"/mdadm.service
+ systemd_newtmpfilesd "${FILESDIR}"/mdadm.tmpfiles.conf mdadm.conf
+}
+
+pkg_postinst() {
+ if ! systemd_is_booted; then
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ # Only inform people the first time they install.
+ elog "If you're not relying on kernel auto-detect of your RAID"
+ elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
+ elog " rc-update add mdraid boot"
+ fi
+ fi
+}