summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-04-10 01:05:58 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-04-10 01:05:58 +0000
commit994b8b067ee25d32139fc25c4690f0dd837218dc (patch)
treee1033c6e336553f320fe6d5102b88aaa32cb361a /sys-fs
parentMake PT default for pax marking (pax-utils.eclass) (diff)
downloadgentoo-2-994b8b067ee25d32139fc25c4690f0dd837218dc.tar.gz
gentoo-2-994b8b067ee25d32139fc25c4690f0dd837218dc.tar.bz2
gentoo-2-994b8b067ee25d32139fc25c4690f0dd837218dc.zip
USE=rule-generator by default, else warn about predictable netiface names.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/eudev/ChangeLog5
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild77
2 files changed, 45 insertions, 37 deletions
diff --git a/sys-fs/eudev/ChangeLog b/sys-fs/eudev/ChangeLog
index 0534e85fb2b4..b8e7fa165a1f 100644
--- a/sys-fs/eudev/ChangeLog
+++ b/sys-fs/eudev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/eudev
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.35 2013/04/08 01:35:57 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/ChangeLog,v 1.36 2013/04/10 01:05:58 blueness Exp $
+
+ 10 Apr 2013; Anthony G. Basile <blueness@gentoo.org> eudev-9999.ebuild:
+ USE=rule-generator by default, else warn about predictable netiface names.
08 Apr 2013; Anthony G. Basile <blueness@gentoo.org> eudev-1_beta3.ebuild,
eudev-9999.ebuild:
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index 81ca5bebd8bd..c2ed383539e8 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.25 2013/04/08 01:35:57 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/eudev/eudev-9999.ebuild,v 1.26 2013/04/10 01:05:58 blueness Exp $
EAPI=5
@@ -14,7 +14,7 @@ then
inherit git-2
else
SRC_URI="http://dev.gentoo.org/~axs/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
fi
DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
@@ -22,7 +22,7 @@ HOMEPAGE="https://github.com/gentoo/eudev"
LICENSE="LGPL-2.1 MIT GPL-2"
SLOT="0"
-IUSE="doc gudev hwdb kmod introspection legacy-libudev keymap +modutils +openrc rule-generator selinux static-libs"
+IUSE="doc gudev hwdb kmod introspection legacy-libudev keymap +modutils +openrc +rule-generator selinux static-libs"
RESTRICT="test"
@@ -66,39 +66,42 @@ udev_check_KV()
pkg_pretend()
{
- ewarn "As of 2013-01-29, eudev-9999 provides the new interface renaming"
- ewarn "functionality, as described in the URL below:"
- ewarn "http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
- ewarn
- ewarn "This functionality is enabled BY DEFAULT because eudev has no means of synchronizing"
- ewarn "between the default or user-modified choice of sys-fs/udev. If you wish to disable"
- ewarn "this new iface naming, please be sure that /etc/udev/rules.d/80-net-name-slot.rules"
- ewarn "exists:"
- ewarn "\ttouch /etc/udev/rules.d/80-net-name-slot.rules"
- ewarn
- ewarn "We are working on a better solution for the next beta release."
- ewarn
- if has_version "<sys-fs/udev-180" && ! use legacy-libudev; then
- ewarn
- ewarn "This version of eudev does not contain the libudev.so.0 library by "
- ewarn "default. This is an issue when migrating from sys-fs/udev-180 or older."
- ewarn
- ewarn "Removal of libudev.so.0 will effectively break any active Xorg sessions, and"
- ewarn "will probably have repercussions with other software as well. A revdep-rebuild"
- ewarn "is required to resolve these issues."
- ewarn
- ewarn "Add USE=legacy-libudev to tell eudev to install a copy of libudev.so.0, if"
- ewarn "you wish to continue to use your system while migrating to libudev.so.1"
- else
- if use legacy-libudev ; then
- ewarn
- ewarn "You are installing eudev with USE=legacy-libudev , this should only be used"
- ewarn "to support binary-only applications or legacy applications while in the"
- ewarn "process of doing a full systems upgrade, that require libudev.so.0 -- it is"
- ewarn "HIGHLY RECOMMENDED to leave this flag disabled unless absolutely necessary."
+ if ! use rule-generator; then
+ ewarn
+ ewarn "As of 2013-01-29, eudev-9999 provides the new interface renaming functionality,"
+ ewarn "as described in the URL below:"
+ ewarn "http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
+ ewarn
+ ewarn "This functionality is enabled BY DEFAULT because eudev has no means of synchronizing"
+ ewarn "between the default or user-modified choice of sys-fs/udev. If you wish to disable"
+ ewarn "this new iface naming, please be sure that /etc/udev/rules.d/80-net-name-slot.rules"
+ ewarn "exists:"
+ ewarn "\ttouch /etc/udev/rules.d/80-net-name-slot.rules"
+ ewarn
+ ewarn "We are working on a better solution for the next beta release."
+ ewarn
fi
+
+ if has_version "<sys-fs/udev-180" && ! use legacy-libudev; then
+ ewarn
+ ewarn "This version of eudev does not contain the libudev.so.0 library by "
+ ewarn "default. This is an issue when migrating from sys-fs/udev-180 or older."
+ ewarn
+ ewarn "Removal of libudev.so.0 will effectively break any active Xorg sessions, and"
+ ewarn "will probably have repercussions with other software as well. A revdep-rebuild"
+ ewarn "is required to resolve these issues."
+ ewarn
+ ewarn "Add USE=legacy-libudev to tell eudev to install a copy of libudev.so.0, if"
+ ewarn "you wish to continue to use your system while migrating to libudev.so.1"
+ ewarn
+ elif use legacy-libudev ; then
+ ewarn
+ ewarn "You are installing eudev with USE=legacy-libudev , this should only be used"
+ ewarn "to support binary-only applications or legacy applications while in the"
+ ewarn "process of doing a full systems upgrade, that require libudev.so.0 -- it is"
+ ewarn "HIGHLY RECOMMENDED to leave this flag disabled unless absolutely necessary."
+ ewarn
fi
- ewarn
}
pkg_setup()
@@ -109,10 +112,11 @@ pkg_setup()
linux-info_pkg_setup
- if ! udev_check_KV
- then
+ if ! udev_check_KV; then
+ eerror
eerror "Your kernel version (${KV_FULL}) is too old to run ${P}"
eerror "It must be at least ${KV_min}!"
+ eerror
fi
KV_FULL_SRC=${KV_FULL}
@@ -123,6 +127,7 @@ pkg_setup()
eerror "Your running kernel version (${KV_FULL}) is too old"
eerror "for this version of udev."
eerror "You must upgrade your kernel or downgrade udev."
+ eerror
fi
# for USE=legacy-libudev