summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-07-28 02:24:07 +0000
committerNed Ludd <solar@gentoo.org>2005-07-28 02:24:07 +0000
commita1533cd0a00fd9f0b66519104f6cd6007a35c90c (patch)
tree734f502c908a7d13efcb1198b4fea7ddcf7915c8 /sys-fs
parentRemoved old version (diff)
downloadgentoo-2-a1533cd0a00fd9f0b66519104f6cd6007a35c90c.tar.gz
gentoo-2-a1533cd0a00fd9f0b66519104f6cd6007a35c90c.tar.bz2
gentoo-2-a1533cd0a00fd9f0b66519104f6cd6007a35c90c.zip
- initial version of dmraid. bug #63041 - This software discovers, activates, deactivates and displays properties of software RAID sets (eg, ATARAID) and contained DOS partitions.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dmraid/ChangeLog11
-rw-r--r--sys-fs/dmraid/Manifest4
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild62
-rw-r--r--sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r11
-rw-r--r--sys-fs/dmraid/metadata.xml10
5 files changed, 88 insertions, 0 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
new file mode 100644
index 000000000000..ee7459a0c68b
--- /dev/null
+++ b/sys-fs/dmraid/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-fs/dmraid
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.1 2005/07/28 02:24:07 solar Exp $
+
+*dmraid-1.0.0_rc8-r1 (27 Jul 2005)
+
+ 27 Jul 2005; <solar.@gentoo.org> +metadata.xml, +dmraid-1.0.0_rc8-r1.ebuild:
+ - initial version of dmraid. bug #63041 - This software discovers, activates,
+ deactivates and displays properties of software RAID sets (eg, ATARAID) and
+ contained DOS partitions.
+
diff --git a/sys-fs/dmraid/Manifest b/sys-fs/dmraid/Manifest
new file mode 100644
index 000000000000..37227ba94c1a
--- /dev/null
+++ b/sys-fs/dmraid/Manifest
@@ -0,0 +1,4 @@
+MD5 7dd328d4169fbdf6457c005c2dd13f5d dmraid-1.0.0_rc8-r1.ebuild 1701
+MD5 045dc59cf5e99f296a30bcd020e25740 ChangeLog 416
+MD5 3bb7e945a8c9e94592bf5ad614aeb57a metadata.xml 449
+MD5 397241bdc56be36ee9e2bc81b7a67f67 files/digest-dmraid-1.0.0_rc8-r1 69
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild
new file mode 100644
index 000000000000..7c3fa7820865
--- /dev/null
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2005-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild,v 1.1 2005/07/28 02:24:07 solar Exp $
+
+inherit linux-info flag-o-matic
+
+DESCRIPTION="dmraid (Device-mapper RAID tool and library)"
+HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
+SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${P/_/.}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+DEPEND="sys-fs/device-mapper"
+S=${WORKDIR}/${PN}/${PV/_/.}
+
+pkg_setup() {
+ if kernel_is lt 2 6; then
+ ewarn "You are using a kernel < 2.6"
+ ewarn "DMraid uses recently introduced Device-Mapper features."
+ ewarn "These might be unavailable in the kernel you are running now."
+ fi
+}
+
+src_compile() {
+ # Build fix rc8 for shared lib
+ sed -e 's:global\::global\:\ init_locking;:' -i lib/.export.sym
+
+ #inlining doesnt seem to work for dmraid
+ filter-flags -fno-inline
+
+ # We want shared. For static boot stuff, people should use genkernel.
+ ./configure --enable-shared_lib || die "Failed configure"
+ #econf --enable-shared_lib || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die "einstall failed"
+
+ dolib.a lib/libdmraid.a
+
+ # no header file is installed by make install
+ insinto /usr/include
+ newins include/dmraid.h libdmraid.h
+
+ dodoc CHANGELOG README TODO KNOWN_BUGS doc/*
+}
+
+pkg_postinst() {
+ echo
+ einfo "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
+ echo
+ einfo "Genkernel will generate the kernel and the initrd with a staticly linked dmraid binary:"
+ einfo "emerge -av sys-kernel/genkernel"
+ einfo "genkernel --dmraid --udev all"
+ echo
+ ewarn "DMraid should be safe to use, but no warranties can be given"
+ echo
+ ebeep
+}
diff --git a/sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r1 b/sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r1
new file mode 100644
index 000000000000..76214c73f1e1
--- /dev/null
+++ b/sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r1
@@ -0,0 +1 @@
+MD5 b7843de0ff7a10434cf0b84d0a19724d dmraid-1.0.0.rc8.tar.bz2 130421
diff --git a/sys-fs/dmraid/metadata.xml b/sys-fs/dmraid/metadata.xml
new file mode 100644
index 000000000000..e0088fb7d088
--- /dev/null
+++ b/sys-fs/dmraid/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>solar@gentoo.org</email>
+ <description>housemate needed it</description>
+ </maintainer>
+ <longdescription>This software discovers, activates, deactivates and displays properties of software RAID sets eg: ATARAID and contained DOS partitions.</longdescription>
+</pkgmetadata>