summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-08-23 10:30:29 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-08-23 10:30:29 +0000
commitb655214689402c3ac12d403659f105c394b8a0e6 (patch)
tree6b39543b442641a36035d6ccc2de6a2cd30fff8a /sys-fs
parentFix DEPEND as we are running eautoreconf (#481386 by Peter Stuge), drop old. (diff)
downloadgentoo-2-b655214689402c3ac12d403659f105c394b8a0e6.tar.gz
gentoo-2-b655214689402c3ac12d403659f105c394b8a0e6.tar.bz2
gentoo-2-b655214689402c3ac12d403659f105c394b8a0e6.zip
Revision bump: EAPI 5, epatch_user, fix typo in help message, wrt bug #482078. Thanks to <zhaoxiaoqiang007 AT gmail.com> for discovering this issue and for provided patch
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuseiso/ChangeLog10
-rw-r--r--sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch12
-rw-r--r--sys-fs/fuseiso/fuseiso-20070708-r1.ebuild29
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-fs/fuseiso/ChangeLog b/sys-fs/fuseiso/ChangeLog
index cc8bec9e24a3..1472a59e5d95 100644
--- a/sys-fs/fuseiso/ChangeLog
+++ b/sys-fs/fuseiso/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/fuseiso
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuseiso/ChangeLog,v 1.5 2013/08/22 08:11:48 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuseiso/ChangeLog,v 1.6 2013/08/23 10:30:29 pinkbyte Exp $
+
+*fuseiso-20070708-r1 (23 Aug 2013)
+
+ 23 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> +fuseiso-20070708-r1.ebuild,
+ +files/fuseiso-20070708-fix-typo.patch:
+ Revision bump: EAPI 5, epatch_user, fix typo in help message, wrt bug
+ #482078. Thanks to <zhaoxiaoqiang007 AT gmail.com> for discovering this issue
+ and for provided patch
22 Aug 2013; Sergey Popov <pinkbyte@gentoo.org> metadata.xml:
Package will be maintained through proxy maintainers
diff --git a/sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch b/sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch
new file mode 100644
index 000000000000..522ee7598e0e
--- /dev/null
+++ b/sys-fs/fuseiso/files/fuseiso-20070708-fix-typo.patch
@@ -0,0 +1,12 @@
+diff -urp fuseiso-20070708.org/src/fuseiso.c fuseiso-20070708/src/fuseiso.c
+--- fuseiso-20070708.org/src/fuseiso.c 2013-08-22 19:33:46.316904170 +0800
++++ fuseiso-20070708/src/fuseiso.c 2013-08-22 19:31:54.789908834 +0800
+@@ -295,7 +295,7 @@ void usage(const char* prog) {
+ " -f -- run in foreground, do not daemonize\n"
+ " -d -- run in foreground and print debug information\n"
+ " -s -- run single-threaded\n"
+- "\nPlease consult with FUSE ducumentation for more information\n",
++ "\nPlease consult with FUSE documentation for more information\n",
+ VERSION,
+ prog);
+ };
diff --git a/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild b/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild
new file mode 100644
index 000000000000..7bb1f64d4dde
--- /dev/null
+++ b/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuseiso/fuseiso-20070708-r1.ebuild,v 1.1 2013/08/23 10:30:29 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Fuse module to mount ISO9660"
+HOMEPAGE="http://sourceforge.net/projects/fuseiso"
+SRC_URI="http://superb-dca2.dl.sourceforge.net/project/fuseiso/fuseiso/20070708/fuseiso-20070708.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse
+ sys-libs/zlib
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-largeiso.patch"
+ epatch "${FILESDIR}/${P}-fix-typo.patch" # bug #482078
+ epatch_user
+}