summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-23 20:47:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-23 20:47:04 +0000
commitc5b2c91970198070d49ccc4bf87f4742d7c1a990 (patch)
treeb48d23cc993ee0989d173ef344a26916c03ca17c /sys-fs
parentComplete last fix (diff)
downloadgentoo-2-c5b2c91970198070d49ccc4bf87f4742d7c1a990.tar.gz
gentoo-2-c5b2c91970198070d49ccc4bf87f4742d7c1a990.tar.bz2
gentoo-2-c5b2c91970198070d49ccc4bf87f4742d7c1a990.zip
and use REPLACING_VERSIONS for last commit
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/udev-197-r4.ebuild4
-rw-r--r--sys-fs/udev/udev-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/udev/udev-197-r4.ebuild b/sys-fs/udev/udev-197-r4.ebuild
index 366647afb31a..aaa7e444293f 100644
--- a/sys-fs/udev/udev-197-r4.ebuild
+++ b/sys-fs/udev/udev-197-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-197-r4.ebuild,v 1.17 2013/01/23 20:41:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-197-r4.ebuild,v 1.18 2013/01/23 20:47:04 ssuominen Exp $
EAPI=4
@@ -399,7 +399,7 @@ pkg_postinst()
{
mkdir -p "${ROOT}"/run
- if has_version '<sys-fs/udev-197'; then
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 197 ]]; then
net_rules="${ROOT}"etc/udev/rules.d/80-net-name-slot.rules
[[ -f ${net_rules} ]] || cp "${ROOT}"usr/share/doc/${PF}/gentoo/80-net-name-slot.rules "${net_rules}"
fi
diff --git a/sys-fs/udev/udev-9999.ebuild b/sys-fs/udev/udev-9999.ebuild
index 8bd726bd89c3..cfab3f2d6d8d 100644
--- a/sys-fs/udev/udev-9999.ebuild
+++ b/sys-fs/udev/udev-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.159 2013/01/23 20:41:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-9999.ebuild,v 1.160 2013/01/23 20:47:04 ssuominen Exp $
EAPI=4
@@ -399,7 +399,7 @@ pkg_postinst()
{
mkdir -p "${ROOT}"/run
- if has_version '<sys-fs/udev-197'; then
+ if [[ ${REPLACING_VERSIONS} ]] && [[ ${REPLACING_VERSIONS} < 197 ]]; then
net_rules="${ROOT}"etc/udev/rules.d/80-net-name-slot.rules
[[ -f ${net_rules} ]] || cp "${ROOT}"usr/share/doc/${PF}/gentoo/80-net-name-slot.rules "${net_rules}"
fi