summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-02-07 16:47:30 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-02-07 16:47:30 +0000
commitcd9140f04ba704826067de7f6a01813ff7badb74 (patch)
tree7b6503d3a64db62abb56f66a88aedd27d5b5ae3b /sys-fs
parentBring 0.8.1 keywords up to 0.8 and remove old DOSable version (diff)
downloadgentoo-2-cd9140f04ba704826067de7f6a01813ff7badb74.tar.gz
gentoo-2-cd9140f04ba704826067de7f6a01813ff7badb74.tar.bz2
gentoo-2-cd9140f04ba704826067de7f6a01813ff7badb74.zip
Version bump.
(Portage version: 2.1.2-r8)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.33
-rw-r--r--sys-fs/fuse/fuse-2.6.3.ebuild78
3 files changed, 87 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 8c72706aa510..de1105984b0a 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.72 2007/02/05 08:07:41 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.73 2007/02/07 16:47:30 chutzpah Exp $
+
+*fuse-2.6.3 (07 Feb 2007)
+
+ 07 Feb 2007; Patrick McLean <chutzpah@gentoo.org> +fuse-2.6.3.ebuild:
+ Version bump.
05 Feb 2007; <genstef@gentoo.org> +files/fuse-2.6.20.patch,
fuse-2.6.1.ebuild:
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.3 b/sys-fs/fuse/files/digest-fuse-2.6.3
new file mode 100644
index 000000000000..be1acdd63dc3
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.6.3
@@ -0,0 +1,3 @@
+MD5 3f4f5d07d12dedc0a3fd23472171fe94 fuse-2.6.3.tar.gz 473147
+RMD160 df05bc42cb4c97f9e54048662f64a8cac5713f18 fuse-2.6.3.tar.gz 473147
+SHA256 804d7fae424c97dc3790ad12d798e7b27dc6c12e4116f8bd69ca0130773d3f9d fuse-2.6.3.tar.gz 473147
diff --git a/sys-fs/fuse/fuse-2.6.3.ebuild b/sys-fs/fuse/fuse-2.6.3.ebuild
new file mode 100644
index 000000000000..4cdcad203016
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.6.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.1 2007/02/07 16:47:30 chutzpah Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+MODULE_NAMES="fuse(fs:${S}/kernel)"
+CONFIG_CHECK="@FUSE_FS:fuse"
+BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+BUILD_TARGETS="all"
+ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
+FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+We will continue, but we wont build the module this time."
+
+pkg_setup() {
+ if use kernel_linux ; then
+ linux-mod_pkg_setup
+ kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
+ older version from viewcvs"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-kernel-module \
+ --disable-example \
+ || die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux ; then
+ cd "${S}"
+ sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
+ convert_to_m kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
+ README.NFS NEWS doc/how-fuse-works
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ linux-mod_src_install
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ fi
+
+ newinitd ${FILESDIR}/fuse.init fuse
+
+ rm -rf "${D}/dev"
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}