summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-11-08 18:41:51 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-11-08 18:41:51 +0000
commitf3b543c1f0018a61bd16a51f15817dffd3cc549b (patch)
tree09eb3d55937e40d7248d9291ce8e7bfed32b58ff /sys-fs
parentstable on amd64 (diff)
downloadgentoo-2-f3b543c1f0018a61bd16a51f15817dffd3cc549b.tar.gz
gentoo-2-f3b543c1f0018a61bd16a51f15817dffd3cc549b.tar.bz2
gentoo-2-f3b543c1f0018a61bd16a51f15817dffd3cc549b.zip
Added suspend2-2.2.8.4 support
(Portage version: 2.1.1-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dazuko/ChangeLog8
-rw-r--r--sys-fs/dazuko/dazuko-2.3.1-r1.ebuild54
-rw-r--r--sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch69
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.1-r13
4 files changed, 133 insertions, 1 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 68069a070bc5..0a87a22f2a21 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.7 2006/10/21 19:48:07 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.8 2006/11/08 18:41:51 alonbl Exp $
+
+*dazuko-2.3.1-r1 (08 Nov 2006)
+
+ 08 Nov 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/dazuko-2.3.1-suspend2.patch, +dazuko-2.3.1-r1.ebuild:
+ Added suspend2-2.2.8.4 support
21 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> dazuko-2.3.1.ebuild:
Add ~alpha and ~ia64 keywords, bug 151630.
diff --git a/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild b/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..604d8c0eab02
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.1-r1.ebuild,v 1.1 2006/11/08 18:41:51 alonbl Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=virtual/linux-sources-2.2"
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-suspend2.patch"
+}
+
+src_compile() {
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ || die "configure failed"
+ convert_to_m Makefile
+ linux-mod_src_compile
+
+ cd library
+ emake || die
+ cd ..
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
diff --git a/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch b/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch
new file mode 100644
index 000000000000..b54e2c043d6a
--- /dev/null
+++ b/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch
@@ -0,0 +1,69 @@
+diff -urNp dazuko-2.3.1.org/configure dazuko-2.3.1/configure
+--- dazuko-2.3.1.org/configure 2006-10-04 00:48:18.000000000 +0200
++++ dazuko-2.3.1/configure 2006-11-08 15:11:38.000000000 +0200
+@@ -590,21 +590,20 @@ do_linux26()
+ then
+ LINUX26_USE_SUSPEND=1
+ fi
++ fi
++
++ SRC_PATH_END="/include/linux/freezer.h"
++ get_src_path
+
+- grep "try_todo_list.*(.*void.*)" "$SRC_PATH" > /dev/null 2>&1
++ if [ -f "$SRC_PATH" ]
++ then
++ grep "try_to_freeze.*(.*void.*)" "$SRC_PATH" > /dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+- LINUX26_USE_SUSPEND=2
++ LINUX26_USE_SUSPEND=1
+ fi
+ fi
+
+- if [ $LINUX26_USE_SUSPEND -eq 2 ]
+- then
+- echo "ok (suspend2)"
+- else
+- echo "ok (suspend1)"
+- fi
+-
+ if [ $LOCAL_DPATH -eq 2 ]
+ then
+ LOCAL_DPATH=1
+@@ -705,11 +704,6 @@ do_linux26()
+ echo "EXTRA_CFLAGS += -DUSE_TRYTOFREEZEVOID" >> Makefile
+ fi
+
+- if [ ${LINUX26_USE_SUSPEND} -eq 2 ]
+- then
+- echo "EXTRA_CFLAGS += -DUSE_SUSPEND2" >> Makefile
+- fi
+-
+ if [ ${LINUX26_USE_CLASS} -eq 1 ]
+ then
+ echo "EXTRA_CFLAGS += -DUSE_CLASS" >> Makefile
+diff -urNp dazuko-2.3.1.org/dazuko_linux26.c dazuko-2.3.1/dazuko_linux26.c
+--- dazuko-2.3.1.org/dazuko_linux26.c 2006-07-29 12:13:03.000000000 +0300
++++ dazuko-2.3.1/dazuko_linux26.c 2006-11-08 15:15:25.000000000 +0200
+@@ -37,7 +37,7 @@
+ #include <linux/devfs_fs_kernel.h>
+ #endif
+ #include <linux/device.h>
+-#if !defined(USE_TRYTOFREEZEVOID) && !defined(USE_SUSPEND2)
++#if !defined(USE_TRYTOFREEZEVOID)
+ #include <linux/suspend.h>
+ #endif
+ #include <asm/uaccess.h>
+@@ -178,10 +178,7 @@ inline int xp_wait_until_condition(struc
+ {
+ ret = wait_event_interruptible(queue->queue, cfunction(cparam) != 0);
+
+-#ifdef USE_SUSPEND2
+- if (try_todo_list() == 0)
+- break;
+-#elif defined (USE_TRYTOFREEZEVOID)
++#if defined (USE_TRYTOFREEZEVOID)
+ if (try_to_freeze() == 0)
+ break;
+ #else
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.1-r1 b/sys-fs/dazuko/files/digest-dazuko-2.3.1-r1
new file mode 100644
index 000000000000..4478b3fc29d0
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.1-r1
@@ -0,0 +1,3 @@
+MD5 7f8373d4b429a9e454aa556a8f2e40fb dazuko-2.3.1.tar.gz 176944
+RMD160 cc527bf0f251cfa96ec79ddbcc8e6ad49247dbef dazuko-2.3.1.tar.gz 176944
+SHA256 9481875699e6fefd80f40b945159df55815408f76f9fd511656c55a52499fc8e dazuko-2.3.1.tar.gz 176944