summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-08-11 22:49:13 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-08-11 22:49:13 +0000
commitf7fe5c454c403144ec9c536be0c0d700a5f53232 (patch)
treeac2826f84d1362fb6650c3515c429aba26ad019a /sys-fs
parentgames goes last on inherit line; tidy (diff)
downloadgentoo-2-f7fe5c454c403144ec9c536be0c0d700a5f53232.tar.gz
gentoo-2-f7fe5c454c403144ec9c536be0c0d700a5f53232.tar.bz2
gentoo-2-f7fe5c454c403144ec9c536be0c0d700a5f53232.zip
Remove .la files and add static-libs USE flag.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g/ChangeLog5
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 84254750eea9..4e3decc08235 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.115 2011/05/30 14:34:22 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.116 2011/08/11 22:49:13 chutzpah Exp $
+
+ 11 Aug 2011; Patrick McLean <chutzpah@gentoo.org> ntfs3g-2011.4.12.ebuild:
+ Remove .la files and add static-libs USE flag.
30 May 2011; Patrick McLean <chutzpah@gentoo.org> ntfs3g-2011.4.12.ebuild:
RDEPEND on net-libs/gnutls (bug #366701).
diff --git a/sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild b/sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild
index b45710a42906..aa540319a321 100644
--- a/sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild,v 1.2 2011/05/30 14:34:22 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2011.4.12.ebuild,v 1.3 2011/08/11 22:49:13 chutzpah Exp $
EAPI=2
inherit linux-info
@@ -15,7 +15,7 @@ SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
-IUSE="acl crypt debug ntfsprogs suid xattr +udev +external-fuse"
+IUSE="acl crypt debug ntfsprogs suid static-libs xattr +udev +external-fuse"
RDEPEND="external-fuse? ( >=sys-fs/fuse-2.8.0 )
ntfsprogs? ( !!sys-fs/ntfsprogs )
@@ -48,6 +48,7 @@ src_configure() {
$(use_enable crypt crypto) \
$(use_enable acl posix-acls) \
$(use_enable xattr xattr-mappings) \
+ $(use_enable static-libs static) \
$(use_enable debug)
}
@@ -62,6 +63,8 @@ src_install() {
insinto /etc/udev/rules.d/
doins "${FILESDIR}/99-ntfs3g.rules"
fi
+
+ find "${D}" -name '*.la' -delete
}
pkg_postinst() {