summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-11-16 08:05:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-11-16 08:05:01 +0000
commitfe9e37b3a63e977550dc1d557ab009336b54d992 (patch)
tree1b519e9f070dc8f42fe63a798801efd3ef914c19 /sys-fs
parentRemove old. (diff)
downloadgentoo-2-fe9e37b3a63e977550dc1d557ab009336b54d992.tar.gz
gentoo-2-fe9e37b3a63e977550dc1d557ab009336b54d992.tar.bz2
gentoo-2-fe9e37b3a63e977550dc1d557ab009336b54d992.zip
Convert nolvmstatic and nolvm1 USE flags to static and lvm1 USE flags via the base profile package.use. Finish merging clvm support. Provide a slightly better than stock default configuration that is more suited to Gentoo, and ignores network-block devices by default for the livecd environment.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/ChangeLog13
-rwxr-xr-xsys-fs/lvm2/files/clvmd.rc-2.02.28-r3126
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.28-r33
-rw-r--r--sys-fs/lvm2/files/lvm.conf-2.02.28-r3.patch79
-rw-r--r--sys-fs/lvm2/lvm2-2.02.28-r3.ebuild142
5 files changed, 362 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 7f920b093cb9..22ab80054444 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.119 2007/11/06 17:15:42 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.120 2007/11/16 08:05:01 robbat2 Exp $
+
+*lvm2-2.02.28-r3 (16 Nov 2007)
+
+ 16 Nov 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/clvmd.rc-2.02.28-r3, +files/lvm.conf-2.02.28-r3.patch,
+ +lvm2-2.02.28-r3.ebuild:
+ Convert nolvmstatic and nolvm1 USE flags to static and lvm1 USE flags via
+ the base profile package.use. Finish merging clvm support. Provide a
+ slightly better than stock default configuration that is more suited to
+ Gentoo, and ignores network-block devices by default for the livecd
+ environment.
06 Nov 2007; Markus Rothe <corsair@gentoo.org> lvm2-2.02.28-r2.ebuild:
Stable on ppc64; bug #195173
diff --git a/sys-fs/lvm2/files/clvmd.rc-2.02.28-r3 b/sys-fs/lvm2/files/clvmd.rc-2.02.28-r3
new file mode 100755
index 000000000000..80cfdb1b12bf
--- /dev/null
+++ b/sys-fs/lvm2/files/clvmd.rc-2.02.28-r3
@@ -0,0 +1,126 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/files/clvmd.rc-2.02.28-r3,v 1.1 2007/11/16 08:05:01 robbat2 Exp $
+
+depend() {
+ use dns logger
+ use net
+ need cluster-manager cluster-locking-manager fenced
+}
+
+exefile=/sbin/clvmd
+
+umount_gfs_filesystems() {
+ local sig retry
+ local remaining="$(awk '$3 == "gfs" { print $2 }' /proc/mounts | sort -r)"
+
+ if [ -n "${remaining}" ]
+ then
+ sig=
+ retry=3
+ while [ -n "${remaining}" -a "${retry}" -gt 0 ]
+ do
+ if [ "${retry}" -lt 3 ]
+ then
+ ebegin "Unmounting GFS filesystems (retry)"
+ umount ${remaining} &>/dev/null
+ eend $? "Failed to unmount GFS filesystems this retry"
+ else
+ ebegin "Unmounting GFS filesystems"
+ umount ${remaining} &>/dev/null
+ eend $? "Failed to unmount GFS filesystems"
+ fi
+ remaining="$(awk '$3 == "gfs" { print $2 }' /proc/mounts | sort -r)"
+ [ -z "${remaining}" ] && break
+ /bin/fuser -k -m ${sig} ${remaining} &>/dev/null
+ sleep 5
+ retry=$((${retry} -1))
+ sig=-9
+ done
+ fi
+}
+
+
+
+start() {
+ if [ -e /proc/modules -a ! -e /dev/device-mapper ] ; then
+ ebegin "Loading device-mapper module"
+ modprobe -q dm-mod
+ eend $?
+ fi
+ if [ ! -e /dev/device-mapper ]; then
+ eerror "device-mapper not available!"
+ exit 1
+ fi
+
+ ebegin "Starting clvmd"
+ start-stop-daemon --start --quiet --exec ${exefile}
+ rc=$?
+ eend $rc
+
+ ebegin "Scanning LVM volumes"
+ /sbin/vgscan &>/dev/null
+ rc=$?
+ eend $rc
+
+ if [ "$rc" -eq 0 ] && [ -x /sbin/vgchange ] && [ -d /etc/lvm ]
+ then
+ ebegin "Setting up the Logical Volume Manager"
+ /sbin/vgchange -aly >/dev/null
+ eend $? "Failed to setup the LVM"
+ fi
+
+}
+
+stop() {
+ # umount GFS filesystems
+ umount_gfs_filesystems
+
+ # This sucks majorly. We need to find a way to only take out the CLUSTER
+ # VGs and LVs, and never the local ones.
+ einfo "Shutting down the Logical Volume Manager"
+
+ LOGICAL_VOLUMES=`lvdisplay |grep "LV Name"|awk '{print $3}'|sort|xargs echo`
+ VOLUME_GROUPS=`vgdisplay |grep "VG Name"|awk '{print $3}'|sort|xargs echo`
+ for x in ${LOGICAL_VOLUMES}
+ do
+ LV_IS_ACTIVE=`lvdisplay ${x}|grep "# open"|awk '{print $3}'`
+ if [ "${LV_IS_ACTIVE}" = 0 ]
+ then
+ ebegin " Shutting Down logical volume: ${x} "
+ lvchange -an --ignorelockingfailure -P ${x} >/dev/null
+ eend $?
+ fi
+ done
+
+ for x in ${VOLUME_GROUPS}
+ do
+ VG_HAS_ACTIVE_LV=`vgdisplay ${x}|grep "Open LV"|awk '{print $3}'|xargs echo`
+ if [ "${VG_HAS_ACTIVE_LV}" = 0 ]
+ then
+ ebegin " Shutting Down volume group: ${x} "
+ vgchange -an --ignorelockingfailure -P ${x} >/dev/null
+ eend
+ fi
+ done
+
+ for x in ${LOGICAL_VOLUMES}
+ do
+ LV_IS_ACTIVE=`lvdisplay ${x}|grep "# open"|awk '{print $3}'`
+ if [ "${LV_IS_ACTIVE}" = 1 ]
+ then
+
+ ROOT_DEVICE=`mount|grep " / "|awk '{print $1}'`
+ if [ ! ${ROOT_DEVICE} = ${x} ]
+ then
+ ewarn " Unable to shutdown: ${x} "
+ fi
+ fi
+ done
+ einfo "Finished Shutting down the Logical Volume Manager"
+
+ ebegin "Stopping clvmd"
+ start-stop-daemon --stop --quiet --exec ${exefile}
+ eend $?
+}
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.28-r3 b/sys-fs/lvm2/files/digest-lvm2-2.02.28-r3
new file mode 100644
index 000000000000..920c6a9cc962
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.28-r3
@@ -0,0 +1,3 @@
+MD5 940a882a71cae84f6befc8069a260ad1 LVM2.2.02.28.tgz 531905
+RMD160 bf6f25db6e34bf362353ae9557691a7f01962502 LVM2.2.02.28.tgz 531905
+SHA256 2d8d7b123e427d0bfb7471d7c17dfd88890eb98257ca22ea3be5d7307e83aceb LVM2.2.02.28.tgz 531905
diff --git a/sys-fs/lvm2/files/lvm.conf-2.02.28-r3.patch b/sys-fs/lvm2/files/lvm.conf-2.02.28-r3.patch
new file mode 100644
index 000000000000..f7e4a346e930
--- /dev/null
+++ b/sys-fs/lvm2/files/lvm.conf-2.02.28-r3.patch
@@ -0,0 +1,79 @@
+diff -Nuar LVM2.2.02.28/doc/example.conf LVM2.2.02.28.new/doc/example.conf
+--- LVM2.2.02.28/doc/example.conf 2007-04-26 09:44:57.000000000 -0700
++++ LVM2.2.02.28.new/doc/example.conf 2007-11-15 23:09:53.844322792 -0800
+@@ -49,7 +49,9 @@
+
+
+ # By default we accept every block device:
+- filter = [ "a/.*/" ]
++ # Gentoo: we exclude /dev/nbd by default, because it makes a lot of kernel
++ # noise when you probed while not available.
++ filter = [ "r|/dev/nbd.*|", "a/.*/" ]
+
+ # Exclude the cdrom drive
+ # filter = [ "r|/dev/cdrom|" ]
+@@ -85,7 +87,7 @@
+ # If sysfs is mounted (2.6 kernels) restrict device scanning to
+ # the block devices it believes are valid.
+ # 1 enables; 0 disables.
+- sysfs_scan = 1
++ sysfs_scan = 1
+
+ # By default, LVM2 will ignore devices used as components of
+ # software RAID (md) devices by looking for md superblocks.
+@@ -218,12 +220,14 @@
+ # e.g. vgscan.lvm1 and they will stop working after you start using
+ # the new lvm2 on-disk metadata format.
+ # The default value is set when the tools are built.
+- # fallback_to_lvm1 = 0
++ # Gentoo: the LVM tools are a seperate package.
++ fallback_to_lvm1 = 0
+
+ # The default metadata format that commands should use - "lvm1" or "lvm2".
+ # The command line override is -M1 or -M2.
+ # Defaults to "lvm1" if compiled in, else "lvm2".
+- # format = "lvm1"
++ # Gentoo: default to LVM2 format
++ format = "lvm2"
+
+ # Location of proc filesystem
+ proc = "/proc"
+@@ -344,12 +348,12 @@
+
+ # Metadata settings
+ #
+-# metadata {
++metadata {
+ # Default number of copies of metadata to hold on each PV. 0, 1 or 2.
+ # You might want to override it from the command line with 0
+ # when running pvcreate on new PVs which are to be added to large VGs.
+-
+- # pvmetadatacopies = 1
++ # Gentoo: enabled for data safety
++ pvmetadatacopies = 2
+
+ # Approximate default size of on-disk metadata areas in sectors.
+ # You should increase this if you have large volume groups or
+@@ -371,17 +375,17 @@
+ # the supplied toolset to make changes (e.g. vgcfgrestore).
+
+ # dirs = [ "/etc/lvm/metadata", "/mnt/disk2/lvm/metadata2" ]
+-#}
++}
+
+ # Event daemon
+-#
+-# dmeventd {
++# Gentoo: uncommented, since we provide the dmeventd init script
++dmeventd {
+ # mirror_library is the library used when monitoring a mirror device.
+ #
+ # "libdevmapper-event-lvm2mirror.so" attempts to recover from failures.
+ # It removes failed devices from a volume group and reconfigures a
+ # mirror as necessary.
+ #
+- # mirror_library = "libdevmapper-event-lvm2mirror.so"
+-#}
++ mirror_library = "libdevmapper-event-lvm2mirror.so"
++}
+
diff --git a/sys-fs/lvm2/lvm2-2.02.28-r3.ebuild b/sys-fs/lvm2/lvm2-2.02.28-r3.ebuild
new file mode 100644
index 000000000000..0b3586ae557c
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.28-r3.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.28-r3.ebuild,v 1.1 2007/11/16 08:05:01 robbat2 Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="readline static clvm cman gulm lvm1 selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.22-r5
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+pkg_setup() {
+ use nolvmstatic && eerror "USE=nolvmstatic has changed to USE=static via package.use"
+ use nolvm1 && eerror "USE=nolvm1 has changed to USE=lvm1 via package.use"
+}
+
+src_unpack() {
+ unpack ${A}
+ #cd "${S}" || die
+ #epatch "${FILESDIR}"/lvm2-2.02.04-vgid.patch
+ epatch "${FILESDIR}"/lvm.conf-2.02.28-r3.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+ local buildmode
+
+ # fsadm is broken, don't include it (2.02.28)
+ myconf="${myconf} --enable-dmeventd --enable-cmdlib"
+
+ # Most of this package does weird stuff.
+ # The build options are tristate, and --without is NOT supported
+ # options: 'none', 'internal', 'shared'
+ if use static ; then
+ einfo "Building static LVM, for usage inside genkernel"
+ myconf="${myconf} --enable-static_link"
+ buildmode="internal"
+ else
+ ewarn "Building shared LVM, it will not work inside genkernel!"
+ buildmode="shared"
+ fi
+
+ # dmeventd requires mirrors to be internal, and snapshot available
+ # so we cannot disable them
+ myconf="${myconf} --with-mirrors=internal"
+ myconf="${myconf} --with-snapshots=${buildmode}"
+
+ if use lvm1 ; then
+ myconf="${myconf} --with-lvm1=${buildmode}"
+ else
+ myconf="${myconf} --with-lvm1=none"
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ myconf="${myconf} --with-cluster=${buildmode}"
+ # 4-state!
+ local clvmd="none"
+ use cman && clvmd="cman"
+ use gulm && clvmd="${clvmd}gulm"
+ clvmd="${clvmd/cmangulm/all}"
+ myconf="${myconf} --with-clvmd=${clvmd}"
+ myconf="${myconf} --with-pool=${buildmode}"
+ else
+ myconf="${myconf} --with-clvmd=none --with-cluster=none"
+ fi
+
+ myconf="${myconf} --sbindir=/sbin --with-staticdir=/sbin"
+ econf $(use_enable readline) \
+ $(use_enable selinux) \
+ --libdir=/usr/$(get_libdir) \
+ ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # TODO: At some point in the future, we need to stop installing the static
+ # as the /sbin/lvm name, and have both variants seperate.
+ if use static; then
+ cp -f "${D}"/sbin/lvm.static "${D}"/sbin/lvm \
+ || die "Failed to copy lvm.static"
+ fi
+
+ dodir /$(get_libdir)
+ # Put these in root so we can reach before /usr is up
+ for i in libdevmapper-event-lvm2mirror liblvm2{format1,snapshot} ; do
+ b="${D}"/usr/$(get_libdir)/${i}
+ if [ -f "${b}".so ]; then
+ mv -f "${b}".so* "${D}"/$(get_libdir) || die
+ fi
+ done
+
+ dodoc README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/lvm2-start.sh-2.02.28-r2 lvm-start.sh || die
+ newins "${FILESDIR}"/lvm2-stop.sh lvm-stop.sh || die
+ newinitd "${FILESDIR}"/lvm.rc-2.02.28-r2 lvm || die
+ newconfd "${FILESDIR}"/lvm.confd-2.02.28-r2 lvm || die
+ if use clvm; then
+ newinitd "${FILESDIR}"/clvmd.rc-2.02.28-r3 clvmd || die
+ fi
+
+ elog "use flag nocman is deprecated and replaced"
+ elog "with cman and gulm use flags."
+ elog ""
+ elog "use flags clvm,cman and gulm are masked"
+ elog "by default and need to be unmasked to use them"
+ elog ""
+ elog "Rebuild your genkernel initramfs if you are using lvm"
+ use nolvmstatic && \
+ elog "USE=nolvmstatic has changed to USE=static via package.use"
+ use nolvm1 && \
+ elog "USE=nolvm1 has changed to USE=lvm1 via package.use"
+}
+
+pkg_postinst() {
+ elog "lvm volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add lvm boot"
+}