summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2006-07-09 23:32:22 +0000
committerMichael Marineau <marineam@gentoo.org>2006-07-09 23:32:22 +0000
commit30df367b294c71961ce49512a1ad0911e7814214 (patch)
tree56c3ecf3ca83830a72209f7519b98e8455f40285 /sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild
parentremoved ewarn from pkg_postinst (bug 139761) (diff)
downloadgentoo-2-30df367b294c71961ce49512a1ad0911e7814214.tar.gz
gentoo-2-30df367b294c71961ce49512a1ad0911e7814214.tar.bz2
gentoo-2-30df367b294c71961ce49512a1ad0911e7814214.zip
Security version bumps
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild
new file mode 100644
index 000000000000..ec8a03ffa583
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.17_p1-r1.ebuild,v 1.1 2006/07/09 23:32:22 marineam Exp $
+
+DESCRIPTION="Full sources for the Linux kernel with Con Kolivas' high performance patchset and Gentoo's basic patchset."
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/kernel/"
+IUSE="ck-server"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+K_NOUSENAME="yes"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="3"
+ETYPE="sources"
+inherit kernel-2
+
+detect_version
+# A few hacks to set ck version via _p instead of -r
+MY_PR=${PR/r/-r}
+MY_PR=${MY_PR/-r0/}
+EXTRAVERSION=-ck${PV/*_p/}${MY_PR}
+KV_FULL=${OKV}${EXTRAVERSION}
+KV_CK=${KV_FULL/-r*/}
+
+if use ck-server; then
+ UNIPATCH_LIST="${DISTDIR}/patch-${KV_CK/ck/cks}.bz2"
+else
+ UNIPATCH_LIST="${DISTDIR}/patch-${KV_CK}.bz2"
+fi
+
+# Note: 2.6.x.y updates in genpatches begin with 10 but are included in -ck
+# new order of patches means some additional excludes.
+#UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 10"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI}
+ ck-server? (
+ mirror://kernel/linux/kernel/people/ck/patches/cks/patch-${KV_CK/ck/cks}.bz2
+ )
+ !ck-server? (
+ mirror://kernel/linux/kernel/people/ck/patches/2.6/${OKV}/${KV_CK}/patch-${KV_CK}.bz2 )"
+
+
+pkg_postinst() {
+ postinst_sources
+
+ einfo "The ck patchset is tuned for desktop usage."
+ einfo "To better tune the kernel for server applications add"
+ einfo "ck-server to your use flags and reemerge ck-sources"
+}