summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-01-30 20:26:58 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-01-30 20:26:58 +0000
commitffda199d409edda27fa256529fce11d75c255439 (patch)
tree2d66ead862aa8674ad28c6e22d30ba4519fcbc07 /sys-kernel/ck-sources/ck-sources-3.2.1.ebuild
parentVersion bump, release tracker bug #401555, I screwed up 0.9.8.3 and it was id... (diff)
downloadgentoo-2-ffda199d409edda27fa256529fce11d75c255439.tar.gz
gentoo-2-ffda199d409edda27fa256529fce11d75c255439.tar.bz2
gentoo-2-ffda199d409edda27fa256529fce11d75c255439.zip
Add proper 3.2.1, remove incorrectly versioned 3.2.2.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-3.2.1.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-3.2.1.ebuild b/sys-kernel/ck-sources/ck-sources-3.2.1.ebuild
new file mode 100644
index 000000000000..ab3cfc080029
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.2.1.ebuild,v 1.1 2012/01/30 20:26:58 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="5"
+K_SECURITY_UNSUPPORTED="1"
+
+inherit kernel-2 versionator
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+BASE_VERSION="$(get_version_component_range 1-2)"
+CK_VERSION="1"
+
+CK_URI="http://ck.kolivas.org/patches/3.0/${BASE_VERSION}/${BASE_VERSION}-ck${CK_VERSION}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}