summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-11-24 07:46:32 +0000
committerYixun Lan <dlan@gentoo.org>2014-11-24 07:46:32 +0000
commit4e0a46178d6ea533409a2e98ab5c4f180c5d8721 (patch)
tree40ea75d7d27848309b492b3dddeeed35531368d8 /sys-kernel/ck-sources
parentsci-libs/profphd-utils: Install in /usr instead of / (diff)
downloadgentoo-2-4e0a46178d6ea533409a2e98ab5c4f180c5d8721.tar.gz
gentoo-2-4e0a46178d6ea533409a2e98ab5c4f180c5d8721.tar.bz2
gentoo-2-4e0a46178d6ea533409a2e98ab5c4f180c5d8721.zip
version bump, proxy for Harold Naparst
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog9
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.10.61.ebuild107
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.17.4.ebuild (renamed from sys-kernel/ck-sources/ck-sources-3.10.39.ebuild)10
-rw-r--r--sys-kernel/ck-sources/metadata.xml10
4 files changed, 126 insertions, 10 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index c5e6a660bf10..735dda2d02da 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.239 2014/11/21 07:21:37 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.240 2014/11/24 07:46:32 dlan Exp $
+
+*ck-sources-3.17.4 (24 Nov 2014)
+*ck-sources-3.10.61 (24 Nov 2014)
+
+ 24 Nov 2014; Yixun Lan <dlan@gentoo.org> -ck-sources-3.10.39.ebuild,
+ +ck-sources-3.10.61.ebuild, +ck-sources-3.17.4.ebuild, metadata.xml:
+ version bump, proxy for Harold Naparst
*ck-sources-3.14.24 (21 Nov 2014)
*ck-sources-3.12.32 (21 Nov 2014)
diff --git a/sys-kernel/ck-sources/ck-sources-3.10.61.ebuild b/sys-kernel/ck-sources/ck-sources-3.10.61.ebuild
new file mode 100644
index 000000000000..492db9338eae
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.10.61.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.10.61.ebuild,v 1.1 2014/11/24 07:46:32 dlan Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+IUSE="bfsonly"
+
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_EXP_GENPATCHES_PULL="1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_GENPATCHES_VER="68"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with Con Kolivas' high performance patchset and Gentoo's genpatches"
+
+#-- If Gentoo-Sources don't follow then extra incremental patches are needed -
+
+XTRA_INCP_MIN=""
+XTRA_INCP_MAX=""
+
+#--
+
+CK_VERSION="1"
+BFS_VERSION="440"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}-r1.bz2"
+BFS_FILE="${K_BRANCH_ID}-sched-bfs-${BFS_VERSION}-r1.patch"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/3.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="http://dev.gentoo.org/~dlan/distfiles/${CK_FILE}
+ ${CK_LVER_URL}/${CK_FILE}"
+BFS_URI="http://dev.gentoo.org/~dlan/distfiles/${BFS_FILE}
+ ${CK_LVER_URL}/patches/${BFS_FILE}"
+
+#-- Build extra incremental patches list --------------------------------------
+
+LX_INCP_URI=""
+LX_INCP_LIST=""
+if [ -n "${XTRA_INCP_MIN}" ]; then
+ LX_INCP_URL="${KERNEL_BASE_URI}/incr"
+ for i in `seq ${XTRA_INCP_MIN} ${XTRA_INCP_MAX}`; do
+ LX_INCP[i]="patch-${K_BRANCH_ID}.${i}-$(($i+1)).bz2"
+ LX_INCP_URI="${LX_INCP_URI} ${LX_INCP_URL}/${LX_INCP[i]}"
+ LX_INCP_LIST="${LX_INCP_LIST} ${DISTDIR}/${LX_INCP[i]}"
+ done
+fi
+
+#-- CK needs sometimes to patch itself... (3.7)--------------------------------
+
+CK_INCP_URI=""
+CK_INCP_LIST=""
+
+#-- Local patches needed for the ck-patches to apply smoothly (3.4/3.5) -------
+
+PRE_CK_FIX=""
+POST_CK_FIX=""
+
+#--
+
+SRC_URI="${KERNEL_URI} ${LX_INCP_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_INCP_URI}
+ !bfsonly? ( ${CK_URI} )
+ bfsonly? ( ${BFS_URI} )"
+
+UNIPATCH_LIST="${LX_INCP_LIST} ${PRE_CK_FIX} ${DISTDIR}"
+
+if ! use bfsonly ; then
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${CK_FILE}"
+else
+ UNIPATCH_LIST="${UNIPATCH_LIST}/${BFS_FILE}"
+fi
+
+UNIPATCH_LIST="${UNIPATCH_LIST} ${CK_INCP_LIST} ${POST_CK_FIX}"
+
+UNIPATCH_STRICTORDER="yes"
+
+#-- Since experimental genpatches && we want BFQ irrespective of experimental -
+
+K_EXP_GENPATCHES_LIST="50*_*.patch*"
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+
+ kernel-2_pkg_postinst
+
+ elog
+ elog "For more info on this patchset, see: http://forums.gentoo.org/viewtopic-t-941030-start-0.html"
+ elog
+}
diff --git a/sys-kernel/ck-sources/ck-sources-3.10.39.ebuild b/sys-kernel/ck-sources/ck-sources-3.17.4.ebuild
index 0d4f9f1a7434..2b8226b28deb 100644
--- a/sys-kernel/ck-sources/ck-sources-3.10.39.ebuild
+++ b/sys-kernel/ck-sources/ck-sources-3.17.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.10.39.ebuild,v 1.1 2014/05/09 20:17:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.17.4.ebuild,v 1.1 2014/11/24 07:46:32 dlan Exp $
EAPI="5"
ETYPE="sources"
@@ -13,7 +13,7 @@ HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
K_WANT_GENPATCHES="base extras experimental"
K_EXP_GENPATCHES_PULL="1"
K_EXP_GENPATCHES_NOUSE="1"
-K_GENPATCHES_VER="46"
+K_GENPATCHES_VER="7"
K_SECURITY_UNSUPPORTED="1"
K_DEBLOB_AVAILABLE="1"
@@ -32,8 +32,8 @@ XTRA_INCP_MAX=""
#--
-CK_VERSION="1"
-BFS_VERSION="440"
+CK_VERSION="2"
+BFS_VERSION="458"
CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.bz2"
BFS_FILE="${K_BRANCH_ID}-sched-bfs-${BFS_VERSION}.patch"
@@ -56,7 +56,7 @@ if [ -n "${XTRA_INCP_MIN}" ]; then
done
fi
-#-- CK needs sometimes to patch itself... (3.7)--------------------------------
+#-- CK needs sometimes to patch itself... (3.7/3.13)---------------------------
CK_INCP_URI=""
CK_INCP_LIST=""
diff --git a/sys-kernel/ck-sources/metadata.xml b/sys-kernel/ck-sources/metadata.xml
index 591f0129de1d..eef03a69dc1f 100644
--- a/sys-kernel/ck-sources/metadata.xml
+++ b/sys-kernel/ck-sources/metadata.xml
@@ -3,12 +3,14 @@
<pkgmetadata>
<herd>proxy-maintainers</herd>
<maintainer>
- <email>eric-f.garioud@wanadoo.fr</email>
- <name>Eric F. GARIOUD</name>
- </maintainer>
- <maintainer>
<email>harold@alum.mit.edu</email>
<name>Harold Naparst</name>
+ <description>Active Maintainer, Assign bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>eric-f.garioud@wanadoo.fr</email>
+ <name>Eric F. GARIOUD</name>
+ <description>Previous Maintainer, CC bugs</description>
</maintainer>
<use>
<flag name='bfsonly'>BFS by itslef vs The full ck patchset</flag>