summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-06-30 17:42:56 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-06-30 17:42:56 +0000
commit544d1d93033ffa6ff2f9a9781e7ba61fcc44672f (patch)
tree3065c267c66e917210b63ec91bdb3ab6f52b6425 /sys-kernel/ck-sources
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-544d1d93033ffa6ff2f9a9781e7ba61fcc44672f.tar.gz
gentoo-2-544d1d93033ffa6ff2f9a9781e7ba61fcc44672f.tar.bz2
gentoo-2-544d1d93033ffa6ff2f9a9781e7ba61fcc44672f.zip
Added a patch for the IPTables RDoS vulnerability; bug #55694.
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog6
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild4
-rw-r--r--sys-kernel/ck-sources/files/ck-sources-2.6.IPTables-RDoS.patch11
3 files changed, 18 insertions, 3 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index e9dfd9861dce..fac44441f999 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.41 2004/06/26 12:15:29 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.42 2004/06/30 17:42:56 plasmaroo Exp $
+
+ 30 Jun 2004; <plasmaroo@gentoo.org> ck-sources-2.6.7-r2.ebuild,
+ +files/ck-sources-2.6.IPTables-RDoS.patch:
+ Added a patch for the IPTables RDoS vulnerability; bug #55694.
*ck-sources-2.6.7-r2 (26 Jun 2004)
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild
index be1583359cc7..61db341e4805 100644
--- a/sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild
+++ b/sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild,v 1.1 2004/06/26 12:15:29 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.7-r2.ebuild,v 1.2 2004/06/30 17:42:56 plasmaroo Exp $
-UNIPATCH_LIST="${DISTDIR}/patch-${KV}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${KV}.bz2 ${FILESDIR}/${PN}-2.6.IPTables-RDoS.patch"
K_PREPATCHED="yes"
UNIPATCH_STRICTORDER="yes"
diff --git a/sys-kernel/ck-sources/files/ck-sources-2.6.IPTables-RDoS.patch b/sys-kernel/ck-sources/files/ck-sources-2.6.IPTables-RDoS.patch
new file mode 100644
index 000000000000..8f89d1605c9a
--- /dev/null
+++ b/sys-kernel/ck-sources/files/ck-sources-2.6.IPTables-RDoS.patch
@@ -0,0 +1,11 @@
+--- net/ipv4/netfilter/ip_tables.c.orig 2004-04-04 05:36:47.000000000 +0200
++++ net/ipv4/netfilter/ip_tables.c 2004-06-24 21:24:26.000000000 +0200
+@@ -1461,7 +1461,7 @@
+ int *hotdrop)
+ {
+ /* tcp.doff is only 4 bits, ie. max 15 * 4 bytes */
+- char opt[60 - sizeof(struct tcphdr)];
++ u_int8_t opt[60 - sizeof(struct tcphdr)];
+ unsigned int i;
+
+ duprintf("tcp_match: finding option\n");