summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-08-19 13:28:02 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-08-19 13:28:02 +0000
commit6a8e308374089e4cc36fffa87e90b2fa7bf99e1a (patch)
tree9b9ef912947bbe2c7b4d454076befb3dffe724e9 /sys-kernel/ck-sources
parentVersion bump. (diff)
downloadgentoo-2-6a8e308374089e4cc36fffa87e90b2fa7bf99e1a.tar.gz
gentoo-2-6a8e308374089e4cc36fffa87e90b2fa7bf99e1a.tar.bz2
gentoo-2-6a8e308374089e4cc36fffa87e90b2fa7bf99e1a.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog9
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.35-r1.ebuild39
-rw-r--r--sys-kernel/ck-sources/ck-sources-2.6.35.ebuild39
3 files changed, 86 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 5165e59cfbe9..2c7efb436ceb 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.177 2010/08/03 17:18:34 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.178 2010/08/19 13:28:02 nelchael Exp $
+
+*ck-sources-2.6.35-r1 (19 Aug 2010)
+*ck-sources-2.6.35 (19 Aug 2010)
+
+ 19 Aug 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +ck-sources-2.6.35.ebuild, +ck-sources-2.6.35-r1.ebuild:
+ Version bump.
03 Aug 2010; Robin H. Johnson <robbat2@gentoo.org> Manifest:
kernel-2 deblob support for 2.6.35; bug #324505: deblob-check usage.
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.35-r1.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.35-r1.ebuild
new file mode 100644
index 000000000000..a4580e94f3e6
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.35-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.35-r1.ebuild,v 1.1 2010/08/19 13:28:02 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="2"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+K_SECURITY_UNSUPPORTED="1"
+
+CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/ck-sources/ck-sources-2.6.35.ebuild b/sys-kernel/ck-sources/ck-sources-2.6.35.ebuild
new file mode 100644
index 000000000000..c25b6fc7309d
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-2.6.35.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-2.6.35.ebuild,v 1.1 2010/08/19 13:28:02 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://www.kernel.org/pub/linux/kernel/people/ck/patches/2.6/"
+
+CK_VERSION="1"
+K_SECURITY_UNSUPPORTED="1"
+
+CK_URI="mirror://kernel/linux/kernel/people/ck/patches/2.6/${PV}/${PV}-ck${CK_VERSION}/patch-${PV}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/patch-${PV}-ck${CK_VERSION}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}