summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-02-19 16:25:48 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-02-19 16:25:48 +0000
commitd1396a6efe8a7866bd87f5aeef4cdce74588d8dc (patch)
treeca3a0def3dd31b5c9a77d92b43f1cf9abeabaf0d /sys-kernel/ck-sources
parentFix tests and add few more patches to play nicer wrt bug#294548. Stable 0.9.9... (diff)
downloadgentoo-2-d1396a6efe8a7866bd87f5aeef4cdce74588d8dc.tar.gz
gentoo-2-d1396a6efe8a7866bd87f5aeef4cdce74588d8dc.tar.bz2
gentoo-2-d1396a6efe8a7866bd87f5aeef4cdce74588d8dc.zip
Version bump.
(Portage version: 2.1.10.47/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ChangeLog7
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.2.6.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-kernel/ck-sources/ChangeLog b/sys-kernel/ck-sources/ChangeLog
index 45cf2b4430e6..74814cee7cdc 100644
--- a/sys-kernel/ck-sources/ChangeLog
+++ b/sys-kernel/ck-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/ck-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.203 2012/02/11 19:00:45 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ChangeLog,v 1.204 2012/02/19 16:25:48 nelchael Exp $
+
+*ck-sources-3.2.6 (19 Feb 2012)
+
+ 19 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org> +ck-sources-3.2.6.ebuild:
+ Version bump.
*ck-sources-3.2.5 (11 Feb 2012)
diff --git a/sys-kernel/ck-sources/ck-sources-3.2.6.ebuild b/sys-kernel/ck-sources/ck-sources-3.2.6.ebuild
new file mode 100644
index 000000000000..fe9f985e9ce5
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.2.6.ebuild,v 1.1 2012/02/19 16:25:48 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="9"
+K_SECURITY_UNSUPPORTED="1"
+
+inherit kernel-2 versionator
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+BASE_VERSION="$(get_version_component_range 1-2)"
+CK_VERSION="1"
+
+CK_URI="http://ck.kolivas.org/patches/3.0/${BASE_VERSION}/${BASE_VERSION}-ck${CK_VERSION}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}