summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-04 17:16:28 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-04 17:16:28 +0000
commitb374271278a87378119ec06134373ede538b1731 (patch)
tree9e2e6620abca09e0025f0d0f6f081d92eb2d4e70 /sys-kernel/development-sources
parentclean out cruft and bump (diff)
downloadgentoo-2-b374271278a87378119ec06134373ede538b1731.tar.gz
gentoo-2-b374271278a87378119ec06134373ede538b1731.tar.bz2
gentoo-2-b374271278a87378119ec06134373ede538b1731.zip
clean up
Diffstat (limited to 'sys-kernel/development-sources')
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.50.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.51.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.52.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.53.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.54.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.55.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.56.ebuild102
-rw-r--r--sys-kernel/development-sources/development-sources-2.5.57.ebuild102
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.501
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.511
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.521
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.531
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.541
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.551
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.561
-rw-r--r--sys-kernel/development-sources/files/digest-development-sources-2.5.571
16 files changed, 0 insertions, 824 deletions
diff --git a/sys-kernel/development-sources/development-sources-2.5.50.ebuild b/sys-kernel/development-sources/development-sources-2.5.50.ebuild
deleted file mode 100644
index fd360ca44bd0..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.50.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.50.ebuild,v 1.2 2002/12/18 00:12:48 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.51.ebuild b/sys-kernel/development-sources/development-sources-2.5.51.ebuild
deleted file mode 100644
index b21ff11b5893..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.51.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.51.ebuild,v 1.2 2002/12/18 00:12:48 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.52.ebuild b/sys-kernel/development-sources/development-sources-2.5.52.ebuild
deleted file mode 100644
index 3e1f8bb226ce..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.52.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.52.ebuild,v 1.2 2002/12/18 00:12:48 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.53.ebuild b/sys-kernel/development-sources/development-sources-2.5.53.ebuild
deleted file mode 100644
index c166dd22e4fa..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.53.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.53.ebuild,v 1.1 2002/12/24 07:51:21 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.54.ebuild b/sys-kernel/development-sources/development-sources-2.5.54.ebuild
deleted file mode 100644
index 550bec40b5fc..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.54.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.54.ebuild,v 1.1 2003/01/02 07:49:51 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.55.ebuild b/sys-kernel/development-sources/development-sources-2.5.55.ebuild
deleted file mode 100644
index 17c6f2f56dc0..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.55.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.55.ebuild,v 1.1 2003/01/09 04:54:59 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.56.ebuild b/sys-kernel/development-sources/development-sources-2.5.56.ebuild
deleted file mode 100644
index 408623599cf9..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.56.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.56.ebuild,v 1.1 2003/01/10 21:12:56 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/development-sources-2.5.57.ebuild b/sys-kernel/development-sources/development-sources-2.5.57.ebuild
deleted file mode 100644
index a8769d0387f3..000000000000
--- a/sys-kernel/development-sources/development-sources-2.5.57.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/development-sources/development-sources-2.5.57.ebuild,v 1.1 2003/01/14 00:10:35 lostlogic Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${PV}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# beta 2.5.36 kernel sources
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="x86 ppc"
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-# mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
-# make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
-# cd ${S}
-# mv Makefile Makefile.orig
-# sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
-# Makefile.orig >Makefile || die # test, remove me if Makefile ok
-# rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux-beta ]
- then
-
- ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
- fi
-}
-
-
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.50 b/sys-kernel/development-sources/files/digest-development-sources-2.5.50
deleted file mode 100644
index b2458d542aa8..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.50
+++ /dev/null
@@ -1 +0,0 @@
-MD5 29efe7ab8b0b919f31c38c4ae3b764c7 linux-2.5.50.tar.bz2 31189888
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.51 b/sys-kernel/development-sources/files/digest-development-sources-2.5.51
deleted file mode 100644
index 5315912120c7..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.51
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2300b7b7d2ce4c017fe6dae49717fd9a linux-2.5.51.tar.bz2 31126764
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.52 b/sys-kernel/development-sources/files/digest-development-sources-2.5.52
deleted file mode 100644
index 090a08388c34..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.52
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8d69fc81b029ec7f19ee6080929d1fe8 linux-2.5.52.tar.bz2 31173836
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.53 b/sys-kernel/development-sources/files/digest-development-sources-2.5.53
deleted file mode 100644
index 86e78406c666..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.53
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e1da8dbda1a51e05c2eaf3d26c0ebacd linux-2.5.53.tar.bz2 31457681
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.54 b/sys-kernel/development-sources/files/digest-development-sources-2.5.54
deleted file mode 100644
index 9d7c0e1aefbb..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.54
+++ /dev/null
@@ -1 +0,0 @@
-MD5 13d1fcc77b9245b09f2317e277c99cdc linux-2.5.54.tar.bz2 31556230
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.55 b/sys-kernel/development-sources/files/digest-development-sources-2.5.55
deleted file mode 100644
index 0592123d54ad..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.55
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b588bd723c595bec509caf30a2d64867 linux-2.5.55.tar.bz2 31509109
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.56 b/sys-kernel/development-sources/files/digest-development-sources-2.5.56
deleted file mode 100644
index 95f538a32c2a..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.56
+++ /dev/null
@@ -1 +0,0 @@
-MD5 21c4dc7ef27395097edc8eb5ff47bbd7 linux-2.5.56.tar.bz2 31562012
diff --git a/sys-kernel/development-sources/files/digest-development-sources-2.5.57 b/sys-kernel/development-sources/files/digest-development-sources-2.5.57
deleted file mode 100644
index 370053ba54e9..000000000000
--- a/sys-kernel/development-sources/files/digest-development-sources-2.5.57
+++ /dev/null
@@ -1 +0,0 @@
-MD5 ea388e66e9e5ba373c7070e73cd9b19e linux-2.5.57.tar.bz2 31483124